OVH Community, votre nouvel espace communautaire.

Ligne SIP : le correspondant ne m'entend pas


PierrYves L
20/05/2015, 12h54
Bonjour,

Je vous remercie pour votre retour.

Pouvez-vous me confirmer que les pré-requis réseaux soit bien respectés (ouvertures des ports UDP et ouverture de la plage de ports RTP 30000 à 40000).

Pouvez-vous faire un test en désactivant le pare-feu de votre modem, et brancher votre équipement directement sur celui-ci?

Bien cordialement,
PierrYves L.

Feasir
19/05/2015, 12h05
Effectivement, je ne vérifiais pas l'IP publique lorsque je passais par Assistance / Dépannage Plug&Phone, et celle-ci était incorrecte. J'ai fait le test en spécifiant la bonne IP, mais sans plus de résultats. :-(

PierrYves L
18/05/2015, 12h06
Bonjour Feasir,

Je ne retrouve aucune tentative de connexion de ta ligne depuis le 14/05/2015. Pouvez-vous m'indiquer si votre adresse IP publique est toujours la même qu'à cette date? (xx.xxx.xx.229)

Si celle-ci a été modifié, il faut bien spécifier la nouvelle adresse lors d'un dépannage plug&phone depuis votre espace client.

Je vous inviterais ensuite à vérifier que la plage de ports RTP 3000 à 40000 soient bien ouverts sur votre réseau (ports utiliser pour faire transiter la voix).

Bien cordialement,
PierrYves L.

Feasir
16/05/2015, 18h11
J'ai voulu profiter du WE pour refaire le test sans firewall : résultat, depuis que j'ai rebooté mon routeur, le téléphone est de nouveau bloqué en "registration failed". C'est pas un peu trop sensible ces bêtes là ?!

Gaston_Phone
13/05/2015, 20h59
@ Feasir, cela fait 10 jours que tu as ton problème et cela n'a pas l'air de s'arranger.

Tu devrais prendre pour 1 mois une ligne SIP sans matériel et faire un test avec Zoiper sur ton PC ou ton Smartphone (Android ou Ipad, iphone).

Feasir
13/05/2015, 14h20
Bon, retour à la case départ :
- ligne enregistrée et active (après un nouveau reset+autoconfig)
- mais toujours pas d'audio chez mon correspondant
Indice supplémentaire : la messagerie fonctionne partiellement, à savoir que l'appui sur les touches ne fonctionne pas, bien que le DTMF soit activé (à rapprocher du "pas d'audio chez mon correspondant")

Du coup je vais pouvoir réessayer de couper le firewall et rebooter le routeur.

Gaston_Phone
12/05/2015, 20h32
Citation Envoyé par PierrYves L
Je parviens bien à enregistrer votre ligne sur softphone..
Avec ZOIPER ?

PierrYves L
12/05/2015, 18h23
Bonjour,

Je viens de vérifier en interne, je ne retrouve aucune tentative de connexion sur nos serveurs de votre ligne depuis le 08/05/2015.

Je viens donc de faire une vérification en interne pour vérifier si celle-ci est bien fonctionnelle. Je parviens bien à enregistrer votre ligne sur softphone.

Je vous inviterais donc à vérifier les prérequis réseaux et à procéder au ré-enregistrement de votre ligne en effectuant un dépannage plug&phone depuis votre espace client. Je tiens à attirer votre attention sur votre adresse IP publique sur laquelle les requêtes d'enregistrement sont envoyés.

Bien cordialement,
PierrYves L.

Feasir
12/05/2015, 09h31
Bon, j'ai voulu repartir d'une config propre pour avoir une base saine, j'ai fait un reset du C610 + une autoconfiguration, et là catastrophe => je reste désespérément bloqué sur l'erreur "registration failed".

abds69
07/05/2015, 08h57
Clairement ton routeur a activé une function qui fait merder la VOIP.

Quand tu as désactivé le firewall, tu as rebooté la bête et le telephone ?
Sinon fais le. Ensuite verifies si Aiprotection est actif aussi, désactive le et reboot (en clair tout type de SPI ou DPI, ie inspection des packets).

Comme le telephone est provisionné, tu n'y touche pas, par contre regarde sur le manager ovh , dans telephone , informations generales, les ports ouverts et l'adresse IP publique privée, spécifiée.

A+

Feasir
06/05/2015, 23h13
Session UDP vérifié, déjà configuré sur :
- UDP Timeout: Assured 180
- UDP Timeout: Unreplied 30
SIP ALG désactivé (il était actif) : ça ne change rien, toujours pas de son chez mon correspondant
Le statut actuel est :
- PPTP Passthrough : enabled
- L2TP Passthrough : enabled
- IPSec Passthrough : disabled
- RTSP Passthrough : disabled
- H.323 Passthrough : disabled
- SIP Passthrough : disabled
- Enable PPPoE Relay : disabled
Firewall désactivé : aucun changement (je l'ai réactivé du coup)
Port 5080 ajouté (j'avais le 5180 ?), ce qui me fait maintenant :
ALL TCP 30000:40000 192.168.1.38 30000:40000 VSERVER
ALL UDP 30000:40000 192.168.1.38 30000:40000 VSERVER
ALL TCP 5060 192.168.1.38 5060 VSERVER
ALL UDP 5060 192.168.1.38 5060 VSERVER
ALL TCP 5962 192.168.1.38 5962 VSERVER
ALL UDP 5962 192.168.1.38 5962 VSERVER
ALL TCP 5080 192.168.1.38 5080 VSERVER
ALL UDP 5080 192.168.1.38 5080 VSERVER

Un point que j'ai oublié de préciser : je ne peux plus joindre ma messagerie vocale, je n'ai ni tonalité ni message, rien.

PierrYves L
06/05/2015, 16h21
Bonjour à tous,

La ligne de Feasir est bien associée à un téléphone fourni par nos services. C'est à dire qu'il y a un auto provisionning sur celui-ci. Je confirme donc l'utilisation des ports UDP 5060 et 5962.

Pour la désactivation du SIP ALG ainsi que le réglages des durée de vie des sessions UDP supérieur à 180s que nous conseillons sur le routeur, je peux vous inviter à vous rapprocher de votre FAI afin de procéder à cette manipulation.

Bien cordialement,
PierrYves L.

abds69
06/05/2015, 14h57
Ok comme tu as une ligne individuelle, il n' ya pas de provisioning donc ton telephone n'a pas la configuration forcée par OVH.
Les ports du telephone peuvent être autre que 5060 ou 30000, etc..., le codec dans le telephone autre que celui mis dans le manager...mais en config usine ça devrait marcher direct !!

Le SIP ALG réécrit les packets SIP, si routeur autre que cisco, désactiver cette merde, par contre chez toi tu risque de pas trouver l'option , jettes un oeil sur ce qui suit. Jettes un oeil sur advanced WAN pour l'option NAT pass trough, sinon telnet mon gars !!
Le dernier firmware a du activer cette option, good luck !!

Asus RT-AC66U devices with their most current firmware enables their SIP ALG by default. THERE IS NO GUI OPTION TO DISABLE IT

So as to add to your knowledge base, I thought I'd share the solution:
To disable the SIP ALG manually, you enable telnet to the device via the WWW interface
Telnet to the device (from a command line enter "telnet 192.168.1.1" or the appropriate IP address for the device.)

Issue the following commands:
nvram get nf_sip


(It should return a "1")
nvram set nf_sip=0
nvram commit


Reboot
Voilà

Then reboot the router for the changes to take effect.

Under firmware 3.0.0.4.374_257 SIP ALG is located in (via the web interface):
1. Log into the router's web interface.
2. Go to Advanced Settings / WAN on left side.
3. From the tabs across the top, choose NAT Pass through.
4. Change SIP pass through to "Disable." Hit apply.

For phones to pick up the change immediately, reboot each of them, otherwise they will pick up the new NAT table with changes during their next registration.

Feasir
06/05/2015, 10h42
Ah ! Plein de piste, super. :-)

Citation Envoyé par Gaston_Phone
5060 ou 5962
- - - Mise à jour - - -
Extrait de --> SIP - OVH - Mes interlocuteurs ne m’entendent pas
Je vais revérifier mais il me semble que ceux là sont bien ouverts (j'avais suivi le tuto cité justement).

Citation Envoyé par abds69
Faudrait remettre la LB et vérifier si ça marche correctement, dans ce cas c'est un paramètrage du routeur ASUS.
Sinon la config interne du c610 est à revérifier, entre autres le codec de l'appareil.
Avec l'asus, supprimer temporairement le firewall et tester.
Par experience les C610 marchent correctement sans config spécifique . Tu n'as pas touché aux réglages ?
C'est une ligne à 4€ ou 15€ ? Avec provisioning OVH ?
Je ne peux pas remettre la LB car je l'ai rendu. :-/
Le C610 est par défaut configuré pour accepter tous les codecs, dans cet ordre là : G729, G726, G711 a law, G711 µ law, G722. J'avais fait quelques modifs en suivant les propositions évoquées page précédente, mais sans succès. J'ai tout remis à zéro via la config automatique.
Je vais faire un test en stoppant le firewall.
Mon offre est celle à 0,99 € HT/mois (Offre Plug & Phone : SIP individuelle, inclus vers les fixes en France et 40 pays, Offre mobile : A la seconde)

Citation Envoyé par Luigi_B
Bonjour.
Vu les informations communiquées, il s'agit très probablement d'un filtre au niveau du routeur.
Je préconiserai cependant malgré tout le test croisé comme le conseille abds69.
Faites cependant vos tests en neutre, juste le téléphone directement derrière le modem, après pour les configurations, la plupart des pistes ont été déjà vérifiées, en résumé :
- Codec 711,729
- Tester avec ou sans l'outbound
- Le SIP ALG doit être désactivé
- Désactiver le parefeu
- La session UDP doit être supérieure à 180 secondes
- Le trafic les réseaux 91.121.128.0/24 et 91.121.129.0/24 doit être autorisé sur les ports 5060 - 5962 et 5080 en UDP et la plage de 30000 à 40000 en UDP également.
Cordialement.
Luigi.B
Pas sur de pouvoir brancher le téléphone directement sur le boitier fibre Orange, mais je peux tenter (?).
en résumé :
- Codec 711,729 :
testé, KO
- Tester avec ou sans l'outbound : testé, KO
- Le SIP ALG doit être désactivé : non testé (je ne vois pas ce que c'est ni où ça se configure mais je vais regarder)
- Désactiver le parefeu : non testé, j'essaye ASAP
- La session UDP doit être supérieure à 180 secondes : non testé (je ne vois pas où ça se configure mais je vais regarder)
- Le trafic les réseaux 91.121.128.0/24 et 91.121.129.0/24 doit être autorisé sur les ports 5060 - 5962 et 5080 en UDP et la plage de 30000 à 40000 en UDP également : j'ai ouvert les ports dans le routeur (règle NAT vers l'IP interne du C610), en revanche je n'ai rien fait pour les réseaux 91.121.128.0/24 et 91.121.129.0/24 mais la règle NAT doit suffire ?

Merci pour tous ces conseils !

Luigi_B
06/05/2015, 09h26
Bonjour.

Vu les informations communiquées, il s'agit très probablement d'un filtre au niveau du routeur.

Je préconiserai cependant malgré tout le test croisé comme le conseille abds69.

Faites cependant vos tests en neutre, juste le téléphone directement derrière le modem, après pour les configurations, la plupart des pistes ont été déjà vérifiées, en résumé :

- Codec 711,729
- Tester avec ou sans l'outbound
- Le SIP ALG doit être désactivé
- Désactiver le parefeu
- La session UDP doit être supérieure à 180 secondes
- Le trafic les réseaux 91.121.128.0/24 et 91.121.129.0/24 doit être autorisé sur les ports 5060 - 5962 et 5080 en UDP et la plage de 30000 à 40000 en UDP également.

Cordialement.

Luigi.B

abds69
06/05/2015, 08h49
Faudrait remettre la LB et vérifier si ça marche correctement, dans ce cas c'est un paramètrage du routeur ASUS.
Sinon la config interne du c610 est à revérifier, entre autres le codec de l'appareil.
Avec l'asus, supprimer temporairement le firewall et tester.

Par experience les C610 marchent correctement sans config spécifique . Tu n'as pas touché aux réglages ?
C'est une ligne à 4€ ou 15€ ? Avec provisioning OVH ?

Gaston_Phone
05/05/2015, 23h00
5060 ou 5962

- - - Mise à jour - - -

Extrait de --> SIP - OVH - Mes interlocuteurs ne m’entendent pas

Feasir
05/05/2015, 21h52
Ne vous battez pas, j'ai testé les deux config (cf page précédente), et ça ne change rien.
Si l'un de vous peut me confirmer les ports à ouvrir sur le routeur, je suis preneur.

Merci :-)

Gaston_Phone
05/05/2015, 20h27
PierrYves si j'osais je préciserai :

- Télécom
- Ancienne interface client
- Sélectionner votre ligne
- Téléphone
- codecs
- Modifier
- g711 exclusivement
- Valider

PierrYves L
05/05/2015, 15h16
Bonjour,

Je vous remercie pour votre retour.

Je constate actuellement que votre ligne téléphonique est configuré avec le codec g711 uniquement. Nous conseillons d'utiliser les codecs g711 et g729 sur nos lignes.

Je vous invite donc à vous connecter sur votre espace client, disponible sur https://www.ovhtelecom.fr/espaceclient/login/, pour modifier cela, puis cliquez sur:

- Télécom
- Ancienne interface client
- Sélectionner votre ligne
- Téléphone
- codecs
- Modifier
- g711, g729
- Valider

Comme vous disposez d'un matériel fourni par OVH, le mot de passe du compte SIP n'est pas fourni. Celui-ci étant paramétrer automatiquement par notre serveur de configuration.

Je reste à votre disposition pour toute informations complémentaires.

Bien cordialement,
PierrYves L.

Feasir
04/05/2015, 16h38
Citation Envoyé par Gaston_Phone
Tu as donc tous les identifiants de ta ligne SIP et tu peux alors faire le test avec le softphone Zoiper.
Il me manque toujours le mot de passe. J'ai fait une autoconfiguration du téléphone et du coup je ne connais pas le mot de passe (il est masqué dans l'IHM du C610). Il y avait apparemment une page dans le manager OVH pour changer ce mot de passe (si j'en crois cette page : http://www.wordetweb.com/word-et-web...par-OVH-FR.htm ), mais la page a disparu.

Citation Envoyé par PierrYves L
Bonjour Feasir,
Afin de vérifier l'origine des phénomènes constatés, pouvez-vous me communiquer votre identifiant client s'il vous plait?
Merci d'avance de votre retour.
Bien cordialement,
PierrYves L.
Merci.
Mon identifiant OVH est : cs14269-ovh

PierrYves L
04/05/2015, 14h39
Bonjour Feasir,

Afin de vérifier l'origine des phénomènes constatés, pouvez-vous me communiquer votre identifiant client s'il vous plait?

Merci d'avance de votre retour.

Bien cordialement,
PierrYves L.

Gaston_Phone
03/05/2015, 22h14
A qui as-tu acheté ta ligne SIP ?

- - - Mise à jour - - -

Au tant pour moi. Tu as bien une ligne SIP OVH.

Tu as donc tous les identifiants de ta ligne SIP et tu peux alors faire le test avec le softphone Zoiper.

Feasir
03/05/2015, 21h56
Ah, je croyais que le softphone était pour tester la ligne SIP OVH. :-/
Parce que j''ai bien une ligne SIP avec mon pack Orange Fibre, mais comme j'ai supprimé la LiveBox pour la remplacer par un routeur Asus (RT-AC68U), je ne peux plus l'utiliser (il y a une négociation à la noix entre la LB et les serveurs SIP Orange, sans LB pas de SIP Orange). C'est d'ailleurs pour ça que j'ai pris une ligne SIP chez OVH.
Ma ligne OVH fonctionnait jusqu'à un récent update du firmware de mon routeur, et depuis plus rien. J'ai bien tenté un downgrade de mon routeur mais en vain. Je pense qu'il y a un paramétrage foireux au niveau du routeur (firewall, nat, ...), mais impossible de trouver lequel...

A noter : la config du C610 précise l'utilisation de port dynamique :
SIP : 5060-5090
RTP : 30000-65535
mais je n'ai pas trouvé l'équivalent dans le manager OVH, du coup j'ai un doute sur la plage RTP à ouvrir au niveau de mon routeur.

Gaston_Phone
03/05/2015, 21h38
Oh la la,as-tu une ligne SIP incluse avec ton pack ADSL ?

Feasir
03/05/2015, 21h13
Aïe, je coince à la configuration du softphone. Où est-ce que je trouve le mot de passe asssocié à ma ligne SIP ?

Gaston_Phone
03/05/2015, 20h42
On va procéder autrement : tester avec un softphone.

--> SIP, Zoiper PORTABLE et OVH

Peux-tu tester et venir nous donner le résultat ?

Feasir
03/05/2015, 20h26
Fait à l'instant dans le Manager OVH : sans succès, toujours pas de son côté correspondant. Il faut faire quelque chose sur le téléphone aussi ? (j'ai un Siemens C610)

Gaston_Phone
03/05/2015, 19h55
Citation Envoyé par Feasir
- forcé les codecs dans l'interface OVH : g711, g729 (précédemment g729, g711)
Hum! Hum! Ne mettre que le codec G711 et ... supprimer tous les autres.

Feasir
03/05/2015, 17h12
Hello,


J"ai un soucis avec ma ligne SIP, en appel entrant ou sortant j'entends bien mon correspondant mais de son côté c'est le néant, il n'entend absolument aucun son.

J'ai épluché les docs en ligne et les différents forum sans succès, aucune des solutions proposées n'a fonctionné.
- forcé les codecs dans l'interface OVH : g711, g729 (précédemment g729, g711)
- activé l'outbound proxy : mode "Toujours" et serveur "91.121.129.20" (précédemment mode "Auto" et pas d'adresse pour le serveur)
- ouverture des ports RTP dans mon routeur : 30000:40000 (TCP+UDP)
- activation de la QoS dans mon routeur avec positionnement des la VoIP en priorité

Help me, je suis à sec...

Merci !