OVH Community, votre nouvel espace communautaire.

Problème Connection Dbase - HELP


Bindels Hubert
13/05/2015, 23h07
Bonjour et un tout grand merci à Janus57 qui m'a mis la puce à l'oreille...

En faisant un essai avec votre code ci-dessus, je me suis rendu compte en effet que l'appel de la page par l'URL classique fonctionnait et me signalait que j'étais en PHP 5.5.2, alors que l'appel de l'URL par le sous domaine me retournait une erreur de syntaxe à la ligne 8 au niveau du } avant le try.

J'en ai donc déduit que je n'étais plus en PHP5 vi que le try-catch est apparu dans la version 5 de PHP.

Au niveau de mon .ovhconfig j'ai bien app.engine.version=5.5 et rien de spécial au niveau du .htaccess....tout vérifié et sûr que le problème ne provenait pas de là.

Alors, m'a pris l'idée de rajouter la ligne SetEnv PHP_VER 5_5 dans mon .htaccess et BINGO ça fonctionne !!!

Encore mille fois merci et bien à vous tous !

janus57
13/05/2015, 03h22
Bonjour,

que donne ce code (avec les bonnes infos) :
Code:
getMessage());
}

echo '
Ma version de PHP : ' . phpversion(); ?>
Car là sur http://mobile.trois-frontieres.be/test_conn_db.php j'ai ceci :
Fatal error: Call to undefined function: mysqli_connect() in /home/troisfro/www/mobile/test_conn_db.php on line 7
ce qui semblerait indiqué qu'un .ovhconfig ou .htaccess écrase la version de PHP pour passer à PHP4 sur mobile.trois-frontieres.be

P.S. d'ailleurs c'est quoi al config de votre .ovhconfig ?

Cordialement, janus57

Bindels Hubert
13/05/2015, 00h44
Personne n'a trouvé une solution , et si le problème était chez OVH ???

Bindels Hubert
02/05/2015, 17h10
Citation Envoyé par Gaston_Phone
Essaie ton script avec pour adresse de serveur SQL :
- sql1.300gp
- troisfro.mysql.db
J'ai à peu près tout essayé, mais le résultat est identique, c à d que j'ai remplacé la valeur de $host qui était "sql1" par "sql1.300gp" et c'est pareil.
L'appel par l'url classique fonctionne donc pour les 2 valeurs $host, mais l'appel par sous-domaine ne fonctionne toujours pas !

Ps: troisfro.mysql.db ne donne absolument rien dans les 2 cas

Gaston_Phone
02/05/2015, 14h42
Essaie ton script avec pour adresse de serveur SQL :
- sql1.300gp
- troisfro.mysql.db

Bindels Hubert
02/05/2015, 12h06
Citation Envoyé par Gaston_Phone
Quel est le nom complet du serveur SQL ?
Ca c'est une bonne question, car si je regarde dans l'ancien manager v3 on me met comme serveur : sql1.300gp
et dans le nouveau manager on me met : troisfro.mysql.db

Donc ???

Gaston_Phone
30/04/2015, 19h48
Quel est le nom complet du serveur SQL ?

Bindels Hubert
30/04/2015, 17h36
Bonjour,

J'ai récemment basculé vers le PHP 5.5 et tout fonctionne correctement sur le site y compris les connexions à la base de données
Pour résumer, je suis en offre perso2014 et sur le serveur sql1 (mysql)..

Parallèlement au site, j'ai créé une version mobile qui fonctionne également bien...pas de susci.

La version mobile est tout simplement un sous répertoire de www et pour lequel j'ai créé un sous domaine.

J'ai créé une page test de connexion à la base de données pour que vous puissiez vous faire une idée.

Si j'appelle la page au moyen du chemin classique http://www.trois-frontieres.be/mobile/test_conn_db.php alors la connexion est OK.

Si j'appelle la page au moyen du chemin de sous-domaine : http://www.mobile.trois-frontieres.be/test_conn_db.php alors la connexion ne se fait plus.

Voici le code de la page:

$host = "sql1";
$user = "xxx";
$pass = "xxx";
$bdd = "xxx";
// connexion
$Dblink = mysqli_connect($host,$user,$pass,$bdd);
if (!$Dblink) {
die('Could not connect: ' . mysqli_connect_error());
}
$db_selected = mysqli_select_db($Dblink, $bdd);
if (!$db_selected) {
die ('

Cannot use 3f_news : ' . mysqli_error());
}
echo "Connection DBase OK";
?>

Je dois avouer que je ne comprends pas...Merci de me donner une solution