OVH Community, votre nouvel espace communautaire.

Debien 8 "Jessie" pour quand sur VPS?


janus57
29/05/2015, 10h13
Bonjour,

si tu veux savoir si c'est l'image OVH ou non tu install virtualbox (ou autre) sur ton PC et tu installe une ISO officiel de Debian8 tu sera très vite fixé, j'ai déjà fait ça pour une install TS3 qui foiré sous Debian 7 sur les VPS OVH mais fonctionné sur une officiel + autre hébergeur, j'ai pas cherché plus loin.

Cordialement, janus57

polytan
29/05/2015, 10h02
Citation Envoyé par janus57
Bonjour,

et au passage si on dit au script de remplacer les sources il nous met les wheezy et non les jessie donc ça va planter lamentablement car il va y avoir un mélange de sources.

Cordialement, janus57
Salut Janus57,

Oui, pas de soucis concernant le point "jessie/wheezy" je le savais. Mais mon script avait un soucis avant d'en arriver là. Chaque chose en sont temps

Mon soucis avec l'image Debian 8 sur VPS Classic 1 était étrange : je n'arrivais pas à voir les couleurs dans le shell de base.
Aujourd'hui j'ai refais un test et maintenant ça fonctionne....alors que je n'ai rien changé.....

Je suppose que l'image Jessie 8 n'est pas encore finalisée et du coup elle "se bonifie" avec le temps ?
Pas simple de résoudre des bugs dans ces conditions pour moi

Là maintenant j'ai même m'interface en ncurses qui s'affiche

janus57
27/05/2015, 17h01
Bonjour,

et au passage si on dit au script de remplacer les sources il nous met les wheezy et non les jessie donc ça va planter lamentablement car il va y avoir un mélange de sources.

Cordialement, janus57

polytan
27/05/2015, 16h29
Il semble que j'ai résolu mon soucis qui vient d'une de mes commandes bash interprétée différemment sous Wheezy et Jessie.

janus57
27/05/2015, 16h06
Bonjour,

@Nowwhat : non c'est juste car le script va taper dans un fichier nommé etc qui est avec le script.

To copy these files on your server, simply do :
apt-get update
apt-get install git
git clone https://github.com/polytan02/yunohost_auto_config_basic
cd yunohost_auto_config_basic/
Regarde sur le git tu verra un dossier "etc" avec les différents scripts.

Cordialement, janus57

Nowwhat
27/05/2015, 15h55
Très suspect ça:
Code:
source etc/couleurs.sh
Je ne connais pas le script, mais je préfère de loin:
Code:
source /etc/couleurs.sh
pour des raisons bien évidentes.

T'as testé ça ?

polytan
27/05/2015, 14h58
Bonjour Janus57,

Mes scripts (par exemple https://github.com/polytan02/yunohos...unoHost.sh#L51) n'ont pas été adaptés à Jessie. Il ne devrait pas y avoir de modif nécessaire dans cette partie du programme !

Je n'ai aucun log (apparemment).

Le script ne fait vraiment rien de particulier à l'endroit où il plante : il utilise la commande "source" qui inclue un script dans un autre. Un peu comme un include en C je suppose.

C'est la première fois que j'ai ce soucis avec Debian :/

janus57
27/05/2015, 13h01
Bonjour,

faut regarder dans les logs ou rendre les script bash "verbeux" pour voir si y a pas une erreur.

Est-ce que les script ont été adapté à Jessie ?

Cordialement, janus57

polytan
27/05/2015, 12h38
Bonjour,

Je viens d'installer Jessie sur mon VPS Classic1 de test.

Pas de bol pour moi, j'ai un soucis juste après la connexion en root :/

En effet, pour installer et configurer mon système, je lance quelques scripts en bash. Malheureusement, ceux-ci s'arrêtent sans message d'erreur lorsque je dois faire un "source dossier/fichier".

J'utilise la console KVM pour lancer mes commandes initiales. Tout ce que j'ai changé c'est le mot de passe root avant de lancer le script (récupéré sur un autre serveur via scp).

Sauriez-vous ce qui ne va pas svp ?

identifiantkims
20/05/2015, 21h10
Bonsoir,

Citation Envoyé par damien.rannou
Bonjour à tous,
Nous venons de mettre à disposition les distributions debian 8 et Ubuntu 15.04 pour les Vps Classic.
N'hésitez pas à nous faire des retours en cas de soucis.
Cordialement,
Après un premier test rapide sur un VPS classic, pas de soucis, donc un grand merci pour cette mise à disposition !

damien.rannou
20/05/2015, 09h55
Bonjour à tous,

Nous venons de mettre à disposition les distributions debian 8 et Ubuntu 15.04 pour les Vps Classic.

N'hésitez pas à nous faire des retours en cas de soucis.

Cordialement,

- - - Mise à jour - - -

Bonjour à tous,

Nous venons de mettre à disposition les distributions debian 8 et Ubuntu 15.04 pour les Vps Classic.

N'hésitez pas à nous faire des retours en cas de soucis.

Cordialement,

Nowwhat
11/05/2015, 21h33
Citation Envoyé par janus57
perso ntp(d) n'a jamais fonctionné par toujours refusé à l’exécution sur un OpenVZ, il faut que l'hébergeur autorise les container OpenVZ à l'utiliser (ce qu'il ne font pratiquement jamais), d'un côté c'est pas mal, à condition que l'hôte soit à jour.
lol, oui, j'ai compris (après) que ça n'a pas de sens de mettre à jour l'heure sur un VPS ..... Normalement, le 'hôte' devrait de toute façon s'occuper de ça.
Sinon, postfix (dernière version) sur un "Debian 8" => hyper solide.

janus57
11/05/2015, 14h27
Bonjour,

perso ntp(d) n'a jamais fonctionné par toujours refusé à l’exécution sur un OpenVZ, il faut que l'hébergeur autorise les container OpenVZ à l'utiliser (ce qu'il ne font pratiquement jamais), d'un côté c'est pas mal, à condition que l'hôte soit à jour.

Cordialement, janus57

sich
11/05/2015, 14h01
ha cool, reste encore à avoir Percona sur Jessie et ça sera tout bon pour moi

Nowwhat
11/05/2015, 13h33
Mise à jour de Wheezy vers Jessi sur VPS Classic qui tourne dans une boite OpenVZ : npt(d) ne démarre plus pour - ça termine avec un
Apr 23 04:26:46 vps62725 ntpd[1491]: ntpd 4.2.6p5@1.2349-o Sat Feb 7 11:05:48 UTC 2015 (1)
Apr 23 04:26:46 vps62725 ntpd[1492]: proto: precision = 0.115 usec
Apr 23 04:26:46 vps62725 ntpd[1492]: Listen and drop on 0 v4wildcard 0.0.0.0 UDP 123
Apr 23 04:26:46 vps62725 ntpd[1492]: Listen and drop on 1 v6wildcard :: UDP 123
Apr 23 04:26:46 vps62725 ntpd[1492]: Listen normally on 2 lo 127.0.0.1 UDP 123
Apr 23 04:26:46 vps62725 ntpd[1492]: Listen normally on 3 venet0 127.0.0.2 UDP 123
Apr 23 04:26:46 vps62725 ntpd[1492]: Listen normally on 4 venet0:0 92.222.20.243 UDP 123
Apr 23 04:26:46 vps62725 ntpd[1492]: Listen normally on 5 lo ::1 UDP 123
Apr 23 04:26:46 vps62725 ntpd[1492]: Listen normally on 6 venet0 2001:41d0:52:cff::1286 UDP 123
Apr 23 04:26:46 vps62725 ntpd[1492]: peers refreshed
Apr 23 04:26:46 vps62725 ntpd[1492]: Listening on routing socket on fd #23 for interface updates
Apr 23 04:26:46 vps62725 ntpd[1492]: cap_set_proc() failed to drop root privileges: Operation not permitted
Solution : http://support.ntp.org/bin/view/Supp...tion_9.2.4.2.5. - ce qui est impossible sur un VPS-Classic.

Conclusion : enlève ntp(d) puis bosse avec ntpdate.

identifiantkims
11/05/2015, 13h17
Citation Envoyé par damien.rannou
debian 8 est disponible sur VPS Cloud,
Nous travaillons sur la version VPS Classic, elle sera disponible prochainement.
Bonjour,

Comme d'autres j'attends avec impatience la disponibilité de Debian 8 sur les VPS Classic pour faciliter la découverte et les tests d'installation sur cette nouvelle version stable de Debian.
Merci donc pour cette information concernant Debian Jessie sur VPS Cloud et à bientôt pour l'annonce de la mise à disposition de la version VPS Classic j'espère !

damien.rannou
11/05/2015, 12h39
debian 8 est disponible sur VPS Cloud,
Nous travaillons sur la version VPS Classic, elle sera disponible prochainement.

- - - Mise à jour - - -

debian 8 est disponible sur VPS Cloud,
Nous travaillons sur la version VPS Classic, elle sera disponible prochainement.

sich
07/05/2015, 08h52
Toujours rien côté VPS.... Un membre du staff dans le coin pour donner des infos ?
Avec le changement d'init notamment j'aimerai partir sur une install "propre" perso.

janus57
30/04/2015, 22h40
Bonjour,

pour fail2ban il on revu la disposition des fichiers de config et les jails perso ainsi que l'activation de celle-ci (en gros).

Donc tous ceux qui ont fait des jails perso sous Wheezy et mis dans jail.conf (et non jail.local) vont les perdre à la migration (normalement).

De plus on vois l'apparition de nouvelles jail (shellshock/snort) ainsi qu'une modification de là ou ils vont chercher les fichiers de logs à analyser (tout est réunit dans un fichier ou les jails).

Cordialement, janus57

helas
30/04/2015, 22h37
Citation Envoyé par janus57
Bonjour,

pourquoi il le serait pas ? =)

D'autre concurrents on déjà Jessie sur leur plateforme OpenVZ


non ell est juste passé à "without-paswword" (comme indiqué dans le guide ici : https://www.debian.org/releases/stab...n.html#openssh ), voilà pourquoi je conseillé de le lire au complet car y a pas mal de changement, surtout avec fail2ban qui c'est pris un lifting dans la tête avec les conditions apache et systemd.

Cordialement, janus57
Oui j'ai pas plus d'info sur le fail2ban mais bon marche nikel !
A peine plus gourmand en RAM

janus57
30/04/2015, 21h19
Citation Envoyé par minitigrou
Tout à fait, par contre une question : est-ce que le noyau OpenVZ d'OVH est compatible avec Jessie ?
Bonjour,

pourquoi il le serait pas ? =)

D'autre concurrents on déjà Jessie sur leur plateforme OpenVZ

EDIT : Fonctionne bien juste la fonction root login qui est désactivé par default sur debian 8
non ell est juste passé à "without-paswword" (comme indiqué dans le guide ici : https://www.debian.org/releases/stab...n.html#openssh ), voilà pourquoi je conseillé de le lire au complet car y a pas mal de changement, surtout avec fail2ban qui c'est pris un lifting dans la tête avec les conditions apache et systemd.

Cordialement, janus57

helas
30/04/2015, 19h39
Citation Envoyé par minitigrou
Tout à fait, par contre une question : est-ce que le noyau OpenVZ d'OVH est compatible avec Jessie ?
L'uppgrade est encours je vous tiens au courant si il demarre au reboot


EDIT : Fonctionne bien juste la fonction root login qui est désactivé par default sur debian 8

minitigrou
30/04/2015, 19h20
Citation Envoyé par janus57
en installe ou en upgrade ?

En upgrade c'est à vous de le faire.
Tout à fait, par contre une question : est-ce que le noyau OpenVZ d'OVH est compatible avec Jessie ?

polytan
30/04/2015, 18h12
Citation Envoyé par janus57
Bonjour,

pour upgrade "proprement" voici le guide Debian : https://www.debian.org/releases/stab...upgrading.html

Sinon perso je conseil de rester encore un peu en Wheezy car va surement y avoir une ou plusieurs vague de patch à cause de bugs dans les prochaines semaines/mois, surtout que Wheezy est encore maintenant jusque Fevrier2016 puis passera en support LTS, donc sa sert à rien de se précipiter à upgrade son Debian surtout si on le fait mal ou dans "le feu de l'action" sans suivre les conseils Debian et surtout lire les incompatibilité avec les nouvelle version (apache 2.2 vs 2.4 | php5.4 vs php5.6 | opcache vs APC etc...).

Cordialement, janus57
Dans tous les cas, j'attends également une image Jessy disponible sur les VPS Classic pour faire des tests car même si on attend tous qu'elle se "stabilise", les projets ne s'arrêtent pas et ont besoin de vivre avec leur temps

Donc vivement une Jessy sur les VPS Classic

janus57
30/04/2015, 16h48
Bonjour,

pour upgrade "proprement" voici le guide Debian : https://www.debian.org/releases/stab...upgrading.html

Sinon perso je conseil de rester encore un peu en Wheezy car va surement y avoir une ou plusieurs vague de patch à cause de bugs dans les prochaines semaines/mois, surtout que Wheezy est encore maintenant jusque Fevrier2016 puis passera en support LTS, donc sa sert à rien de se précipiter à upgrade son Debian surtout si on le fait mal ou dans "le feu de l'action" sans suivre les conseils Debian et surtout lire les incompatibilité avec les nouvelle version (apache 2.2 vs 2.4 | php5.4 vs php5.6 | opcache vs APC etc...).

Cordialement, janus57

helas
30/04/2015, 16h36
Citation Envoyé par Thaldan
Bonjour,

est-ce que quelqu'un sait quand on pourra passé a la nouvelle version stable de debian sur nos chers VPS?
Sinon édite ton sources.list nano /etc/apt/sources.list

Code:
deb http://debian.mirror.uber.com.au/debian/ jessie main
deb-src http://debian.mirror.uber.com.au/debian/ jessie main

deb http://security.debian.org/ jessie/updates main contrib
deb-src http://security.debian.org/ jessie/updates main contrib

# jessie-updates, previously known as 'volatile'
deb http://debian.mirror.uber.com.au/debian/ jessie-updates main contrib
de
après ça

Code:
apt-get update
apt-get upgrade
apt-get dist-upgrade
apt-get autoremove

reboot

cat /etc/debian_version
8.0

janus57
30/04/2015, 15h01
Bonjour,

en installe ou en upgrade ?

En upgrade c'est à vous de le faire.

Cordialement, janus57

helas
30/04/2015, 14h30
Citation Envoyé par Thaldan
Bonjour,

est-ce que quelqu'un sait quand on pourra passé a la nouvelle version stable de debian sur nos chers VPS?
Très bonne question Wait and See

Thaldan
30/04/2015, 14h15
Bonjour,

est-ce que quelqu'un sait quand on pourra passé a la nouvelle version stable de debian sur nos chers VPS?