OVH Community, votre nouvel espace communautaire.

Impossible de faire la mise à jour Wordpress ( ftp )


shirokoweb
28/04/2015, 21h17
De mémoire, à la location d'un VPS, vous recevez un utilisateur "root" et un mot de passe pour pouvoir vous connecter à la machine (ssh ou sftp).
Je parie que l'upload de WP s'est fait avec cet user, dans ces conditions, il faut modifier la propriété / groupe des dossiers pour que wordpress puisse écrire dedans.

PS : si vous êtes connecté en root via un terminal SSH, la commande sudo est inutile
PS2 : AVANT d'intervenir sur un service, généralement, on l'arrête au préalable : /etc/init.d/vsftpd stop
PS3 : useradd --system ftp ne fait qu'ajouter un utilisateur, il faut ensuite créer son mot de passe avec la cmde 'passwd' : passwd ftp > entrée > @!#MonMotDePasse123#!@

prérequis :

éditer le fichier /etc/vsftpd.conf
décommenter la ligne #write_enable=YES

0. Arrêter le service VSFTPD :
service vsftpd stop ou /etc/init.d/vsftpd stop
1. Créer un groupe :
groupadd FTPU
2. Créer le dossier du groupe ;
mkdir /FTP
3. Créer et ajouter l'utilisateur FTP 'FTPuser' dans le dossier FTPU :
useradd -g FTPU -d /FTP FTPuser
4. Définir un mot de passe pour l'utilisateur :
passwd FTPuser !*@*!#P9pç&BbaZ#!*$*!
5. Modifier la propriété et le groupe du dossier FTP et changer les droits :
chmod 770 /FTP && chown root:FTPU /FTP
6. Redémarrer le service vsftps :
service vsftpd restart ou /etc/init.d/vsftpd start

Kos95
28/04/2015, 17h21
Désolé double.

J'ai installer : sudo apt-get install vsftpd pour utiliser la fonction FTPS de wordpress.

j'ai créer un user : sudo useradd --system ftp

Mais pas de mot passe à la création du compte

Kos95
28/04/2015, 08h50
Merci pour votre réponse mais justement au moment de la mise à jour il semble que le nom d'hote ne soit pas bon ( localhost, nom du vps, ip )

De plus je ne peux cocher que l'option "FTP" ou une autre option en bas des identifiants à remplir.

Nowwhat
28/04/2015, 08h04
Bonjour,

Un VPS, c'est comme un dédié.
Donc, si tu désire avoir un serveur FTP sur ton VPS, c'est à toi d'installer (et paramétrer) un.

De plus, t'as l'accès SFTP (inclus avec l'accès SSH) donc je te conseille de laisser tomber ce 'FTP', un truc de l'autre siècle.

Par contre, j'ai un VPS, un vrai dédié (un SYS) et même des Mutu d'OVH: je clique sur "mettre à jour" dans la partie admin de WordPress et hoppa ... il est à jour (version 4.2.1).
Pas besoin de 'FTP' ou quoi que ce soit.

Kos95
28/04/2015, 07h31
Bonjour à tous

Je n'arrive pas à faire la mise à jour automatique de Wordpress, je susi chez OVH ( j'ai un VPS ) et il ne m'a été transmis aucun nom d'hote FTP lors de la location du VPS.

J'ai testé le nom du vps, l'ip et localhost mais rien n'y fait...

( j'ai bien un user + mot de passe quand je me connecte en sftp via WINSCP )

Merci d'avance