OVH Community, votre nouvel espace communautaire.

Problème envoi email via formulaire si domaine extérieur


MatthieuP
24/04/2015, 15h30
Je vous en prie, effectivement un redémarrage de bind permet de recharger les zones dns.

Bon week end à vous également.

Matthieu P.
OVH Team.

Claude06
24/04/2015, 14h26
J'ai suivi vos conseils et désactivé dans PLESK le service DNS sur les deux domaines qui posaient problème.
Dernière question : je suppose qu'il y a un temps de propagation pour que la modification soir prise en compte ?

EDIT : après un redémarrage du serveur DNS de Plesk, et un premier test, le résultat est OK.

Merci encore Matthieu et merci aussi à fritz2cat.
Bon WE.
Claude.

MatthieuP
24/04/2015, 14h17
Il faudra soit désactiver totalement la zone dns dans plesk, celle-ci n'étant pas utile car les serveurs dns déclarés pour ce domaine sont les serveurs dns mutualisés, ou soit modifier le champ mx pour que les mails soient redirigés vers les bon serveurs de mails.

Dans le cas ou vous changez uniquement les champs MX, vous risquez d'avoir une problématique similaire avec des sous domaines que vous pourrez rajouter dans l'espace client qui ne seront pas pris en compte dans plesk, où vous devrez effectuer la modification une seconde fois.

Matthieu P.

OVH Team

Claude06
24/04/2015, 13h34
Citation Envoyé par MatthieuP
Il faudra également désactiver la zone dns du plesk (les dns utilisés étant les dns mutualisés) ou modifier le champ mx afin que les mails soient bien redirigés vers le bon serveur de mail, la zone configurée sur votre serveur étant active et contenant de mauvaises informations.

dig orgaco.net @37.187.72.182 mx

; <<>> DiG 9.8.4-rpz2+rl005.12-P1 <<>> orgaco.net @37.187.72.182 mx
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 45529
;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 1
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;orgaco.net. IN MX

;; ANSWER SECTION:
orgaco.net. 86400 IN MX 10 mail.orgaco.net.

;; AUTHORITY SECTION:
orgaco.net. 86400 IN NS ns3362174.ovh.net.
orgaco.net. 86400 IN NS sdns2.ovh.net.

;; ADDITIONAL SECTION:
mail.orgaco.net. 86400 IN A 37.187.72.182

Matthieu P.
OVH Team
Si j'ai bien compris, soit je supprime le champ MX du domaine sur Plesk, soit je change la valeur par celles du domaine. Dans ce dernier cas, sur le domaine j'ai deux champs MX (MX1 et MX5), je dois copier les deux à l'identique sur Plesk ?

Claude06
24/04/2015, 13h26
Citation Envoyé par fritz2cat
Classique. Je ne connais pas Plesk mais il faut dire que ton serveur n'est pas le serveur mail pour ces 2 domaines.
Dans Postfix, on parle de mydomains ou virtual-domains.
D'après toi, il faudrait donc modifier certains champs DNS du domaine sur Plesk ?

MatthieuP
24/04/2015, 13h25
Il faudra également désactiver la zone dns du plesk (les dns utilisés étant les dns mutualisés) ou modifier le champ mx afin que les mails soient bien redirigés vers le bon serveur de mail, la zone configurée sur votre serveur étant active et contenant de mauvaises informations.

dig orgaco.net @37.187.72.182 mx

; <<>> DiG 9.8.4-rpz2+rl005.12-P1 <<>> orgaco.net @37.187.72.182 mx
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 45529
;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 1
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;orgaco.net. IN MX

;; ANSWER SECTION:
orgaco.net. 86400 IN MX 10 mail.orgaco.net.

;; AUTHORITY SECTION:
orgaco.net. 86400 IN NS ns3362174.ovh.net.
orgaco.net. 86400 IN NS sdns2.ovh.net.

;; ADDITIONAL SECTION:
mail.orgaco.net. 86400 IN A 37.187.72.182

Matthieu P.
OVH Team

Claude06
24/04/2015, 13h09
Bonjour Matthieu,

Le domaine est orgaco.net.
Je viens de décocher la case "Activer le service de messagerie sur ce domaine ", car je pense que c'est cette fonction qui permet d'activer ou de désactiver les emails sur le domaine.

Merci,
Claude.

fritz2cat
24/04/2015, 12h46
Classique. Je ne connais pas Plesk mais il faut dire que ton serveur n'est pas le serveur mail pour ces 2 domaines.
Dans Postfix, on parle de mydomains ou virtual-domains.

MatthieuP
24/04/2015, 12h44
Bonjour,

D'après ce que vous décrivez, le serveur tente probablement d'envoyer les emails en local.

Pourriez-vous préciser le domaine en question? Ceci afin de vérifier si vous utilisez un serveur dns externe, qu'il n'y ait pas sur le serveur une zone dns active avec des informations erronées (comme un champ mx comprenant un domaine pointant sur le serveur).

Les mails sont bien désactivé pour ce domaine dans plesk?

Matthieu P.
OVH Team

Claude06
24/04/2015, 11h30
Bonjour,

Je rencontre un problème d'email sur un serveur qui tourne sous Plesk :

Pour faire court, j'ai 2 sites qui sont hébergés sur ce serveur, dont les comptes email sont hébergés sur des plan MX OVH. Autrement dit, j'ai modifié les DNS de chaque domaine afin que seul l'hébergement soit redirigé sur le servuer Plesk d'un autre compte OVH.
Les destinataires des formulaires de contact de chaque site sont chaque fois des adresses rattachées au nom de domaine, et lorsqu'un mail est envoyé depuis le formulaire, il n'arrive nulle part. Si je mets une adresse extérieure (genre gmail) tout fonctionne.

Je pense qu'il s'agit d'un problème DNS, mais sans en savoir plus.
Quelqu'un aurait une idée ?

Merci,
Claude.