OVH Community, votre nouvel espace communautaire.

Problème de mise en place d'un CNAME www vers un domaine tiers chez Gandi


Daniel60
20/03/2015, 12h57
Citation Envoyé par Histrion
Bonjour JuGU, j'ai ouvert le ticket, mais mon problème est résolu. C'est plutôt que vu l'état du nouveau manager un bandeau "Beta" en gros, en gras et en rouge ne serait pas de trop pour comprendre qu'on ne peut pas s'en servir de manière fiable.
Excellente suggestion

JuGU
20/03/2015, 12h12
C'est probablement dû à un conflit avec une autre entrée existante.

Je t'invite à patienter le temps que l'administrateur puisse revenir vers toi.

Histrion
19/03/2015, 13h17
Bonjour JuGU, j'ai ouvert le ticket, mais mon problème est résolu. C'est plutôt que vu l'état du nouveau manager un bandeau "Beta" en gros, en gras et en rouge ne serait pas de trop pour comprendre qu'on ne peut pas s'en servir de manière fiable.

JuGU
19/03/2015, 12h28
Bonjour Histrion.

Je te remercie pour ta remontée.

Après avoir inspecté les logs, il semble en effet que malgré ts modifications, ces dernières n'ont pas été prises en compte.

Je t'invite à déclarer un ticket incident depuis l'ancienne interface de l'espace client dans la partie support, déclarer un incident.

Histrion
19/03/2015, 10h20
Et voilà. Je vois enfin mon CNAME avec un nslookup sur les DNS d'OVH...

Votre nouveau manager m'aura quand même fait perdre plusieurs jours. Je sais que quand on est un géant on s'en fout d'un client qui est à la peine, mais sérieusement quelle mauvaise pub, je ne suis pas sûr de conseiller OVH pour un nom de domaine d'ici un bon bout de temps (alors que je suis très content de l'ADSL).

Histrion
19/03/2015, 10h14
Via le manager ancienne version voici ce que je vois :

AVEC ASSISTANT :

Code:
Champ	Type	Cible
.dj-ace972.com	NS	dns111.ovh.net
.dj-ace972.com	NS	ns111.ovh.net
.dj-ace972.com	MX 1	redirect.ovh.net
www.dj-ace972.com	CNAME	autredomaine.com
_autodiscover._tcp.dj-ace972.com	SRV	0 0 443 mailconfig.ovh.net
_imaps._tcp.dj-ace972.com	SRV	0 0 993 ssl0.ovh.net
_submission._tcp.dj-ace972.com	SRV	0 0 465 ssl0.ovh.net
autoconfig.dj-ace972.com	CNAME	mailconfig.ovh.net
ftp.dj-ace972.com	CNAME	dj-ace972.com
imap.dj-ace972.com	CNAME	ssl0.ovh.net
mail.dj-ace972.com	CNAME	ssl0.ovh.net
pop3.dj-ace972.com	CNAME	ssl0.ovh.net
smtp.dj-ace972.com	CNAME	ssl0.ovh.net
SANS ASSISTANT (la zone telle que configurée !) :

Code:
$TTL 3600
@	IN SOA dns111.ovh.net. tech.ovh.net. (2015031801 86400 3600 3600000 300)
                          IN NS     dns111.ovh.net.
                          IN NS     ns111.ovh.net.
                          IN MX 1   redirect.ovh.net.
                          IN A      213.186.33.5
                          IN TXT    "1|www.dj-ace972.com"
_autodiscover._tcp        IN SRV    0 0 443 mailconfig.ovh.net.
_imaps._tcp               IN SRV    0 0 993 ssl0.ovh.net.
_submission._tcp          IN SRV    0 0 465 ssl0.ovh.net.
autoconfig                IN CNAME  mailconfig.ovh.net.
ftp                       IN CNAME  dj-ace972.com.
imap                      IN CNAME  ssl0.ovh.net.
mail                      IN CNAME  ssl0.ovh.net.
pop3                      IN CNAME  ssl0.ovh.net.
smtp                      IN CNAME  ssl0.ovh.net.
www                       IN MX 1   spool.mail.gandi.net
www                       IN MX 1   fb.mail.gandi.net
www                       IN TXT    "3|welcome"
www                       IN TXT    "l|fr"
Autrement dit le CNAME pour "www" n'est jamais arrivé jusqu'au fichier de zone... Je vais tenter de faire la modif en désactivant les assistants.

Histrion
18/03/2015, 10h53
Bonjour,

J'aide un ami qui a acheté le domaine dj-ace972.com chez OVH à se créer un site web. De mon côté je possède un domaine chez Gandi, dont le A principal pointe sur l'IP d'un serveur dédié où j'héberge temporairement son site. Ma zone chez Gandi est OK, et fonctionne depuis des années, je n'y ai pas touché.

Sur la zone de dj-ace972.com j'ai :
- supprimé l'entrée CNAME pour www.dj-ace972.com. qui pointait vers la page "vous avez bien acheté un nom de domaine chez OVH"
- créé une entrée CNAME pour www.dj-ace972.com. qui pointe sur mon domaine (directement le domaine, pas un sous-domaine, et j'ai bien mis le "." à la fin)

Une fois ces modifications faites la zone porte le serial "2015031802", ce qui correspond bien à aujourd'hui avec 2 modifs.

Par contre, quand j'interroge les DNS d'OVH (ns111.ovh.net ou dns111.ovh.net qui sont ceux configurés dans la zone de dj-ace972.com) j'ai une réponse qui me dit qu'il n'y a pas de CNAME en www, alors que le serial est bien "2015031802"... Comme si mes modifs à la zone n'avaient pas du tout été prises en compte et que seul le n° de version du fichier de zone avait été incrémenté !

Pour le détail :

Code:
Looking up IP address for ns111.ovh.net...

Sending DNS query for www.dj-ace972.com...

ns111.ovh.net [2001:41d0:1:199b::1] returned an authoritative response in 114 ms:

Header

rcode:	Success
id:	34150	opcode:	Query
is a response:	True	authoritative:	True
recursion desired:	True	recursion avail:	False
truncated:	False
questions:	1	answers:	0
authority recs:	1	additional recs:	0

Questions

name	class	type
www.dj-ace972.com	ANY	CNAME

Answer records

none

Authority records

name	class	type	data	time to live
dj-ace972.com	IN	SOA	
server:	dns111.ovh.net
email:	tech@ovh.net
serial:	2015031802
refresh:	86400
retry:	3600
expire:	3600000
minimum ttl:	300
300s	(00:05:00)

Additional records

none
Est-ce qu'il y a un problème avec le nouveau manager de zone ? J'ai oublié de cliquer sur un bouton "activer vos modifs" que j'aurais raté (j'ai beau chercher je n'en ai pas trouvé) ?