OVH Community, votre nouvel espace communautaire.

Envoi de mail depuis une appli ASP.NET (serveur mutualisé)


fritz2cat
20/03/2015, 09h35
587 et TLS ?
C'est le futur, et ceci d'autant plus que suite au bug Heartbleed, SSLv3 doit être abandonné pour erreur de conception impossible à corriger.

PrjCmb
19/03/2015, 16h11
J'avais essayé avec le port 587 et ssl0.ovh.net et ça ne fonctionne pas ("Le serveur ne prend pas en charge les connexions sécurisées")
Toutefois, en virant le client.EnableSsl dans mon code, ça fonctionne !

Vu que ce site n'est qu'un site de test, ça règle le problème MAIS il n'est pas question, sur le futur "vrai" site, que les mails soient envoyé sans SSL.
OVH propose t-il cette option sur ses SMTP ? Y a t-il des offres particulières à choisir pour avoir cette option ? Je comptais prendre un hébergement perso, mais je n'ai pas encore décidé lequel, y en a t-il à éviter pour avoir le SSL d'activé ?

En tout cas, merci pour cette solution qui règle temporairement e problème :-)

JuGU
19/03/2015, 15h27
As-tu essayé avec le port 587 et ssl0.ovh.net ?

JuGU
19/03/2015, 14h38
Il s'agit de mail php, et tu fais du mail smtp, donc ça ne pas d'incidence.

Je vérifie ton dossier et reviens vers toi.

PrjCmb
19/03/2015, 13h59
Je viens de tester avec le port 465 et le serveur ssl0.ovh.net, et mon log m'indique : "Le délai d'attente de l'opération a expiré"

Mon nic handle est ba136767-ovh, le site concerné est celui se terminant par -test.fr

Au moment d'écrire ces lignes, je suis en train de me rappeler que mon autre site (un site perso wordpress basique) avait fait l'objet d'une attaque il y a plusieurs mois, et avait servi de relai pour du spam. Il me semble qu'OVH avait bloqué les mails sortants, ce qui ne me dérangeait pas puisque je n'utilise JAMAIS le mail associé à ce site. Mais peut être cela a t-il une incidence sur le site que je teste actuellement ?

JuGU
19/03/2015, 13h01
Si tu utilises le port 465, as-tu essayé avec le serveur ssl0.ovh.net en serveur ?

Pour mieux te renseigner, j'aurais besoin du nom de domaine concerné, ou de ton nic handle s'il te plaît.

PrjCmb
18/03/2015, 13h51
Comme le demande mon VDD, une réponse de la part d'une personne de la team OVH serait la bienvenue... Surtout que c'est une question assez basique il me semble, et que je ne suis pas le seul à avoir ce problème...

Merci

fritz2cat
17/03/2015, 15h11
Je suis aussi un client (sans hébergement Windows) -- ce serait bien que quelqu'un de la team OVH intervienne dans cette conversation.

PrjCmb
17/03/2015, 14h55
Ok, pour résumer je fais des tests de config SMTP via un logiciel tiers, et j'ai ENFIN une configuration d'où le mail est parti (via ce logiciel tiers donc)

Code:
SmtpClient client = new SmtpClient();
client.Credentials = new System.Net.NetworkCredential("account@monDomaine.fr", "monPass"  );
 client.Port = 465;
client.Host = "smtp.monDomaine.fr";
client.EnableSsl = true;
Par contre quand je pousse cette config sur le site OVH, le mail ne part pas et j'ai le log suivant :
"Le délai d'attente de l'opération a expiré." En effet il est resté une bonne minute à "envoi en cours", puis planté.

=> Ça veut dire que le quota a expiré ??
Il faut que je fasse mes tests à 0h01 ou quoi ?

fritz2cat
17/03/2015, 14h27
Essaie un peu le port 465 ?
Ou bien 5025 ?
En effeil y a des différences entre SSL et TLS.
SSL est sur le port 465.
Sur le port 25 ou 587 tu devrais pouvoir faire du cleartext (déconseillé) ou du TLS.
Je pense que 5025 (historique chez OVH) se comporte comme 25 et 587.

Lis les discussions sur les quotas de mails par IP, par compte mail et par heure. Ton hébergement Windows partage la même IP que tes voisins d'hébergement.

PrjCmb
17/03/2015, 14h13
Je viens de créer une adresse mail depuis le manager, que j'ai appelé account@mondomaine.fr

J'ai désormais le bout de code suivant :

Code:
SmtpClient client = new SmtpClient();
client.Credentials = new System.Net.NetworkCredential("account@mondomaine.fr", "monPass"  );
client.Port = 587;
client.Host = "smtp.mondomaine.fr";
client.EnableSsl = true;
Or le mail ne s'envoie toujours pas !!
Mon log m'indique : "Le serveur ne prend pas en charge les connexions sécurisées."

Le fait de repasser le port à 25 et de mettre à false le EnableSsl me donne le log suivant :
"Impossible de se connecter au serveur distant"

Pouvez-vous me donner une configuration SMTP fiable afin que mon mail parte ?
Merci

fritz2cat
17/03/2015, 13h12
On ne peut pas pinguer ssl0.ovh.net.

Pour le reste l'envoi de mails depuis les hébergements Windows c'est une longue histoire qui n'avance pas chez OVH.
Une offre d'hébergement (même sous Windows) doit contenir une possibilité d'envoi fiable d'e-mail sans devoir bricoler et sans devoir appeler Gmail à la rescousse pour pallier les manquements d'OVH.

JuGU
17/03/2015, 12h56
Le login est l'adresse mail complète, et le mot de passe, celui du compte mail en question. Mais il faut pour cela que l'adresse mail soit créée sur nos offres de mail mutualisé. Est-ce le cas ?

PrjCmb
17/03/2015, 09h36
Bonjour,

En définissant le port à 587 ou à 465 en SSL, le mail ne s'envoie toujours pas et j'ai systématiquement l'erreur suivante dans mes logs :
"Échec d'envoi du courrier." et "Impossible de se connecter au serveur distant".

Avez-vous une autre configuration SMTP à me donner pour que cela fonctionne une fois publié sur OVH ?
Faut-il activer "manuellement" le SSL quelque part dans le manager OVH ? (il ne me semble pas mais je préfère demander)

J'ai vu qu'il était possible d'utiliser ssl0.ovh.net avec le port 465, mais où puis-je trouver le login / pass qui m'a été attribué pour utiliser ce serveur ? Remarquez, je viens de ping ce serveur et il ne répond pas... Idem pour smtp.monsite.fr

JuGU
16/03/2015, 13h04
Bonjour PrjCmb.

Je t'inviterai à essayer de définir un smtp, et éviter le port 25 qui est filtré. Utilise plutôt le 587 ou le 465 en ssl.

PrjCmb
16/03/2015, 10h11
Bonjour,

Je suis en train de développer une application que j'ai déployée il y a peu sur un serveur mutualisé ASP.NET

A la création d'un compte utilisateur, l'appli envoie un email pour valider l'adresse donnée. En localhost, cela marche parfaitement, mais le mail n'est jamais envoyé depuis le serveur d'OVH.

Pour info, histoire de tester, j'ai mis comme adresse d'expéditeur mon adresse perso Gmail, ce qui donne :

Code:
SmtpClient client = new SmtpClient();
client.Credentials = new System.Net.NetworkCredential("monEmailPerso@gmail.com", "monPass");
client.Port = 25;
client.Host = "smtp.gmail.com";
client.EnableSsl = true; //gmail oblige à enable le ssl
Je n'ai RIEN configuré de spécial dans le manager d'OVH (c'est surement mon erreur, mais je ne sais pas trop quoi modifier).
Actuellement je me fiche de l'adresse de l'expéditeur, ce peut être une adresse @ovh ou une adresse perso, je souhaiterai juste que mon mail parte (et arrive) correctement.

En vous remerciant pour votre aide,
Cordialement