OVH Community, votre nouvel espace communautaire.

les sous domaines n'aparaissent pas dans filezilla


royol
17/03/2015, 11h39
Citation Envoyé par JuGU
Tu as une erreur 404 car il y a une différence entre le chemin que tu as renseigné dans l'espace client, et le chemin du ftp.

Sur le ftp, tu as mis :
./www/consultant

Et sur l'espace client, tu as seulement mis :

consultant

Donc, tu as le choix, sois tu remets sur le ftp le dossier à la racine, donc en parallèle de www, soit sur l'espace client, tu renseignes le chemin www/consultant.

Et là ça fonctionnera.
Et bien merci JuGU, je viens de replacer le dossier en // du www, et effectivement cela fonctionne (comme l'avais proposé également Gaston plus haut).

Merci beaucoup, je vais pouvoir avancer maintenant.

Merci à tout le monde pour vos pistes et conseils.

JuGU
17/03/2015, 10h38
Tu as une erreur 404 car il y a une différence entre le chemin que tu as renseigné dans l'espace client, et le chemin du ftp.

Sur le ftp, tu as mis :
./www/consultant

Et sur l'espace client, tu as seulement mis :

consultant

Donc, tu as le choix, sois tu remets sur le ftp le dossier à la racine, donc en parallèle de www, soit sur l'espace client, tu renseignes le chemin www/consultant.

Et là ça fonctionnera.

royol
17/03/2015, 10h26
Bonjour à tous,

Merci de vos réponses.

Padpad, je n'ai pas compris, mais j'espère que tu as bien dormi.

Gaston et Jugu, pour l'emplacement des sous dossiers, de ce que j'avais compris c'était dans le WWW. du domaine principal, peut ^tre que je me trompe.

sinon Gaston pour les noms de sous-domaines, j'ai fait une faute de frappe dans le post précédent, niway.com n'existe pas.

Domaine de base : niceway-brazil.com.
deux sous-domaines : consultant.niceway-brazil.com & consultor.niceway-brazil.com.

J'ai mis un html "site en construction" dans les deux dossiers www.niceway-brazil.com/consultant et www.niceway-brazil.com/consultor.

En tapant www.niceway-brazil.com/consultant dans l'adresse du navigateur j'arrive bien à cette page "en construction".
Par contre en tapant www.consultant.niceway-brazil.com j'ai une page erreur 401. comme cela ne fait que 22 heures c'est peut-etre normal.

Je vais attendre et retenter, si cela ne marche pas je vais aussi contacter le support en parrallèle de vos aides car cela commence à me gonfler.

a bientôt et encore merci.

Gaston_Phone
16/03/2015, 20h54
@ padpad, en général tes remarques sont très pertinentes.
Laisse moquette et chapeau et dors bien.

padpad
16/03/2015, 20h43
(mode je mange mon chapeau on)
Le CMS ne crée pas le sous-répertoire, c'est moi qui ai fumé la moquette
(mode je mange mon chapeau off)

Gaston_Phone
16/03/2015, 13h21
Citation Envoyé par royol
Sur le manager dans la section domaine il y a maintenant :

Domaines .................................................. ............. Racine
consultant.niceway-brazil.com ......................................... consultant
consultor.niway-brazil.com........................................ ......... consultor
niceway-brazil.com........................................ ......................... www
consultant.niceway-brazil.com........................................ .... consultant
consultor.niway-brazil.com........................................ ........... consultor

Ensuite, je suis allé sur filezilla et dans le dossier WWW, j'ai créé deux sous-dossiers sous cette forme :
www/consultant
www/consultor
J'aurai plutôt créé (au même niveau que /www) :
/consultant
/consultor

- - - Mise à jour - - -

Quelles différences entre les domaines :
  • niceway-brazil.com
  • niway-brazil.com

JuGU
16/03/2015, 13h05
Vérifie bien que les chemins définis pour le sous domaines soient eux aussi en www/nomdudossier, sinon tu risques de te retrouver avec une erreur 404.

royol
16/03/2015, 12h50
Bonjour et encore merci.

Donc en suivant ces instructions, voici ce que j'ai fait :

Ce matin j'ai supprimé les deux sous domaines et répertoires correspondant sur le manager et j'ai recommencer (pour partir sur des bases saines.

Sur le manager dans la section domaine il y a maintenant :

Domaines .................................................. ............. Racine
consultant.niceway-brazil.com ......................................... consultant
consultor.niway-brazil.com........................................ ......... consultor
niceway-brazil.com........................................ ......................... www
consultant.niceway-brazil.com........................................ .... consultant
consultor.niway-brazil.com........................................ ........... consultor

Ensuite, je suis allé sur filezilla et dans le dossier WWW, j'ai créé deux sous-dossiers sous cette forme :
www/consultant
www/consultor

Si j'ai bien suivi ce qui a été dit, cela devrait être bon.

Cela veut donc dire que j'aurai deux accès possibles à ces blogs, l'un à l'adresse :

www.niceway-brazil.com/consultant et www.consultant.niceway-brazil.com (d'ici à 24 h).
www.niceway-brazil.com/consultor et www.consultor.niceway-brazil.com (d'ici à 24 h).

C'est bien cela ? et si oui il ne va y avoir un problème de duplicate content ?

Gaston_Phone
16/03/2015, 12h06
Citation Envoyé par royol
Par contre, si je crée ces dossiers (dans le dossier principal www.domaine.com), je dois les créer sous quels noms et quel chemin :
www.domaine/blog.domaine ou
www.domaine/www.blog.domaine ou
www.domaine/blog ?
La réponse est ici en #4 :
Citation Envoyé par Gaston_Phone
Il faut que tu crées au préalable et à la main via FileZilla les sous dossiers :
/www/blog1
/www/blog2
Pour www.blog1.domaine.com
Et www.blog2.domaine.com

JuGU
16/03/2015, 12h00
Bonjour royol.

Lorsque tu créés un sous-domaine, tu choisis le chemin de ton ftp vers lequel pointera ton sous-domaine.

Tu peux retrouver notre guide à ce sujet depuis ce lien : http://www.ovh.com/fr/g1332.attacher...ebergement_web

royol
16/03/2015, 10h43
Bonjour à tous,

Merci pour ces points d'éclaircissement.

Si je vous suis bien, selon vous les sous-domaines www.blog.domaine.com 1 et 2 sont créés, mais les dossiers sont à créer.



Par contre, si je crée ces dossiers (dans le dossier principal www.domaine.com), je dois les créer sous quels noms et quel chemin :
www.domaine/blog.domaine ou
www.domaine/www.blog.domaine ou
www.domaine/blog ?
Comment se fait la redirection du sous-domaine vers le bon dossier ?

Gaston_Phone
16/03/2015, 09h57
Citation Envoyé par padpad
Bizarre ... il me semble bien que le cms les créait quand on cochait la case ad-hoc
Je ne le pense pas.

Personnellement, j'ai toujours créé mes sous-dossiers destinés aux sous-domaines par FILEZILLA avant de créer le sous domaine.

padpad
16/03/2015, 07h58
Citation Envoyé par Gaston_Phone
Il faut que tu crées au préalable et à la main via FileZilla les sous dossiers :
/www/blog1
/www/blog2
Bizarre ... il me semble bien que le cms les créait quand on cochait la case ad-hoc

Gaston_Phone
16/03/2015, 07h28
Citation Envoyé par royol
J'ai suivi le processus 2 fois de suite pour les deux sous-domaines désirés :
nom : blog1 .domaine.com (blog2 la seconde fois),
nom du fichier cible : www/blog1 (blog2 la seconde fois),
Il faut que tu crées au préalable et à la main via FileZilla les sous dossiers :
/www/blog1
/www/blog2

Daniel60
16/03/2015, 00h25
Citation Envoyé par padpad
quand tu te connectes sous FTP tu devrais voir notamment un dossier www contenant www/blog1 et www/blog2
A condition que les répertoires aient été créés ! Ce n'est pas encore automatique

padpad
15/03/2015, 22h12
tout ce que tu dis parait normal, sauf

2 jours plus tard, quand je me connecte via filezilla, je ne vois que le dossier www.domaine.com, toujours aucun dossier ou fichier www.blog1(ou2).domaine.com.....
De la même manière aucun dossier nouveau d'aucune sorte n''apparait.
quand tu te connectes sous FTP tu devrais voir notamment un dossier www contenant www/blog1 et www/blog2

royol
15/03/2015, 21h49
Bonjour,

Voilà la description du problème.

J'ai un hébergement perso avec un nom de domaine :www.domaine.com et un site hébergé normalement et tout fonctionne.

Je souhaite implanter worpress pour deux blogs distincts.
J'ai donc voulu créer deux sous-domaines grâce à assistant manager.

J'ai suivi le processus 2 fois de suite pour les deux sous-domaines désirés :
nom : blog1 .domaine.com (blog2 la seconde fois),
nom du fichier cible : www/blog1 (blog2 la seconde fois),
Pays : france
activé la création du www.

Puis ok,

J'ai vu le message que tout est ok et que cela sera actif dans 24 h.

2 jours plus tard, quand je me connecte via filezilla, je ne vois que le dossier www.domaine.com, toujours aucun dossier ou fichier www.blog1(ou2).domaine.com.....
De la même manière aucun dossier nouveau d'aucune sorte n''apparait.

Je suis perdu,

1/ je ne sais pas si les sous-domaines ont été créés ou pas, donc si www.blog.domaine.com pourra être indexé par Google.

2/ je ne sais pas ou placer un fichier index.html pour faire un test depuis mon navigateur.

J'ai recherché sur Google et je n'ai rien trouvé de concluant sur le fait d'avoir fait la manip et de rien avoir sur filezilla, la seule chose trouvée est qu'il faut éventuellement créer le dossier soit même, mais où ? dans le dossier initial www.domaine.com ? ce sera alors considéré comme un sous domaine ou un sous dossier ?


Bref je ne comprend rien et j'aurais besoin s'il vous plait de vos lumières.

Merci par avance