OVH Community, votre nouvel espace communautaire.

Postfix n'envoie pas de mail


AnonymousCoward
12/03/2015, 09h49
Sinon, swaks est très supérieur à telnet pour ce qui est de diagnostiquer des soucis de SMTP. - http://www.jetmore.org/john/code/swaks/

Et maintenant, les actualités du Kazakhstan...

--
AnonymousCoward

franky
12/03/2015, 08h58
On avance....
J'arrive à envoyer et recevoir les mails en SMTP / 587 / TLS en utilisant comme identifiant une adresse mail avec le du domaine:
user@mondomaine.com et son mot de passe.
mais toujours pas avec postmaster@mondomaine.com....

Nowwhat
11/03/2015, 15h31
Citation Envoyé par franky
J'ai testé mais les mails ne partent pas non plus...
Commande pour tester:
netstat -naptul | grep 'master'

Si posfix n'écoute pas sur 'localhost', il te manque probablement ceci:
tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN 6218/master
En language clair: postfix n'écoute pas sur localhost (= 127.0.0.1 porte 25)
Car, dans master.cf, il te manque:
(ce que j'ai, localhost en mode IPv4 et IPv6 - porte 25 et submission = 587
Code:
127.0.0.1:smtp      inet    n       -       -       -       -       smtpd
::1:smtp      inet    n       -       -       -       -       smtpd

127.0.0.1:submission      inet    n       -       -       -       -       smtpd
  -o smtpd_tls_security_level=may
  -o smtpd_sasl_auth_enable=yes
  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
  -o milter_macro_daemon_name=ORIGINATING

::1:submission      inet    n       -       -       -       -       smtpd
  -o smtpd_tls_security_level=may
  -o smtpd_sasl_auth_enable=yes
  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
  -o milter_macro_daemon_name=ORIGINATING
A adapter suivant tes gouts et envies

Citation Envoyé par franky
Côté authentification SASL...une piste ?
Il te faut le remede puissance 10:
Google: SASL LOGIN authentication failed: Invalid authentication mechanism

franky
11/03/2015, 15h10
Peut-être une piste:

Code HTML:
hostname -d
com

franky
11/03/2015, 15h00
Normalement, tu pourrait faire plus simple : délivrer tes mails au '127.0.0.1 - port 25'
J'ai testé mais les mails ne partent pas non plus...

Côté authentification SASL...une piste ?

Nowwhat
11/03/2015, 13h55
Bonjour,

Mar 11 08:51:41 monserveur postfix/smtpd[8042]: warning: monsite.com[188.165.233.23]: SASL LOGIN authentication failed: Invalid authentication mechanism
Il faut chercher l'erreur coté authentification SASL - coté postfix, tout va bien.

T'aurias pu le voir quand tu continu un peu avec ton exemple:[root@monsite ~]# telnet smtp.monsite.com 587
Trying 188.165.233.23...
Connected to smtp.monsite.com.
Escape character is '^]'.
220 monsite.com ESMTP Postfix
ehlo monsite.com
250-monsite.com
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
starttls
220 2.0.0 Ready to start TLS
....... puis authentification - il est ou ?
Par contre, si tes sites sont sur la même serveur que ton serveur mail, pourquoi tu passe par 'submission' ? (tu va me dire: pourquoi pas - et t'as raison, je fait la même chose )

Normalement, tu pourrait faire plus simple : délivrer tes mails au '127.0.0.1 - port 25'.

La dépose des mails pour transport par Submission (587) fonctionne pour te clients-mail ? (Outlook, Thunderbird, etc etc ?)

franky
11/03/2015, 11h52
Bonjour,

Je suis sur un dédié
Release 3

Je n'arrive pas à envoyer de mails avec postfix. Il y a plusieurs domaines sur le serveur. Mais l'envoi ne marche qu'avec l'interface postfix ou roundcube mais pas à partir d'un formulaire sur un de mes sites.

Malgrès un 10/10 sur www.mail-tester.com, de nombreuses heures de recherches et de modifications / restauration de la configuration de postfix, sans succès, je sollicite votre aide.

Merci.

maillog

Code HTML:
Mar 11 08:51:41 monserveur postfix/smtpd[8042]: connect from monsite.com[188.165.233.23]
Mar 11 08:51:41 monserveur postfix/smtpd[8042]: setting up TLS connection from monsite.com[188.165.233.23]
Mar 11 08:51:41 monserveur postfix/smtpd[8042]: Anonymous TLS connection established from monsite.com[188.165.233.23]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
Mar 11 08:51:41 monserveur postfix/smtpd[8042]: warning: monsite.com[188.165.233.23]: SASL LOGIN authentication failed: Invalid authentication mechanism
Mar 11 08:51:41 monserveur postfix/smtpd[8042]: disconnect from monsite.com[188.165.233.23]
postconf -n

Code HTML:
alias_database = hash:/etc/aliases, hash:/etc/mailman/aliases
alias_maps = hash:/etc/aliases, hash:/etc/mailman/aliases
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/libexec/postfix
data_directory = /var/lib/postfix
debug_peer_level = 3
html_directory = no
inet_protocols = all
local_recipient_maps = unix:passwd.byname
mailbox_command = /usr/libexec/dovecot/deliver
mailq_path = /usr/bin/mailq.postfix
manpage_directory = /usr/share/man
milter_default_action = accept
mydestination = localhost.$mydomain, localhost, localhost.localdomain
mydomain = localdomain
myhostname = monsite.com
mynetworks = 127.0.0.0/8
myorigin = monsite.com
newaliases_path = /usr/bin/newaliases.postfix
non_smtpd_milters = inet:localhost:8891
readme_directory = /usr/share/doc/postfix-2.6.6/README_FILES
recipient_delimiter = +
sample_directory = /usr/share/doc/postfix-2.6.6/samples
sender_canonical_maps = hash:/etc/postfix/sender_canonical
sendmail_path = /usr/sbin/sendmail.postfix
setgid_group = postdrop
smtpd_milters = inet:localhost:8891
smtpd_recipient_restrictions = check_recipient_access mysql:/etc/postfix/sql/mysql_amavis_in.cf, permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
smtpd_tls_auth_only = yes
smtpd_tls_cert_file = /etc/pki/tls/certs/localhost.crt
smtpd_tls_key_file = /etc/pki/tls/private/localhost.key
smtpd_tls_loglevel = 1
smtpd_tls_security_level = may
smtpd_tls_session_cache_database = btree:/var/lib/postfix/smtpd_tls_cache.db
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
transport_maps = hash:/etc/postfix/transport
unknown_local_recipient_reject_code = 550
virtual_alias_maps = mysql:/etc/postfix/sql/mysql_virtual_alias_maps.cf, mysql:/etc/postfix/sql/mysql_virtual_alias_domain_maps.cf, mysql:/etc/postfix/sql/mysql_virtual_alias_domain_catchall_maps.cf, mysql:/etc/postfix/sql/mysql_virtual_mailing.cf
virtual_gid_maps = static:101
virtual_mailbox_base = /var/mail/vhosts
virtual_mailbox_domains = mysql:/etc/postfix/sql/mysql_virtual_domains_maps.cf
virtual_mailbox_maps = mysql:/etc/postfix/sql/mysql_virtual_mailbox_maps.cf, mysql:/etc/postfix/sql/mysql_virtual_alias_domain_mailbox_maps.cf
virtual_transport = dovecot
virtual_uid_maps = static:500
master.cf

Code HTML:
smtp      inet  n       -       n       -       -       smtpd
587       inet  n       -       n       -       -       smtpd
       -o smtpd_tls_security_level=encrypt
        -o smtpd_tls_auth_only=yes
        -o smtpd_tls_cert_file=/etc/pki/tls/certs/localhost.crt
        -o smtpd_tls_key_file=/etc/pki/tls/private/localhost.key
        -o smtpd_sasl_type=dovecot
        -o smtpd_sasl_auth_enable=yes
        -o smtpd_sasl_path=/var/spool/postfix/private/auth
        -o smtpd_recipient_restrictions=$external_submission_restrictions
        -o receive_override_options=no_address_mappings
pickup    fifo  n       -       n       60      1       pickup
cleanup   unix  n       -       n       -       0       cleanup
qmgr      fifo  n       -       n       300     1       qmgr
tlsmgr    unix  -       -       n       1000?   1       tlsmgr
rewrite   unix  -       -       n       -       -       trivial-rewrite
        -o append_at_myorigin=no
bounce    unix  -       -       n       -       0       bounce
defer     unix  -       -       n       -       0       bounce
trace     unix  -       -       n       -       0       bounce
verify    unix  -       -       n       -       1       verify
flush     unix  n       -       n       1000?   0       flush
proxymap  unix  -       -       n       -       -       proxymap
proxywrite unix -       -       n       -       1       proxymap
smtp      unix  -       -       n       -       -       smtp
relay     unix  -       -       n       -       -       smtp
        -o smtp_fallback_relay=
showq     unix  n       -       n       -       -       showq
error     unix  -       -       n       -       -       error
retry     unix  -       -       n       -       -       error
discard   unix  -       -       n       -       -       discard
local     unix  -       n       n       -       -       local
virtual   unix  -       n       n       -       -       virtual
lmtp      unix  -       -       n       -       -       lmtp
anvil     unix  -       -       n       -       1       anvil
scache    unix  -       -       n       -       1       scache
dovecot   unix  -       n       n       -       -       pipe
        flags=DRhu user=mailboxes:mailboxes argv=/usr/libexec/dovecot/deliver -f ${sender} -d ${user}@${nexthop}
amavisfeed unix -       -       n       -       2       smtp
        -o smtp_data_done_timeout=1200
        -o smtp_send_xforward_command=yes
        -o disable_dns_lookup=yes
        -o max_use=20
127.0.0.1:10025 inet    n       -       n       -       -       smtpd
        -o content_filter=
        -o smtpd_delay_reject=no
Résultat de Telnet:

Code HTML:
[root@monsite ~]# telnet smtp.monsite.com 587
Trying 188.165.233.23...
Connected to smtp.monsite.com.
Escape character is '^]'.
220 monsite.com ESMTP Postfix
ehlo monsite.com
250-monsite.com
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
starttls
220 2.0.0 Ready to start TLS