OVH Community, votre nouvel espace communautaire.

munin et i-mscp


Raln
13/03/2015, 15h48
Merci d'avoir pris le temps de regardé pour moi.
Je conclus donc que le soucis vient de plugin.
Je vais donc faire ce que tu m'a expliqué et je tiens au courant
Mais si j'ai bien compris ce plugin ne sert pas à grand chose ? ^^

Merci encore

Nowwhat
11/03/2015, 09h19
Conclusion: ce plugin, c'est un connerie.

Par exemple;
J'ai une base nommé 'teamspeak'.

J'ai un OS 'normal' donc ceci:
mysqlshow -v --status teamspeak
fonctionne.

Observe bien la colonne Data_length et Max_data_length.

Petit détail qui casse tout : Max_data_lengthn possède la valeur 2 puissance 48 (très grand donc)

Maintenant, va voir ton plugin, qui est un plugin munin type wildcard.
Ce qui veut dire, qu'on symlink pas mysql_isam_space_ /etc/munin/plugins mais qu'il faut y coller un nom d'une base,
Mon plugin munin dans se nomme donc ainsi:

Code:
root@ns311465:~# ls -al /etc/munin/plugins/mysql_isam_space_*
lrwxrwxrwx 1 root root 42 Mar 10 18:31 /etc/munin/plugins/mysql_isam_space_teamspeak -> /usr/share/munin/plugins/mysql_isam_space_
Ouvre ton plugin.
Ce que du perl donc rien de sorcier.
Code:
				my $value =
					$ABSOLUTE ? $fields[$index{Data_length}]
					: (100*$fields[$index{Data_length}]/$fields[$index{Max_data_length}]);
Quand
env.absolute est zéro
(env.absolute 0)
(dans /etc/munin/plugin-conf.d/munin-node)
ceci est préparé comme valeur de résultat:
100 * $fields[$index{Data_length}] / $fields[$index{Max_data_length}]
autrement dit: un petit valeur divisé par 2 puissance 48, multiplié par 100.
Autrement dit = le résultat sera zéro pointé sauf pour des tables avec des milliard des milliards des entrées. [ ]

Maintenant, on déclare
env.absolute à 100
(dans /etc/munin/plugin-conf.d/munin-node)

Code:
munin-run mysql_isam_space_teamspeak
va sortir des valeurs concernant la table teamspeak (il va simplement reproduire ce qui est présent dans la colonne {Data_length}.

Mais .... observe ligne 104 et 105 : on y instaure un seuil limite et warning sur env. "100".
Bien sur, pas mal de {Data_length} dépasse ce "100" donc l’affichage "Munin" va déclencher l'alerte : ton stat aura un bord rouge ....


En gros, il y a du travail à faire pour que ce plugin affiche la vrai taille d'une table.

Pour debug ce plugin, change sur ligne 143 temporairement "3600" pour "1" pour des raisons évidentes
Code:
		if ((stat ($STATEFILE))[9] > (time - 3600))

Nowwhat
10/03/2015, 20h55
Re.

Je travaille dessus : http://www.test-domaine.fr/munin/pap...teamspeak.html

Je reposte avec plus des détails quand j'ai compris quelque chose.

Raln
08/03/2015, 23h01
Hello,

J'ai cherché pas mal et je ne comprend pas pourquoi ce module pose un problème.
Quelqu'un aurait t-il une idée svp ?

Merci d'avance.

Raln
28/02/2015, 15h35
Je pense que sa doit être cela : (mais pas sur)

[mysql*]
user root
env.mysqlopts --defaults-file=/etc/mysql/debian.cnf
env.mysqluser debian-sys-maint
env.mysqlconnection DBI:mysql:mysql;mysql_read_default_file=/etc/mysql/debian.cnf
Voici la réponse de la commande debug :

/usr/share/munin/plugins# munin-run --debug mysql_isam_space_
# Processing plugin configuration from /etc/munin/plugin-conf.d/munin-node
# Setting /rgid/ruid/ to /116/0/
# Setting /egid/euid/ to /116 116/0/
# Setting up environment
# Environment mysqlopts = --defaults-file=/etc/mysql/debian.cnf
# Environment mysqluser = debian-sys-maint
# Environment mysqlconnection = DBI:mysql:mysql;mysql_read_default_file=/etc/mysql/debian.cnf
# About to run '/etc/munin/plugins/mysql_isam_space_'

Nowwhat
26/02/2015, 16h21
T'as le nom de ce plugin ?
T'as mis quoi comme paramétrage pour ce plugin ? (probablement /etc/munin/plugin-conf.d/munin-node )

munin-run --debug nom-du-plugin
donne quoi ?
(man munin-run )

Raln
26/02/2015, 13h33
Merci d'avoir pris le temps pour tes explications.
Je comprend mieux maintenant, il doit surement avoir un soucis avec le plugin en question, car le graph reste vide.

Nowwhat
24/02/2015, 22h37
Citation Envoyé par Raln
Merci pour ta réponse,
il n'y avait rien dans les logs, mais j'ai remplacé :
Allow from localhost 127.0.0.0/8 ::1
PAR :
Allow from all
Dans le fichier /etc/munin/apache.conf, et tout fonctionne !
Normal.
T'as limité tes connections à munin pour des demandes venant de ton propre serveur uniquement.
Ca va pas le faire.
T'as pas de browser dans ton serveur ..... (sauf si t'as un truc interface GUI desktop genre Bureau à Distance ou VNC).
Tu consulte ton munin à partir de l'extérieur, donc tout sauf 127.0.0.0/8 (== localhost)

Normalement (bis) c'est précisé dans le tuto que il faut que tu chance ça.

Par compte j'ai mysql InnoDB free tablespace qui est rouge : http://planet-upload.net/images/ce28...ee47cf7f2f.jpg et je ne comprend pas pourquoi
De mémoire, Munin te signale un "probleme": va voir chez moi: zéro problèmes en ce moment http://www.test-domaine.fr/munin/ (en haut à gauche)
Dans le paramétrage de minin concernant le plugin en question, c'est toi qui paramètre le seuil d'un warning ou problème.
A toi donc paramétrer ça.

Par contre, ton image montre un stat vide .... mais il y a quend même un problème. Test donc ce plugin avec munin-run
(man munin-run est indispensable )
Regarde toutes mes stats (3 serveurs) : http://www.test-domaine.fr/munin/ je n'ai pas de stats vide. J'ai paramétré et testé chaque plugin avant de décider si il est utile, ou pas.

Exemple d'un paramétrage d'un warning et problème (== erreur) = http://www.test-domaine.fr/munin/pap...mailqueue.html
en bas de l'écran, à droit.
Dès que le queue de postfix dépasse de "2", j'ai un warning - à partir de 4 il affiche "error" == rouge.
Ça m’indique que postfix n'arrive plus à distribuer des mails - mauvais signe normalement (sauf pour ceux avec le serveur hacké, ils ont des dizaines des milliers des mails dans le queue, c'est le cata total)
En cas de soucis, munin me balance un mail.

Raln
24/02/2015, 15h32
Par compte j'ai mysql InnoDB free tablespace qui est rouge : http://planet-upload.net/images/ce28...ee47cf7f2f.jpg et je ne comprend pas pourquoi

Raln
24/02/2015, 14h58
Merci pour ta réponse,
il n'y avait rien dans les logs, mais j'ai remplacé :

Allow from localhost 127.0.0.0/8 ::1
PAR :

Allow from all
Dans le fichier /etc/munin/apache.conf, et tout fonctionne !

Nowwhat
24/02/2015, 14h35
ah, un 403. Ca me parle déjà plus.

Ce 403 ?

Disons que le type apache2 qui s'exécute sous l'identité 'www' ne peut pas lire les fichiers dans le répertoire 'munin' (avec propio 'munin ?).

Google déborde déjà des proposition possibles : munin apache 403 forbidden

Raln
24/02/2015, 14h16
Merci pour ta réponse, mon virtualhost ré semble bien a sa pourtant.
Mais quand j'essaye d'y accéder : (depuis site.com/munin ou de depuis ip/munin)

Error 403

Forbidden
Je ne comprend pas du tout pourquoi.

Nowwhat
24/02/2015, 14h07
Normallement ™ on balace un fichier comme
Code:
Alias /munin /var/cache/munin/www


    Order allow,deny
    Allow From All
	Options None

    
        ExpiresActive On
    	ExpiresDefault M310
    

 

# Enables fastcgi for munin-cgi-graph if present

ScriptAlias /munin-cgi/munin-cgi-graph /usr/lib/munin/cgi/munin-cgi-graph

	Order allow,deny
	Allow from All
	
		SetHandler fastcgi-script
	


ScriptAlias /munin-cgi/munin-cgi-html /usr/lib/munin/cgi/munin-cgi-html

	Order allow,deny
	Allow from All
	
		SetHandler fastcgi-script
	/IfModule>
dans /etc/apache2/conf.d
et ça roule pour

http://[www.]mon-domaine-1.tld/munin (exemple: http://www.papy-team.org/munin/ )
http://[www.]mon-domaine-2.tld/munin (exemple: http://www.test-domaine.fr/munin/ )
etc

Si c'est n'est pas le cas, il faut voir pourquoi tes 'virtual servers' de apache2 sont mal foutus.

Également à voir: certains .htaccess peuvent appliquer une URL rewrting large spectre, avec comme résultat : Ko total (pas d'exemple, j'ai réparé ça)

Puis, en suite, à voir comment le "panel" à bousillé ta sauce.

Pourquoi tu http://IP/munin ? ( quoi que ça marche pour moi ...)

Raln
24/02/2015, 13h41
Bonjour,

Je possède un dédié sous debian 7 avec comme panel i-mscp dessus.
J'ai donc décidé d'installé munin pour pouvoir surveiller tout cela de plus près, sauf que je n'arrive pas à y avoir accès
car i-mscp prend le dessus.
Exemple, quand je tape http://ip/munin cela tombe directement sur un erreur i-mscp

Quelqu'un aurait t-il une solution svp ?

Merci d'avance.