OVH Community, votre nouvel espace communautaire.

Zend Framework sur OVH R3 Centos


cassiopee
26/02/2015, 07h47
Citation Envoyé par grogui
Code:
    - zendframework/zendframework 2.3.5 requires php >=5.3.23 -> no matching package found.
Pourtant je suis en php 5.3.3.
Justement, ZendFramework demande une version 5.3.23 et vous êtes seulement en 5.3.3

janus57
25/02/2015, 21h54
Bonjour,

Si vous voulez un PHP plus récent que je vous conseil Debian + Virtualmin, le panel sera +/- le même que la R3 (en terme de fonctionnalité) mais avec la "puissance" de Debian.

Cordialement, janus57

grogui
25/02/2015, 16h00
Il faut donc utiliser la version 2.2 (et pas la 2.3)

Code:
cd my/project/dir
git clone git://github.com/zendframework/ZendSkeletonApplication.git
cd ZendSkeletonApplication
php composer.phar require zendframework/zendframework 2.2.*
Merci à tous.

janus57
25/02/2015, 10h12
Bonjour,

ce lien n'a rien à voir avec votre problème car vous êtes pas sous Debian 6 et de toute façons PHP 5.3.3 < 5.2.23.

Y a plus de chance que cela ressemble à ce problème : https://github.com/phpDocumentor/php...r2/issues/1319

Cordialement, janus57

grogui
25/02/2015, 09h27
Citation Envoyé par Kioob
Bonjour,

Tu confonds le ZendEngine, c'est à dire le moteur, la machine virtuelle faisant tourner PHP et le ZendFramework qui est une librairie en PHP.

Bref, édité par la même société mais ça n'a rien à voir.
ok, compris.

Maintenant comment installer ZF2 ?

Selon certains, la version fournie avec OVH R3 n'est pas compatible avec zf2 2.3.5 :
http://stackoverflow.com/questions/2...-2-not-working

Kioob
24/02/2015, 07h26
Bonjour,

Tu confonds le ZendEngine, c'est à dire le moteur, la machine virtuelle faisant tourner PHP et le ZendFramework qui est une librairie en PHP.

Bref, édité par la même société mais ça n'a rien à voir.

grogui
24/02/2015, 00h23
Bonjour,

Je suis un noob en ZF2 et donc je cherche à l'utiliser sur mon serveur.
J'ai tenté une install comme indiqué ici :
http://framework.zend.com/manual/cur...tallation.html
Mais j'obtiens une erreur bizarre :
Code:
Loading composer repositories with package information
Installing dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - zendframework/zendframework 2.3.5 requires php >=5.3.23 -> no matching package found.
    - zendframework/zendframework 2.3.4 requires php >=5.3.23 -> no matching package found.
    - zendframework/zendframework 2.3.3 requires php >=5.3.23 -> no matching package found.
    - zendframework/zendframework 2.3.2 requires php >=5.3.23 -> no matching package found.
    - zendframework/zendframework 2.3.1 requires php >=5.3.23 -> no matching package found.
    - zendframework/zendframework 2.3.0 requires php >=5.3.23 -> no matching package found.
    - Installation request for zendframework/zendframework 2.3.* -> satisfiable by zendframework/zendframework[2.3.0, 2.3.1, 2.3.2, 2.3.3, 2.3.4, 2.3.5].

Potential causes:
 - A typo in the package name
 - The package is not available in a stable-enough version according to your minimum-stability setting
   see  for more details.

Read  for further common problems.
Pourtant je suis en php 5.3.3.

D'ailleurs un petit test php -v :
Code:
PHP 5.3.3 (cli) (built: Oct 28 2014 17:08:02) 
Copyright (c) 1997-2010 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
    with Suhosin v0.9.29, Copyright (c) 2007, by SektionEins GmbH
ça alors !! Zend est déjà sur mon serveur !!

Mais alors comment l'utiliser ? je teste un truc tout simple :
Code:
$mail = new Zend_Mail_Storage_Pop3(array('host'     => 'localhost',
                                         'user'     => username',
                                         'password' => 'password'));
Evidemment j'obtiens une erreur :

Code:
PHP Fatal error:  Class 'Zend_Mail_Storage_Pop3' not found in ...
Une idée ?

Merci