OVH Community, votre nouvel espace communautaire.

Ip DnS Reverse


cassiopee
18/02/2015, 15h47
Citation Envoyé par Asylum
Bonjour, je parle d'Ip free car ma reverse de mon ip free est sur mon domaine de chez OVH (et mon domaine de chez OVH est mis sur mon dédié )
Voyons voir :

Si l''adresse IP locale, chez le FAI Free, est par exemple 82.202.203.204.

Que l'on a configuré un nom de reverse pour cette adresse IP, mettons "irc.mondomaine.fr"

Et que le nom de domaine "mondomaine.fr" est géré au niveau DNS par le Kimsufi.

Est-ce que j'ai bien résumé la situation ?

Si oui, il faut déjà regarder :

1) est-ce que c'est seulement dans le Kimsufi que le reverse n'est pas correct ?
(dans le Kimsufi, via ssh, on tape "nslookup 82.202.203.204", on doit obtenir comme réponse "irc.mondomaine.fr", le nom de reverse)

2) est-ce que depuis n'importe où sur Internet, le reverse n'est pas correct ?
(par exemple via : http://www.whatsmyip.us/reversedns.php )

Asylum
18/02/2015, 14h35
Bonjour, je parle d'Ip free car ma reverse de mon ip free est sur mon domaine de chez OVH (et mon domaine de chez OVH est mis sur mon dédié )

cassiopee
18/02/2015, 11h10
ça ne change rien sur le fond mais ".ar", c'est l'Argentine, pas la Turquie

Pourquoi parler "d'ip free" si le serveur est un Kimsufi ? (donc ip OVH)

Asylum
18/02/2015, 01h15
Bonjour,

Je viens vous voir car vous êtes mon dernier recours avant un gros pétage de plomb. Je vous explique depuis le début ça sera plus simple.

J'ai un dédié kimsufi depuis quelques années (je n'ai jamais eu aucun problème ou très peu). Il y a un peu plus d'une semaine, je me suis aperçu que le dédié ne montrait plus (en SSH) la reverse de mon ip ( ip free = reverse via mon domaine ). Chose étrange !
Dans le dédié, j'ai d'installé un serveur IRC, avec robots eggdrop, services irc etc ...
Il s'avère que généralement, quand je me connecte sur mon irc, il me donne mon ip et ma reverse ip.. Mais la, ce n'est plus le cas, dès que je me connecte, mon server me donne une ip différente de mon ip FREE. J'ai fais un whois ip c est une ip Turque
.[00:42:44] Local host: 93-50-17-190.fibertel.com.ar (190.17.50.93)
-
.[00:42:52] Local host: 93-50-17-190.fibertel.com.ar (190.17.50.93)

J'ai fais un whois sur mon pseudo, mon robot me donne bien mon Ip free. ( mais sans la reverse).
Je me suis aperçu que mes robots ne peuvent pas se connecter sur la reverse du server IRC mais sur l ip (ip = irc.blablabla)

J'ai recherché d'ou venait le problème ( mes reverses sont toujours actives, mes reverses A, mes Cnames tout est toujours valide.
J'ai fait des recherches via le net et au vu des infos que j'ai eu j'ai donc refait Bind9, Apache,
Toujours pareil, pas de reverse et toujours cette ip Turque qui est à la place de ma reverse.
J'ai donc décidé de faire une réinstallation complète de mon dédié. Réinstalle faite, tout était revenu à la normal ( reverse ip, mes eggdrops qui se connectaient sur la reverse de Type A ( irc.blabla.blabla ).

2 ou 3h après la réinstallation, le problème s'est remanifesté de nouveau. Impossible de se connecter via la reverse Typa A de mon IRC mais obligatoirement par l'Ip. ( Hors que cela fonctionnait 2h avant ).
A nouveau cette ip Turque qui m'est donné à ma connexion sur mon IRC..
J'ai regardé les logs, rien. Il y avait des erreurs avec interfaces NEtwork. J4ai refais la conf.
Et hop, tout était redevenu comme avant. Reconnection sur le TypeA de mon IRC, mes eggdrops également. J'avais bien ma reverse qui était indiqué.

2h plus tard, ca recommence. Plus de reverse, à nouveau cette Ip Turque.

J'ai fais des commandes pour vérifier si mes ips, mes reverses, ( dnslookup, ... ) Tout est bon.

nslookup euro-tchat.fr ns.kimsufi.com
Server: ns.kimsufi.com
Address: 2001:41d0:3:1c7::1#53

Name: euro-tchat.fr
Address: 94.23.47.82


nslookup euro-tchat.fr
Server: 213.186.33.99
Address: 213.186.33.99#53

Non-authoritative answer:
Name: euro-tchat.fr
Address: 94.23.47.82

J'ai revérifié mon fichier interfaces ( etc/network)

[....] Running /etc/init.d/networking restart is deprecated because it may not r[warnble some interfaces ... (warning).
[....] Reconfiguring network interfaces...RTNETLINK answers: File exists
Failed to bring up eth0.
RTNETLINK answers: File exists
Failed to bring up eth0:0.
RTNETLINK answers: File exists
Failed to bring up eth0:1.
RTNETLINK answers: File exists
Failed to bring up eth0:2.
RTNETLINK answers: File exists
RTNETLINK answers: File exists
done.

Apache ne me donne aucune erreur. mes sites sont bien activés.

Dans le fichier resolv.conf j'ai l'ip du DNS de mon dédié 213.186.33.99.

Donc mon soucis, c'est cette histoire de reverse qui n'est pas affichée ni en SSH, ni via mes servers, mes eggdrops. Mais toujours cette maudite Ip à la place de ma reverse.

J'ai cherché via le net. J'ai fais des configs comme il était indiqué via des sites, des forums. Toujours pareil, Rien pas de reverse en vu, probleme de connection sur le server irc ( on passe par l'ip et non par le TypeA )

S'il vous plait, est-ce que quelqu'un pourrait m'aider ou me dire ce qui se passe. C'est la 1ere fois que je rencontre un problème de ce genre. Je ne sais plus quoi faire. Réinstallé à nouveau serait inutile.

Je vous confirme que tout est bien configuré dans le panel OVH ( mes DNS, etc ... )

D'avance merci

(Je vous mets ma conf de interfaces )

. # The loopback network interface
auto lo
iface lo inet loopback
address 127.0.0.1
netmask 255.0.0.0
broadcast 127.255.255.255
network 127.0.0.0


auto eth0
iface eth0 inet static
address 94.23.47.82
netmask 255.255.255.0
network 94.23.47.0
broadcast 94.23.47.255
gateway 94.23.47.254

auto eth0:0
iface eth0:0 inet static
address 188.165.36.42
netmask 255.255.255.255
broadcast 188.165.36.42

auto eth0:1
iface eth0:1 inet static
address 188.165.36.241
netmask 255.255.255.255
broadcast 188.165.36.241


auto eth0:2
iface eth0:2 inet static
address 87.98.169.201
netmask 255.255.255.255
broadcast 87.98.169.201