OVH Community, votre nouvel espace communautaire.

Configuration sous domaine


xclam
03/02/2015, 14h14
Bon j'ai tout désactivé puis réactivé les virtualhost un à un.

Sur mon sous domaine j'ai eu un warning [warn] NameVirtualHost *:80 has no VirtualHosts

J'ai édité mon sous domaine en remplaçant
par
Re [warn] NameVirtualHost *:80 has no VirtualHosts

J'ai remis comme avant :
Et tout fonctionne !

xclam
01/02/2015, 15h02
Citation Envoyé par janus57
Bonjour,

quoi comme OS ?

Debian ? Ubuntu ?

cette commande fonctionne ? :
Code:
apache2ctl -S
Cordialement, janus57
C'est une Debian
Résultat :
Code:
VirtualHost configuration:
92.222.21.62:80        lislesadam.mypitaya.fr (/etc/apache2/sites-enabled/lisleadam:1)
wildcard NameVirtualHosts and _default_ servers:
*:80                   is a NameVirtualHost
         default server www.mypitaya.fr (/etc/apache2/sites-enabled/pitaya:1)
         port 80 namevhost www.mypitaya.fr (/etc/apache2/sites-enabled/pitaya:1)
Syntax OK

janus57
01/02/2015, 12h44
Bonjour,

quoi comme OS ?

Debian ? Ubuntu ?

cette commande fonctionne ? :
Code:
apache2ctl -S
Cordialement, janus57

xclam
01/02/2015, 12h24
Citation Envoyé par Freemaster
version d'apache ?

sous la 2.4 les directives suivantes ne fonctionnement plus :

Order allow,deny
allow from all
C'est une 2.2.22

Freemaster
31/01/2015, 20h24
version d'apache ?

sous la 2.4 les directives suivantes ne fonctionnement plus :

Order allow,deny
allow from all

xclam
31/01/2015, 17h27
Bonjour,

Depuis une mise a jour d'apache, mes configurations de sous domaines ne fonctionne plus...

ports.conf :
Code:
NameVirtualHost *:80
Listen 80


    # If you add NameVirtualHost *:443 here, you will also have to change
    # the VirtualHost statement in /etc/apache2/sites-available/default-ssl
    # to 
    # Server Name Indication for SSL named virtual hosts is currently not
    # supported by MSIE on Windows XP.
Listen 443



Listen 443
Domaine principal
Code:

        ServerName www.mypitaya.fr
        ServerAlias mypitaya.fr
        DocumentRoot /home/sites/pitaya
        
                Options FollowSymLinks
                AllowOverride None
        
        
                Options Indexes FollowSymLinks MultiViews
                AllowOverride All
                Order allow,deny
                allow from all
        

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        

        ErrorLog ${APACHE_LOG_DIR}/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog ${APACHE_LOG_DIR}/access.log combined
et le sous domaine
Code:

        ServerName lislesadam.mypitaya.fr
        DocumentRoot /home/sites/lislesadam
        
                Options FollowSymLinks
                AllowOverride None
        
        
                Options Indexes FollowSymLinks MultiViews
                AllowOverride All
                Order allow,deny
                allow from all
        

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        

        ErrorLog ${APACHE_LOG_DIR}/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog ${APACHE_LOG_DIR}/access.log combined
Les VirtualHost sont bien activés (a2ensite) et j'ai redémarré le serveur.

Avez vous une idée ?