OVH Community, votre nouvel espace communautaire.

Mettre site en ligne


kwasi
11/10/2006, 13h48
Citation Envoyé par Guillaume
J'ai donné la réponse à vos problèmes plus haut.
Il ne faut pas oublier d'effacer la page index.html et le dossier memo qui sont présents dans www.
Bonjour
j'ai bien effacé le dossier memo dc le fichier index qui y était. Malgré tout quand je tape mon URL passerellenordsud.net, ma page d'ouverture s'affiche 1 seconde et me redirige sur l'adresse avec passerellenordsud.net/memo/Index.htm. C'est donc une page d'erreur 404 : impossible de trouver la page qui s'affiche. J'essaie depuis hier, pouvez-vous m'aider s'il vous plait?
Merci

Duglan
11/10/2006, 10h23
Bonjour a tous alors je vient continuer la série "j'ai un probleme"
Je vous explique:
J'ai acheter un kit graphique que je n'ai pas encore modifier enfin si juste une chose la page index se nommait theme.php donc je la rennome en index.php, j'up tout sur mon ftp et la miracle quand je tape l'url de mon site http://www.duglan.fr j'ai une page blanche :s Donc voila si vous avez une réponse a sa merci de me la faire parvenir au plus vite.
Merci d'avance
Duglan

Daniel60
07/10/2006, 11h20
Mes excuses, je n'ai pas bien lu : à partir du menu il y a effectivement affichage du choix, mais cela semble conforme au code actuel, non ?
Pour obtenir un autre affichage, il faut coder en utilisant des frames : alors seul le frame maitre apparaît.

Lagrue
07/10/2006, 11h18
Oui le site s'affiche normalement mais je voudrait quand on navigue sur mon site (clique sur menu ...) toujour avoir comme url www.essentielf1.com et non www.essentielf1.com/index.php?choix=pilotes par exemple !
Vous comprenez ?

Daniel60
07/10/2006, 10h43
Pour moi le site s'affiche normalement . Problème de DNS ou de cache du navigateur ?

Mes excuses, je n'ai pas bien lu : à partir du menu il y a effectivement affichage du choix, mais cela semble conforme au code actuel, non ?
Pour obtenir un autre affichage, il faut coder en utilisant des frames : alors seul le frame maitre apparaît.

Lagrue
07/10/2006, 10h32
Bonjour voila l'adresse de mon site Essentielf1 et quand je clique dans mon menu, mon url change elle devient par exemple sous cette forme : http://www.essentielf1.com/index.php?choix=accueil. N'y a t'il pas moyen de cacher tout le superflu et ne laissé apparant que www.essentielf1.com ??
J'ai vu des site internet de ce genres ! Est une option d'ovh ou mon code a changer merci

jab
07/10/2006, 09h26
Bonjour je n'arrive pas a activer mon site quand je rentre l'adresse sa me dit :
Welcome in OVH.

The requested URL was not found on this server

gerrygwada
01/10/2006, 19h52
désolé je ne comprend pas, j'ai lu jusqu'a la page 15 du forum et tous les sujets afférents à la mise en ligne et manifestement tous les débutants ont le même problème.

Je ne trouve pas le fameux répertoire www quant à la racine et je ne sais même pas ou chercher.
j'ai crée mon site avec thundersite et le ftp est intégré.
Dans mon architecture de site (sur mon disque dur) je n'ai pas trouvé de répertoire www non plus, bref je ne comprend rien.
Ou alors je suis trop pressé et je dois encore attendre car mon hébergement est récent ?

Apparement j'ai tranféré mon site trois fois aujourd'hui sur ovh !!! mais j'arrive toujours pas à y accéder.
Peut être qu'un Tuto très précis et détaillé pourrait aider les novices

Daniel60
01/10/2006, 18h45
Juste sous la racine du site

gerrygwada
01/10/2006, 18h40
J'ai le même probleme de fichier index livré par défautqui s'affiche au lieu de mon site, je lis vos explications mais je ne comprend pas.


alors question, je trouve ou le répertoire www ?


Merci
olivier

RB3124-OVH
30/09/2006, 08h44
tu peux me donner l'adresse de ton site afin de voir les problèmes et quel logiciel ton amie utilise
je pourrais peut être t'aider

rockerguitar
26/09/2006, 17h44
Je viens de le télécharger justement
Allez hop, transfert de fichiers en cours
Merci encore

EDIT : Ah, petit problème, Filezilla me met ça comme message :
Etat : Connexion à ftp.xxxxxxx.xx ...
Etat : Connecté à ftp.xxxxxxx.xx
Attente du message d'accueil...
Erreur : Déconnecté du serveur
Erreur : Impossible de se connecter !

Cela a-t-il un rapport avec le fait que lorsque je vais sur mon site, il y ait marqué : "Domaine en cours d'installation"

Merci pour l'aide

Missions courte
25/09/2006, 18h18
Citation Envoyé par rockerguitar
Boarf je prendrais un autre ftp pour mettre mes pages dynamiques, style smartftp
Merci encore
Je te suggère FileZilla : génial

rockerguitar
25/09/2006, 16h54
Citation Envoyé par Missions courte
Bonjour,
Il me semble qu'en standard Nvu ne génère que des pages fixes.
Pour des pages dynamiques, c'est possible, mais il te faudra apprendre les codes PHP et MySQL.

Regarde aussi le forum : http://www.geckozone.org/forum/viewtopic.php?t=24967

Ok, merci pour l'info je savais pas que c'était que les pages fixes...
Boarf je prendrais un autre ftp pour mettre mes pages dynamiques, style smartftp
Merci encore

Elised
25/09/2006, 16h36
Citation Envoyé par Guillaume
85% des gens utilisent IE.
Malheur à moi , mon site http://www.massagepourbebe.org
passe sur Mozilla, mais pas sur IE, ARGGGGGGGGGGGGHH j'y arriverai, je ne sais pas comment, mais j'y arriverai

Daniel60
25/09/2006, 12h39
Il me semble qu'en standard Nvu ne génère que des pages fixes.
Ouais, et il ne traite pas les frames...

Missions courte
25/09/2006, 08h00
Citation Envoyé par rockerguitar
- J'utilise Nvu (que je recommande chaudement) pour faire mes pages web. Il intègre un client ftp : puis-je l'utiliseer pour mettre mon site en ligne ?
Bonjour,
Il me semble qu'en standard Nvu ne génère que des pages fixes.
Pour des pages dynamiques, c'est possible, mais il te faudra apprendre les codes PHP et MySQL.

Regarde aussi le forum : http://www.geckozone.org/forum/viewtopic.php?t=24967

rockerguitar
24/09/2006, 19h13
ok merci shadow
donc, dans 48h, j'aurais le site dispo, ça me laisse le temps de continuer mes pages web
encore merci

Shadow aok
24/09/2006, 18h34
Pour ta première question, tu possèdes la réponse dans la question et même chose pour la deuxième, du moment que c'est un client ftp ça marche.

rockerguitar
24/09/2006, 18h23
Salut à tous !
Comme vous pouvez le voir, je suis nouveau
Et j'ai deux ptites question à poser ... :
- J'ai souscris à un offre Start 5Go (hébergement perso donc) et j'ai aussi pris un nom de domaine. Lorsque je vais sur l'adresse de mon site, la page marque que le site est indisponible, comme lorsque je vais sur un site qui n'existe pas (www.jvtdevdueyv.com par exemple [tapé au hasard sur le clavier]). Est-ce normal ou pas ? (pour info, j'ai reçu un mail disant que mon site serait dispo entre 24 et 48h).
- J'utilise Nvu (que je recommande chaudement) pour faire mes pages web. Il intègre un client ftp : puis-je l'utiliseer pour mettre mon site en ligne ?
Voila, si vous pouviez me répondre, ça serait top
Merci à OVH pour son service d'hébergement en tous cas
rocker

Guillaume
22/09/2006, 15h08
Ce n'est pas le même moteur de rendu et ils respectent différemment les normes du w3c (bon ok, pour ie le terme respecter est un pléonasme).

aurelie_amboise
22/09/2006, 15h04
Bonjour,

Merci pour les deux nouvelles réponses que j'ai reçues et qui, je pense, vont m'être d'une grande aide. Suite au dernier message, je me suis rendue sur les différentes pages de mon site (celles qui fonctionnent et celles qui ne fonctionnent pas) et j'ai effectivement constaté des différences de codes. Pour chaque page qui fonctionne, le bon code (que vous m'avez indiqué) est entré. Je sais maintenant que l'inactivité de certaines fonctionnalités provient de là. MERCI!!!! Cela va grandement nous aider à avancer !!!
C'est vrai également que, si mon site ne fonctionne que sous IE, ça peut être une bonne chose de le signaler pour que les gens qui fonctionnent sous Firefox sachent pourquoi.
A titre purement informatif, savez-vous pourquoi il existe de telles différences de résultat entre firefox et IE? Existe-t-il un moyen pour qu'un site fonctionne de la même manière sous firefox et IE?
Et contente que le design du site vous ait plu....c'est déjà ça !!!

Encore merci,
Aurélie

marc.pasteur
22/09/2006, 09h50
bonjour,

vu que j'avais 5mn je me suis penché sur votre probleme.
en fait l'erreur est la suivante :
dans le fichier qui fonctionne


dans celui qui ne fonctionne pas


vous pouvez voir que dans la 2eme partie il essaye d'aller chercher le fichier dans un repertoire qui n'existera pas sous OVH.
je ne connais pas GoLive je ne peux donc pas dire ce qu'il faut faire pour corriger le probleme mais en tout cas il faut faire pareil que dans le 1er cas.

je vous conseillerai également de mettre un avertissement pour dire que le site ne fonctionne qu'avec IE car cela risque de faire bizarre à 15% des gens
Avec Firefox par exemple on ne peut pas quitter la page d'accueil.

sinon au niveau design je n'ai rien à redire c'est superbe !

bon courage pour vos debuts dans le fabuleux monde d'Internet

cordialement,
Marc Pasteur

Daniel60
22/09/2006, 08h48
Bonjour,
A mes débuts sur OVH, je suis tombé sur un problème de ce genre : certaines pages ne s'affichait pas ... tout simplement parce que les liens ne correspondaient aux pages contenant des majuscules. Sur les systèmes Unix 'monlien.htm' ce n'est pas la même chose que 'Monlien.htm' !!!

aurelie_amboise
21/09/2006, 18h03
Ok, c'est très sympa de ta part,
Bonne soirée
Aurélie

Guillaume
21/09/2006, 17h55
Citation Envoyé par aurelie_amboise
ou dû à un délai de chargement... puisque certaines pages s'affichent très bien...
Pas compris là.

Guillaume
21/09/2006, 17h54
Citation Envoyé par aurelie_amboise
Ah au fait, mon adresse msn c'est aurelie_amboise@hotmail.fr
Je te contacterai ce we, je code déjà assez en semaine

aurelie_amboise
21/09/2006, 17h17
ou dû à un délai de chargement... puisque certaines pages s'affichent très bien...

Guillaume
21/09/2006, 17h16
Non

Pas avec un site comme le tien, c'est-à-dire sans langage dynamique (php & compagnie).

aurelie_amboise
21/09/2006, 17h09
est-ce que le fait que les fonctionnalités ne marchent pas toutes peut être dû à un problème d'hébergement?

aurelie_amboise
21/09/2006, 17h06
c'est dommage pour les 15% restants...

Guillaume
21/09/2006, 17h04
85% des gens utilisent IE.

aurelie_amboise
21/09/2006, 17h02
Ah au fait, mon adresse msn c'est aurelie_amboise@hotmail.fr

aurelie_amboise
21/09/2006, 17h00
J'aime bien entendre le mot "c'est simple", dans la bouche des informaticiens.... On n'a pas la même vision des choses!!! Et concrètement, il y a qd même plus de personnes qui utilisent IE, non? Histoire de me rassurer...

Guillaume
21/09/2006, 16h57
C'est simple, ça marche sous IE et pas sous firefox.
C'est assez difficile d'avoir le même résultat sur tous les navigateurs.

aurelie_amboise
21/09/2006, 16h54
Alors là, je vais devenir folle... et je ne comprends plus rien...déjà que je n'y comprenais pas grand chose

Guillaume
21/09/2006, 16h51
Si cela peut te rassurer, le passage de la souris ne fait rien sur les deux pages

Je suis sous firefox et linux.

aurelie_amboise
21/09/2006, 16h50
Alors, pour te donner un exemple, si tu vas sur la page http://www.sunset-evenements.fr/page.../ethiqueP.html, lorsque tu passes avec la souris sur "notre charte économique" par ex, le texte s'affiche en dessous. par contre si tu vas sur la page http://www.sunset-evenements.fr/page...m/Ethique.html, le mécanisme doit être le même, mais là, ça ne marche pas... c'est ce genre de problème

Guillaume
21/09/2006, 16h43
Indique moi les urls des pages qui ne vont pas d'après toi, car je n'ai aucun lien sur la page principale.

aurelie_amboise
21/09/2006, 16h39
Et pour le fait que, sur sunset-evenements par ex, il y ait des pages où tout marche impeccable et d'autres non, tu as une idée???

Guillaume
21/09/2006, 16h39
Sinon, tu m'enverras un mail avec les infos nécessaires ou un contact msn, et je te montrerai comment régler ton problème de façon propre (sans redirection ni autre).

aurelie_amboise
21/09/2006, 16h37
Bon bah ça devrait aller alors... même moi je sais faire!!!!

Guillaume
21/09/2006, 16h26
Oui, enfin là, c'est juste un copier/coller à faire dans un nouveau fichier.

aurelie_amboise
21/09/2006, 16h23
Ok merci pour l'info, je lui communique de suite en espérant qu'elle saura faire,
Aurélie

Guillaume
21/09/2006, 16h16
Aucun de tes sites ne comporte de fichier nommé index.html directement dans www.

Sinon tu peux créer un fichier index.php dans www/ qui contient ceci :
Code PHP:
header('Location: pages/Accueil.html');
?>
Et cela fera tomber tes domaines sur tes sites.

aurelie_amboise
21/09/2006, 16h10
Mes deux domaines sont : www.sunset-evenements.fr et www.sunset-wedding.com.
Elle a changé quelques trucs, on peut accéder aux deux sites mais pas directement sur l'accueil et certaines fonctionnalités ne marchent toujours pas.
Merci pour ton aide,
Aurélie

Guillaume
21/09/2006, 15h08
Si c'est la première page qui s'affiche quand tu vas sur ton site, c'est qu'il s'agit d'un fichier index.qqchose

Indique moi ton domaine

aurelie_amboise
21/09/2006, 14h50
comment savoir d'où vient l'erreur de la page sans titre ? car sur le second site que j'ai mis en ligne la même erreur se produit.

Guillaume
21/09/2006, 14h41
Non, si tu mets bien tes fichiers, c'est immédiat.

D'ailleurs, le "page sans titre" est dû à une de tes pages.

aurelie_amboise
21/09/2006, 14h37
Alors, je viens de lui demander. apparement, tout est en images donc il n'ya pas de fichier css. Et elle utilise en aperçu soit golive, soit internet explorer.
Sinon, elle a fait les changements pour index et memo et à présent, une page blanche avec marqué "page sans titre -microsoft internet explorer" apparaît et on ne peut donc plus accéder aux pages. Est-ce parce qu'il y a un délai d'activation de la part d'ovh ou l'effet doit être immédiat?

Aurélie

Guillaume
21/09/2006, 11h22
Vérifie qu'il ne manque pas un fichier css par exemple.
Sur son pc, elle parcourt le site avec quel navigateur ? Avec GoLive directement ?

aurelie_amboise
21/09/2006, 11h20
Merci à tous pour vos réponses et merci Elised,ça fait du bien dans ces grands moments de solitude de voir que l'on est pas seuls.

En effet, j'ai fait faire mon site par une amie qui pensait en être capable et elle se heurte à bon nombre de difficultés qu'elle n'avait pas anticipées. Donc, je cherche des solutions pour lui venir en aide. Elle travaille sur Adobe Go Live pour la première fois et lorsque l'on a testé le site sur son PC, toutes les fonctionnalités marchaient. Maintenant qu'il est en ligne, nous rencontrons trois problèmes majeurs :
1/ les pages ne sont plus centrées
2/ les boutons ne changent plus de couleur au passage de la souris
3/ lorsque l'on survole certains mots, de nouveaux cadres doivent s'afficher; plus rien ne s'affiche
et elle ne comprend pas d'où cela peut venir vu que lorsque l'on teste de son ordi, tout marche, il y a de quoi devenir fou!!!

Y-aurait-il des éléments à télécharger sur le serveur que nous aurions oubliés?? Quelqu'un aurait-il une idée sur la ou les sources du problème...

Merci pour vos réponses, vous m'êtes d'une aide précieuse, d'autant que le temps m'est compté...

Je tenais aussi à dire que c'est la première fois que je me rends sur un forum de ce type et que je suis vraiment agréablement surprise de l'entraide et de la solidarité qui y règne...j'espère moi aussi un jour pouvoir me rendre utile...mais dans un autre domaine !!!!

Aurélie

Guillaume
21/09/2006, 10h25
J'ai donné la réponse à vos problèmes plus haut.
Il ne faut pas oublier d'effacer la page index.html et le dossier memo qui sont présents dans www.

Elised
21/09/2006, 10h08
Citation Envoyé par Missions courte
Ce sont des notions de bases qu'il est nécessaire d'avoir.

Pour mettre un site Internet en place, il est important d'avoir un minimum de connaissances HTM et éventuellement de PHP.
ça veut dire que quand on ne connait pas on ne fait rien ?
Et si on a besoin d'un site, qu'on a personne dans l'entourage qui peut aider et pas les sous pour le faire faire ?
Ce qui est mon cas! Et je peux vous dire que c'est très frustrant de se retrouver devant un mur.
En plus évidement, comme Aurelie, j'ai la page index qui s'affiche !
Please, soyez sympa pour les novices

muab
21/09/2006, 09h13
Bonjour,

voici ma reponse...

1. installe easyphp sur ton pc...
2. teste ton site avec ca d'abord
3. ensuite, quand tu utilises FTP, au moins tu sais ce que tu fais


Missions courte
21/09/2006, 09h09
Citation Envoyé par Guillaume
Il te faut une page index.html/index.php/index.htm/index.php3 (au choix) directement dans www.
Ce sont des notions de bases qu'il est nécessaire d'avoir.

Pour mettre un site Internet en place, il est important d'avoir un minimum de connaissances HTM et éventuellement de PHP.

Guillaume
21/09/2006, 08h34
Il te faut une page index.html/index.php/index.htm/index.php3 (au choix) directement dans www.

aurelie_amboise
21/09/2006, 08h31
Bonjour,
Moi aussi, j'ai quelques soucis avec la mise en ligne de mon site. Pourtant, j'ai bien effacé le fichier index.html, mais lorsque je tape le nom de domaine de mon site, j'arrive sur une page qui m'affiche les éléments suivants :

Index of /
Name Last modified Size Description
--------------------------------------------------------------------------------
Parent Directory 19-Sep-2006 03:42 -
GeneratedItems/ 21-Sep-2006 05:15 -
css/ 21-Sep-2006 05:15 -
images/ 21-Sep-2006 05:15 -
memo/ 19-Sep-2006 03:42 -
pages/ 21-Sep-2006 05:25 -

Il faut ensuite que je clique sur pages puis que je sélectionne la page d'accueil pour que le site fonctionne.
Comment faire pour arriver directement sur la page d'accueil de mon site????

Merci pour vos lumières!!!
Aurélie

Guillaume
19/09/2006, 18h26
Pense aussi à effacer le fichier index.html et le dossier memo/ qui sont dans www.

Tibre44
19/09/2006, 18h15
Bonjour,

As-tu bien placé par ftp ton site dans le répertoire www ? Ce que tu vois là est le fichier index livré par défaut.

Bienvenue

Matthleboss
19/09/2006, 18h02
Bonjour,

J'ai pris un hebergement sur OVH, mais j'arrive pas à mettre mon site en ligne
Quand je vais sur l'adresse du sitesa me met sa

Bienvenue sur notre offre Start

Besoin d'assistance ?

1. Consultez nos guides :
* Mettre votre site en ligne
* Astuces PHP chez OVH
* Taches automatisées (CRON)
2. Discutez avec nos autres utilisateurs sur notre forum
3. Toujours pas de solution ? Contactez le support ou téléphonez-nous

Les outils à votre disposition :

* Phpmyadmin
* Votre consommation
* Statistiques
* La configuration PHP et PHP5 de votre hébergement
* Les modules Perl installés sur votre hébergement

Merci d'avoir choisi OVH

Et j'aimerais que quand je tape l'adresse ben on tombe sur mon site et pas la dessus !

Merci de votre aide