OVH Community, votre nouvel espace communautaire.

problème spam roundcube


Raln
04/02/2015, 14h15
D'accord, je vais regarder cela.
Merci pour ton explication

Nowwhat
30/01/2015, 18h53
Ah, non.
D'abord, faut se documenter !!
Pour comprendre: ça me pris quelques années - mais je suis lent, je m'occupe de mon serveur qu'un heur par jour.

Inutile de créer un champs TXT - je me demande d'ailleurs pourquoi tu poste la question.
Google (un clique) + "ipv6 champ DNS" + Entrée et t'as la réponse qui tombe: ce champs s'appelle "AAAA".
Exemple:
Code:
.....
	A	5.196.43.182
	AAAA	2001:41d0:2:927b::15
.....
Concernant postfix: ça débute ici: http://postfix.traduc.org/index.php/IPV6_README.html

En tout cas: il te faut un journal (le truc papier qui arrive dans ton boite au lettre "La Poste" chaque jour).
Pour connaître le pharmacie qui est 'de garde'. T'en auras besoin - ça va être .... longue .... mais t'as le temps

Raln
30/01/2015, 16h24
D'accord, il faut donc ajouter la prise en compte de l'ipv6 dans postfix ?
Puis créer un champ TXT avec l'ipv6 aussi ?

Nowwhat
30/01/2015, 01h15
Et le mail est bien authentifié etc etc ?
Si le 'syntax' de ton mail est ok, mais c'est quand même spam, t'as deux choix:
1) rien faire - car ça regarde gmail après tout. C'est du gratuit donc il ne faut pas se poser des questions. Peut être avec le temps ça changera. T'as du quand même bouriner gmail avec des mails 'pas correct' est gmail possède quelque chose comme une sorte de mémoire (listage interne). Il te probablement te pardonner au bout de x temps.
2) montrer gmail que t'es sérieux. Utilise des moye,s que des spammeurs n'utilisent encore peu : va pour le Ipv6 - va pour le DMARC (que gamil reclame de toute façon déjà).

Raln
29/01/2015, 13h51
Merci pour vos réponses.
Le soucis c'est qu'avec le webmail pareil, les emails arrivent dans les spams chez gmail.

fritz2cat
29/01/2015, 08h20
Citation Envoyé par Nowwhat
à la limite,demande avast qu'il arrête de signer tes mails. Il ne s'agit que de la pub ..... qui peut être vu comme spam .... Il s'agit d'un simple paramétrage d'avast.
J'ai failli le dire, mais ça ne justifie pas que Gmail mettre ce mail dans le dossier spam.
Cette signature n'est pas un indicateur de spam puisque un spam n'est pas signé Avast!
Cette signature n'est pas un indicateur de ham (non-spam) puisque les spammeurs peuvent mimiquer la signature Avast!
Donc rester neutre.

Nowwhat
29/01/2015, 07h26
T'es bon:
Code:
Received-SPF: pass (google.com: domain of raln@domaine.com designates 92.xxxx.36.170 as permitted sender) client-ip=92.xxx.36.170;
Authentication-Results: mx.google.com;
       spf=pass (google.com: domain of raln@domaine.com designates 92.xxx.36.170 as permitted sender) smtp.mail=raln@domaine.com;
       dkim=pass header.i=@xxxx-ados.net
édit: à la limite,demande avast qu'il arrête de signer tes mails. Il ne s'agit que de la pub ..... qui peut être vu comme spam .... Il s'agit d'un simple paramétrage d'avast.

fritz2cat
29/01/2015, 06h43
Gmail t'a classé ce mail dans les spams ?
Franchement, je ne vois rien à y redire.
L'adresse IP de ton serveur VPS n'a l'air blacklistée nulle part.
DKIM OK
SPF : j'enlèverais la clause "mx" , car ton domaine n'a pas de mx. Mais ça me semble mineur comme erreur.

Je serais toi, je demanderais à Gmail pourquoi ce mail est classé comme spam. Mais je n'ai jamais eu à contacter le support Gmail, je ne sais pas par où on peut passer pour ça.

Raln
28/01/2015, 22h37
Voici un mail envoyé sur gmail depuis un client mail : http://pastebin.com/GZxJEWnW

Merci pour l'aide

fritz2cat
28/01/2015, 21h29
Peux-tu poster un message complet en code source (en-tête et contenu) sur pastebin.com (en masquant gentiment mais pas trop les adresses e-mail, et en ne changeant pas les adresses IP ni les noms des serveurs)

Frédéric

Raln
28/01/2015, 21h04
En effet, j'avais pas compris cela. Merci.

Les mails arrivent toujours dans les spams chez gmail et hotmail est-ce normal ?

Merci d'avance.

Nowwhat
28/01/2015, 17h32
Citation Envoyé par Raln
....
Le changement dans la configuration de opendkim :
de :
#DAEMON_OPTS=""
par :
DAEMON_OPTS="-D -v -l -W "
Change quoi ?
J'ai essayé de chercher, mais sans succès.
Comme c'est dit déjà hier:
Citation Envoyé par Nowwhat
Pour savoir ce que c'est tout ça, tape
man opendkim


Ok, je te copie colle ce que ça donne ce "man opendkim".

-D = Sign subdomains of those listed by the -d option as well as the actual domains.
-l = Log via calls to syslog(3) any interesting activity.
-v = Increase verbose output during test mode (see -t above). May be specified more than once to request increasing amounts of output.
-W = If logging is enabled (see -l above), issues very detailed logging about the logic behind the filter's decision to either sign a message or verify it. The "W" stands for "Why?!" since the logic behind the decision is non-trivial and can be confusing to administrators not familiar with its operation. A description of how the decision is made can be found in the OPERATION section of this document. This causes a large increase in the amount of log data generated for each message, so it should be limited to debugging use and not enabled for general operation.

En gros: opendkim va te dire (dans les logs) ce qui se passe.
Généralement, ça aide énormément à mieux comprendre ce qui se passe.

PS: la commande man == manual == lire le BFM.

Raln
28/01/2015, 15h12
Merci pour votre aide à tout les 2.
Je vais donc patienté.

Le changement dans la configuration de opendkim :
de :

#DAEMON_OPTS=""
par :

DAEMON_OPTS="-D -v -l -W "

Change quoi ?

J'ai essayé de chercher, mais sans succès.

J'ai un 10/10 avec mail-tester !
Mais toujours dans les spams avec gmail et hotmail :/ .

Nowwhat
28/01/2015, 14h50
Citation Envoyé par Raln
.... même soucis google ne le voit pas malheureusement.
Je comprend Implicitement que les autres tests 'mail-tester.com' et copains ont trouvé et vérifié ton DKIM (tous Ok).
Dans ce cas, c'est un soucis de DNS cache chez GMail - il suffit patienter.

Raln
28/01/2015, 10h40
Merci pour ta réponse.
J'ai un champ txt et même soucis google ne le voit pas malheureusement.
J'ai une note de 8/10 avec mail tester.

janus57
27/01/2015, 21h40
Bonjour,

pour info si ton serveur ou pointe le NDD est le même que celui qui gère tout les mails, ce SPF devrait passer sans aucun problème :
Code:
v=spf1 a mx -all
Car le champs A et/ou MX de ton domaine renverra forcément l'adresse IP de ton serveur d'envois.

Si ce n'est pas le cas faut rajouter ip4:IPv4_adresse_serv_mail ET ip6:IPv6_adresse_serv_mail

Cordialement, janus57

Raln
27/01/2015, 19h56
Merci pour ta réponse.
Pour l'ipv6, il faut que je vérifie cela.
Le serveur mail sert pour plusieurs domaines.
L'autre serveur mail je l'ai supprimé.

Si j'ai bien compris je dois mettre 1 seul champ comme : "v=spf1 a mx ip4:92.222.36.170 -all" ?
Mais je dois mettre cela dans tout les domaines que j'utilise ?

Merci d'avance.

Nowwhat
27/01/2015, 19h00
Citation Envoyé par Raln
J'ai mis 2 champs spf :

v=spf1 a a:site.com a:infra2.hote.fr include:_spf.google.com ip4:92.222.36.170 -all
v=spf1 a mx ip4:92.222.36.170 ~all

Je ne sais pas le quel je dois garder ou enlever?
Les champs SPF ne sont peut-être pas bon ?
Les champs 'SPF', ça n'existe plus, il te faut UN (1) TXT - et pas 4 TXT, comme maintenant - mais une.

Si Google trouve pas ton SPF, le mail n'est pas venu de :
a:site.com = l'IP de site.com
ni de a:infra2.hote.fr = l'IP de infra2.hote.fr
ni de :_spf.google.com (va voir ce que c'est - j'ai mes petit idées)
ni de ip4:92.222.36.170 - l'IP 92.222.36.170

Dès que le SPF est ok, change "~all" pour "-all"

Attention: ton postfix communique avec l'IPv4 seulement ? (si IPv6, faut l'inclure aussi).

Éventuellement: ton /etc/default/opendkim, change
#DAEMON_OPTS=""
pour
DAEMON_OPTS="-D -v -l -W "
puis redémarre opendkim.

Pour savoir ce que c'est tout ça, tape
man opendkim


T'as DEUX champs MX avec la même "priorité" (= 10)
Tes mails peuvent donc tomber aléatoirement sur
smtp.digi-xxxxxx.eu.
et
infra2.digi-yyyyy.eu.
sachant que il s'agit deux serveurs 'mail' différent.
C'est voulu ça ?
infra2.digi-serveur.eu.

Astuce : n’envoie aucun mail vers "n'importe où" avant que mailtester.com te signale pas un 10/10.
Donc d'abord un 10/10 chez eux - et tant qu'à faire un "tout ok" chez eux:
check-auth@verifier.port25.com
autorespond+dkim@dk.elandsys.com
mailtest@unlocktheinbox.com
sa-test@sendmail.net

Pour s'amuser - et faire un poil mieux que le minimum:
https://starttls.info/
https://www.checktls.com/ (8 fois Ok et t'es ok)

Raln
27/01/2015, 18h28
J'ai mis 2 champs spf :

v=spf1 a a:site.com a:infra2.hote.fr include:_spf.google.com ip4:92.222.36.170 -all
v=spf1 a mx ip4:92.222.36.170 ~all

Je ne sais pas le quel je dois garder ou enlever?
Les champs SPF ne sont peut-être pas bon ?

Merci pour votre aide .

janus57
27/01/2015, 17h02
Bonjour,

Code:
Received-SPF: none (google.com: raln@site.com does not designate permitted sender hosts) client-ip=ip;
Authentication-Results: mx.google.com;
spf=none (google.com: raln@site.com does not designate permitted sender hosts) smtp.mail=raln@site.com;
dkim=pass header.i=@site.com
Hum, alors DKIM c'est très bien, mais il manquerait pas SPF dans le tas ?

Sachant que google demande au minimum le SPF.

Cordialement, janus57

Raln
27/01/2015, 15h05
Merci pour ton aide
Je suis en trains de regarder pour les logs. Ils ne sont pas activé par défaut ?
Concernant la conf : http://pastebin.com/3PdNE3K1
http://pastebin.com/fLVNEkNw
le champ, je pense avoir réussi :

# dig default._domainkey.site.com TXT

; <<>> DiG 9.8.4-rpz2+rl005.12-P1 <<>> default._domainkey.site.com TXT
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 26744
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;default._domainkey.site.com. IN TXT

;; ANSWER SECTION:
default._domainkey.site.com. 10800 IN TXT "v=DKIM1\; k=rsa\; p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQDH0yWJBduK 4OSuPCF/9cDFEtARDRXZFyo9eguKQg2f8uE8RhzK4N1eudNasvbYCeW+BS fIszuh7yiQh/ettiuh+kLxhRqAbG0x81hZCoKyUf/Ndne0x/A/equN2lSIrd7ekirPqOLv0JYm2MJ8klmRJxAZPZKvo+VZijf7dq 7ZcQIDAQAB"

;; Query time: 0 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Tue Jan 27 16:04:08 2015
;; MSG SIZE rcvd: 299

Mail envoyé depuis le webmail vers gmail :

Delivered-To: raln@gmail.com
Received: by 10.27.204.213 with SMTP id c204csp1272592wlg;
Tue, 27 Jan 2015 07:35:46 -0800 (PST)
X-Received: by 10.195.13.104 with SMTP id ex8mr2105594wjd.12.1422372945772;
Tue, 27 Jan 2015 07:35:45 -0800 (PST)
Return-Path:
Received: from infra2.hote.fr (infra2.hote.fr [ip])
by mx.google.com with ESMTP id pi10si3682611wic.30.2015.01.27.07.35.45
for ;
Tue, 27 Jan 2015 07:35:45 -0800 (PST)
Received-SPF: none (google.com: raln@site.com does not designate permitted sender hosts) client-ip=ip;
Authentication-Results: mx.google.com;
spf=none (google.com: raln@site.com does not designate permitted sender hosts) smtp.mail=raln@site.com;
dkim=pass header.i=@site.com
Received: from admin.infra2.hote.fr (infra2.hote.fr [ip])
(Authenticated sender: raln@site.com)
by infra2.hote.fr (Postfix) with ESMTPA id 0257FA83A05
for ; Tue, 27 Jan 2015 16:35:45 +0100 (CET)
DKIM-Signature: v=1; a=rsa-sha256; c=simple/simple; d=site.com;
s=default; t=1422372945;
bh=g3zLYH4xKxcPrHOD18z9YfpQcnk/GaJedfustWU5uGs=;
h=Date:From:To:Subject:From;
b=Pb9w1BMIzBw7LVBs3ORX0EpoYCe5MBWwPVirqnm3EtxXSODU kPZoK8hVgC+EtTXVL
/nscA4iU4q0PYchCzfVZYybonrR2+rU8zdx9fJFTRw50JVOEqWd kNMmJxbKcxF7iLj
EVuS/SM8guaRvSOVO43CCvvG/fEVgUSbVaoAugq4=
MIME-Version: 1.0
Content-Type: text/plain; charset=US-ASCII;
format=flowed
Content-Transfer-Encoding: 7bit
Date: Tue, 27 Jan 2015 16:35:44 +0100
From: raln@site.com
To: raln@gmail.com
Subject: test
Message-ID: <03754eb6bd6f606efacce8d5a96214eb@site.com>
X-Sender: raln@site.com
User-Agent: Roundcube Webmail/1.0.4
X-Antivirus: avast! (VPS 150126-1, 26/01/2015), Inbound message
X-Antivirus-Status: Clean

test

Il arrive toujours dans les spams par compte.

Nowwhat
27/01/2015, 14h29
Quelques conseils:



Citation Envoyé par Raln
Il semble pourtant bien envoyé avec la bonne adresse.
Mais pas de trace de DKIML - qu'il laisse au moins un ligne dans les logs qu'il signe le mail sortent.
T'as des détails concernant le config de dkim ?
(/etc/default/dkim...... ou /etc/default/opendkim...)
(/etc/dkim.... ou /etc/opendkim.... ou )
pour voir pourquoi DKIM ne logge pas (il faut probablement l'activer)

Citation Envoyé par Raln
Dans la source du message j'ai :
dkim=temperror (no key for signature) header.i=@
DKIM-Signature: v=1; a=rsa-sha256; c=simple/simple; d=site.com
et la clef qui suit.
Bizarre.
Il manque le paramétré le plus important: le "s" de selector, nécessaire pour former la requête DNS pour trouve le clé publique de DKIM:
Chez moi , c'est (s=default, d=papy-team.org)) donc la requête pour avoir le champs TXT de dkim est :
default._domainkey.papy-team.org

Vérification:
dig default._domainkey.papy-team.org TXT
Réponse : bingo !
default._domainkey.papy-team.org. 10800 IN TXT "v=DKIM1\; g=*\; k=rsa\; p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQDWlclzyZzh JnUuMDsDA6Fk1bTivv9xMqIKZutJz53MbFEU2b2joF7Nkqf9KM LJl5nt7+NQcFU8r6c/2IFY1TYiUDbRF4TJ9rv2NLTRT/smmM9Bie5Qvtk7iyq/3ZvBiMU6XIEwE9AVlPtFydyCZW/r8ePD19lf7E4NqtorMbfWbwIDAQAB"
Pour toi (site.com), sans selecteur: résultat NADA.

Raln
27/01/2015, 12h55
Merci pour ta réponse.
En effet je n'ai pas posté les logs les voici :


Jan 27 13:48:39 infra2 dovecot: auth-worker(3370): mysql(localhost): Connected to database imscp
Jan 27 13:48:39 infra2 dovecot: imap-login: Login: user=, method=DIGEST-MD5, rip=ip, lip=ip, mpid=3372, secured, session=
Jan 27 13:48:39 infra2 dovecot: imap(raln@site.com): Disconnected: Logged out in=243 out=917
Jan 27 13:48:39 infra2 dovecot: imap-login: Login: user=, method=DIGEST-MD5, rip=ip, lip=ip, mpid=3374, secured, session=<3YOQrKENNgBc3iSq>
Jan 27 13:48:39 infra2 dovecot: imap(raln@site.com): Disconnected: Logged out in=76 out=747
Jan 27 13:48:40 infra2 dovecot: imap-login: Login: user=, method=DIGEST-MD5, rip=ip, lip=ip, mpid=3376, secured, session=
Jan 27 13:48:40 infra2 dovecot: imap-login: Login: user=, method=DIGEST-MD5, rip=ip, lip=ip, mpid=3378, secured, session=
Jan 27 13:48:41 infra2 dovecot: imap(raln@site.com): Disconnected: Logged out in=50 out=422
Jan 27 13:48:42 infra2 dovecot: imap(raln@site.com): Disconnected: Logged out in=263 out=1090
Jan 27 13:48:48 infra2 dovecot: imap-login: Login: user=, method=DIGEST-MD5, rip=ip, lip=ip, mpid=3380, secured, session=
Jan 27 13:48:48 infra2 dovecot: imap(raln@site.com): Disconnected: Logged out in=38 out=408
Jan 27 13:48:48 infra2 dovecot: imap-login: Login: user=, method=DIGEST-MD5, rip=ip, lip=ip, mpid=3382, secured, session=
Jan 27 13:48:48 infra2 dovecot: imap(raln@site.com): Disconnected: Logged out in=50 out=727
Jan 27 13:49:35 infra2 postfix/smtpd[3400]: connect from domaine.com[ip]
Jan 27 13:49:35 infra2 postfix/smtpd[3400]: B6DB9A83A05: client=domaine.com[ip], sasl_method=DIGEST-MD5, sasl_username=raln@site.com
Jan 27 13:49:35 infra2 postfix/cleanup[3403]: B6DB9A83A05: message-id=<592a1eab346c176833f0c810e17a86dc@site.com>
Jan 27 13:49:35 infra2 postfix/qmgr[8343]: B6DB9A83A05: from=, size=653, nrcpt=1 (queue active)
Jan 27 13:49:35 infra2 dovecot: imap-login: Login: user=, method=DIGEST-MD5, rip=ip, lip=ip, mpid=3406, secured, session=
Jan 27 13:49:35 infra2 postfix/smtpd[3400]: disconnect from domaine.com[ip]
Jan 27 13:49:35 infra2 dovecot: imap(raln@site.com): Disconnected: Logged out in=460 out=529
Jan 27 13:49:36 infra2 postfix/smtp[3404]: B6DB9A83A05: to=, relay=proxy1.mx.mail.ovh.net[178.33.245.238]:25, delay=0.58, delays=0.15/0.01/0.08/0.35, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as 2B15F13BCE)
Jan 27 13:49:36 infra2 postfix/qmgr[8343]: B6DB9A83A05: removed
Jan 27 13:49:37 infra2 dovecot: imap-login: Login: user=, method=DIGEST-MD5, rip=ip, lip=ip, mpid=3408, secured, session=
Jan 27 13:49:37 infra2 dovecot: imap(raln@site.com): Disconnected: Logged out in=76 out=747
Jan 27 13:49:38 infra2 dovecot: imap-login: Login: user=, method=DIGEST-MD5, rip=ip, lip=ip, mpid=3411, secured, session=
Jan 27 13:49:38 infra2 dovecot: imap-login: Login: user=, method=DIGEST-MD5, rip=ip, lip=ip, mpid=3412, secured, session=
Jan 27 13:49:38 infra2 dovecot: imap(raln@site.com): Disconnected: Logged out in=132 out=869
Jan 27 13:49:38 infra2 dovecot: imap(raln@site.com): Disconnected: Logged out in=50 out=422
Jan 27 13:50:38 infra2 dovecot: auth-worker(3454): mysql(localhost): Connected to database imscp
Jan 27 13:50:38 infra2 dovecot: imap-login: Login: user=, method=DIGEST-MD5, rip=ip, lip=ip, mpid=3456, secured, session=
Jan 27 13:50:38 infra2 dovecot: imap(raln@site.com): Disconnected: Logged out in=50 out=422

Il semble pourtant bien envoyé avec la bonne adresse.

Dans la source du message j'ai :

dkim=temperror (no key for signature) header.i=@
DKIM-Signature: v=1; a=rsa-sha256; c=simple/simple; d=site.com
et la clef qui suit.

Mais même avec un client mail, la clé ne semble pas être reconnu.
Peut-être un soucis de configuration de dns ?
J'ai mis un champ txt :

dkim._domainkey.domaine.com TXT v=DKIM1; k=rsa; p=cle


Merci d'avance.

Nowwhat
27/01/2015, 02h09
Ooh ho
Ils ont cassé "www.mail-tester.com/".
Par contre, pourquoi tu fait semblent d'ignorer les règles établies ?
T'es pas nouveau ici, donc tu devrai savoir qu'on poste toujours un extrait de log.

Genre: je
tail -f /var/log/mail.log
puis tu utilise ton roundcube pour envoyer un mail.

On y vois tout, ou presque:

Jan 27 02:54:55 ns311465 postfix/smtpd[17719]: DB43363E028D: client=localhost.localdomain[127.0.0.1]
Jan 27 02:54:55 ns311465 postfix/cleanup[17827]: DB43363E028D: message-id=<50f7913a5a86d851e18ed70f1bf06679.squirrel@www. papy-team.org>
Jan 27 02:54:55 ns311465 dk-filter[3185]: Sendmail DomainKeys Filter, v1.0.1 field added ( a=rsa-sha1; s=mail; d=papy-team.org; c=simple; q=dns)
Jan 27 02:54:55 ns311465 opendkim[4092]: DB43363E028D: DKIM-Signature field added (s=default, d=papy-team.org)
Jan 27 02:54:56 ns311465 postfix/qmgr[2663]: DB43363E028D: from=, size=807, nrcpt=1 (queue active)
Jan 27 02:54:56 ns311465 amavis/smtpd[17835]: 7989B63E032A: client=localhost.localdomain[127.0.0.1]
Jan 27 02:54:56 ns311465 postfix/cleanup[17827]: 7989B63E032A: message-id=<50f7913a5a86d851e18ed70f1bf06679.squirrel@www. papy-team.org>
Jan 27 02:54:56 ns311465 postfix/qmgr[2663]: 7989B63E032A: from=, size=2127, nrcpt=1 (queue active)
Jan 27 02:54:56 ns311465 postfix/smtp[17828]: DB43363E028D: to=, relay=localhost[127.0.0.1]:10024, delay=0.85, delays=0.35/0.14/0.03/0.32, dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[127.0.0.1]:10025): 250 2.0.0 Ok: queued as 7989B63E032A)
Jan 27 02:54:56 ns311465 postfix/qmgr[2663]: DB43363E028D: removed
Jan 27 02:54:56 ns311465 papy-team.org-transport/smtp[17837]: connect to mail-tester.com[37.59.112.152]:25: Connection refused
Jan 27 02:54:56 ns311465 papy-team.org-transport/smtp[17837]: 7989B63E032A: to=, relay=none, delay=0.26, delays=0.05/0.16/0.05/0, dsn=4.4.1, status=deferred (connect to mail-tester.com[37.59.112.152]:25: Connection refused)

C'est clair, mail-tester n'est pas dispo.

Avec tout ce que t'as donné jusqu'à la, j'ai l'impression que ton roundcube n'utilise pas le bon nom de domaine.
Il utilise un (p.e. un From quelque chose comme ton-mail@www.ton-nom-de-domaine.tld ou ton-mail@mail.ton-nom-de-domaine.tld
Du coup, dkim ne va pas reconnaitre le nom de domaine, et il ajoute pas de clé.

Médoc: documente toi sur le fichier main.cf, plus précisément ceci:
masquerade_domains
Ça pourrait t’aider.

Avec un beau moreau de log, bien sur, pas besoin de jouer au devinette.

Raln
26/01/2015, 21h30
Il semble y avoir un soucis :

connect to mail-tester.com[37.59.112.152]:25: Connection refused

janus57
26/01/2015, 20h48
Bonjour,

il va alors falloir regarder les logs du serveur pour voir si il ne c'est pas fait refusé ou tout simplement pour savoir si le mail est partie.

Cordialement, janus57

Raln
26/01/2015, 20h24
Bonjour,

Malheureusement on dirait que cela ne fonctionne plus j’envoie l'email et le site reste chargé indéfiniment jusqu’à 10 et me dit que mon mail a pas été reçu.
Cela fonctionnais avant pourtant.

janus57
26/01/2015, 19h33
Bonjour,

simple, si vous donner pas le lien du résultat ou ennoyé pas un mail à l'adresse donné plus haut impossible de vous aider.

De plus avec une note de 7/10 vous ne passerez pas chez certains fournisseurs, c'est sur et certain.
La note minimale doit être de 9/10 pour passer sans trop de problème chez Google & cie.

Cordialement, janus57

Raln
26/01/2015, 19h00
Merci pour votre réponse.
J'ai déjà utilisé ce site. J'avais 7/10.
Le soucis c'est que je ne comprend pas, il y a bien une cle pourtant..

janus57
26/01/2015, 15h24
Citation Envoyé par Raln
DKIM result: permerror (no key)

Comment se fait t-il que la clé n'est pas valide ?
Bonjour,

votre réponse se trouve dans votre question grâce au logs :
Code:
DKIM result: permerror (no key)
Depuis votre webmail (roundcube) envoyé un mail à cette adresse : web-aEkHep@mail-tester.com
et regarder le résultat ici : https://www.mail-tester.com/web-aEkHep

Sachant que la note minimum doit être de 9/10 sans quoi cela risque de ne pas passer chez pas mal de fournisseurs.

Cordialement, janus57

Raln
26/01/2015, 14h13
Le soucis vient de DKIM je pense :

DomainKey result: none (no signature)
If DKIM result is passed, you can ignore DomainKey result: none
================================================== ==============


================================================== ==============
DKIM result: permerror (no key)

Comment se fait t-il que la clé n'est pas valide ?

Raln
26/01/2015, 13h56
Hello,

J'ai déjà faite cet procédure, mais toujours pareil malheureusement.

chrizirox
26/01/2015, 09h42
Il m'est arrivé deux fois d'acheter un VPS/dédié avec une IP blacklistée chez microsoft (donc même pas pu atteindre le dossier spam). Il y a une procédure à suivre, c'est assez rapide, ils sont très réactifs à valider même si à la base j'emploie toujours le mot microsoft dans un sens négatif :-)

Raln
25/01/2015, 20h51
Merci pour ta réponse.
Au niveau de l'hostname c'est ok.
J'ai aussi mis des champs spf aux domaines en question puis DKIM. Mais j'ai justement un soucis avec cela :

DKIM result: permerror (no key)

Peut-être car il faut attendre la propagation des dns ?

Merci d'avance.

fritz2cat
25/01/2015, 20h47
Ce sont donc ces fournisseurs qui ont décidé de classer tes mails comme spam.
Leurs algorithmes sont probablement à moitié secrets et à moitié publics.

Si ton serveur mail est irréprochable au niveau du DNS
hostname <=> adresse IP dans les deux sens ; serveur mail qui s'identifie avec le même HELO que le hostname,
c'est déjà très bien.

Ensuite toute violation du protocole SMTP ou MIME
c'est très mal

Ensuite si tu as SPF et DKIM
c'est mieux

Enfin si ton serveur est blacklisté (voir www.blacklistalert.org par exemple)
c'est une cote d'exclusion

Bref c'est une science inexacte dont tu ne possèdes pas toutes les pièces du puzzle

Raln
25/01/2015, 20h16
En effet, j'ai oublié de le préciser..

Chez gmail et outlook avec Microsoft SmartScreen.

fritz2cat
25/01/2015, 18h26
Citation Envoyé par Raln
Bonjour,

Je viens de prendre un vps. J'ai donc installé postfix ainsi que roundcube, mais je rencontre un petit soucis :
Lors de l'envoi de mail depuis php, le mail arrive normalement, mais lorsque je l'envoi depuis roundcube celui-ci
arrive dans les spams.
il arrive dans les spams de quel hébergement ?
quel filtre anti-spam ?

Raln
25/01/2015, 15h54
Bonjour,

Je viens de prendre un vps. J'ai donc installé postfix ainsi que roundcube, mais je rencontre un petit soucis :
Lors de l'envoi de mail depuis php, le mail arrive normalement, mais lorsque je l'envoi depuis roundcube celui-ci
arrive dans les spams.

Savez-vous d'ou peut venir mon problème svp ?

Merci d'avance.