OVH Community, votre nouvel espace communautaire.

Redirection HTTPS


captainadmin
22/01/2015, 11h09
Il faut m'envoyer un mail (cf tout enbas de mon site) et je pourrai t'expliquer ce que je peux te proposer comme forfait

Bonne journée
http://www.captainadmin.com

WebDieup
22/01/2015, 09h49
Super ça fonctionne.
Merci pour ton aide.

Je viens de regarder ton site internet et ton support pourrais m'être utile et cas de gros pépin que je ne pourrais pas dépanner seul rapidement.
J'aimerai savoir comment tu fonctionnes si c'est un forfait, à l'heure, un abonnement.... ?

captainadmin
21/01/2015, 14h12
Supprime le ServerAlias s'il ne sert pas
et mets tout dans le 443, que de la redirection pour le port 80

Si mon aide est si précieuse, n'hésite pas à me demande du support

Bonne soirée
http://www.captainadmin.com

WebDieup
21/01/2015, 14h07
Pour le ServerName et ServerAlias c'est parce qu'habituellement je mets avec et sans les www. Mais vu que dans ce cas je suis uniquement sur un sous-domaine j'ai mis pareil. C'est grave ou je peux juste enlever ServerAlias vu qu'il n'y en a pas du coup?

Pour les Directory tu me conseil de tous mettre dans le 443?
Dans le 80 j'inscris juste la redirection?

merci pour ton aide précieuse.

captainadmin
21/01/2015, 13h51
Il y a pleins d'incohérences dans ton fichier

Le ServerName et le ServerAlias portent le même domaine
La partie :80 redirige les domaines vers le :443, mais tu gardes tes directory dans la partie :80
Il faut mettre en place un fichier cohérent, s'il y a une rewrite pour tout le domaine, ya peu de chance que le directory soit dans le même vhost.

Bon courage
http://www.captainadmin.com

WebDieup
21/01/2015, 10h25
Code:

    # Adresse email à contacter en cas de problemes
    ServerAdmin webmaster@domaine1.com
    # Nom de domaine avec les www
    ServerName phpmyadmin.domaine1.com
    # Les différents alias du site, généralement le NDD sans les www
    ServerAlias phpmyadmin.domaine1.com
    # La où sont stocké les données du site
    DocumentRoot /home/phpmyadmin/www
    # Redirection vers HTTPS
        RewriteEngine   on
        RewriteCond     %{HTTPS} !=on
        RewriteRule     ^(.*)$ https://%{SERVER_NAME}$1 [L,R=301]

    # Nom d'utilisateur, nom du groupe, généralement identique
    SuexecUserGroup phpmyadmin phpmyadmin
    
        # Des options : ici suivre les liens symboliques
        Options FollowSymLinks
        # Autoriser l'override, autrement dit les .htaccess
        AllowOverride All
    
    
        # Encore des options : multiviews peut être pratique
        # Si on essaye d'accéder à site.com/index
        # Et que index n'existe pas, le serveur va rechercher index.*
        # Autrement dit : index.php, index.html etc...
        Options FollowSymLinks MultiViews
        # Autorise les htaccess
        AllowOverride All
        Order allow,deny
    
    # Log pour les erreurs
    ErrorLog ${APACHE_LOG_DIR}/error.log
    LogLevel warn
    # Log des connexion au site
    CustomLog ${APACHE_LOG_DIR}/access.log combined





       # Configuration de l'addresse
        ServerAdmin     webmaster@domaine1.com
        ServerName      phpmyadmin.domaine1.com
        DocumentRoot    /home/phpmyadmin/www/

       # Personnalisation des logs
        TransferLog     /var/log/apache2/phpmyadmin-access.log
        ErrorLog        /var/log/apache2/phpmyadmin-error.log

        # Utilisation de la clé et du certificat
        SSLEngine       on
        SSLCertificateFile      /etc/ssl/certs/wildcard.domaine1.com.crt
        SSLCertificateKeyFile   /etc/ssl/certs/wildcard.domaine1.com.key
        SSLCACertificateFile /etc/ssl/certs/wildcard.domaine1.com.pem
        SSLProxyEngine  on


captainadmin
21/01/2015, 10h18
Il faudrait voir la conf que tu as mise en place sur tes vhosts

Bonne journée
http://www.captainadmin.com

WebDieup
21/01/2015, 10h07
Merci pour ta réponse.

J'ai déjà plusieurs sous-domaine de domaine1.com en https.
Est-ce donc normal qu ça me redirige quand même?

captainadmin
21/01/2015, 09h35
Hello,


Si tu n'as configuré qu'un seul domaine en ssl sur ton serveur, il devient celui par défaut d'ou la redirection lorsque tu interroges un domaine n'ayant pas de ssl.
Soit tu fais un autre domaine ssl par défaut sur ton serveur pour qu'il choppe tous les https non configuré, soit tu fais une redirection ssl vers http sur les domaines n'ayant pas encore de certificats, soit tu configrues tes domaines directement en ssl

Bon courage
http://www.captainadmin.com

WebDieup
21/01/2015, 09h12
Bonjour,

J'ai un serveur dédié avec plusieurs site hébergés dessus. Chaque site est cloisonné avec son propre utilisateur.

J'ai mis en place un SSL Wildcard pour un domaine que je nommerai domaine1.com
La redirection en mode https fonctionne parfaitement et le certificat est bien mis en place.

Par contre j'ai un soucis quand je tape https://domaine2.com (qui est un domaine sans SSL) je suis redirigé automatiquement vers https://domaine1.com

Je souhaiterai empêcher cette redirection. Je penses que c'est une modif à faire dans les virtualhosts d'apache mais je n'ai rien trouvé à propos sur google.

Si quelqu'un connais la solution , je suis preneur.

D'avance merci.