OVH Community, votre nouvel espace communautaire.

Sip trunk - asterisk - stop apres 32 secondes


laurentm
21/01/2015, 13h09
Ces dernières années, je n'ai jamais eu d'ennuis avec des postes C610ip ou C470ip ou XLITE connectés directement à un compte SIP individuel ou entreprise.

C'est toujours avec Asterisk et les distributions qui sont basées dessus (Freepbx, Pbcinaflash, etc) qu'il y avait des problèmes depuis le passage de sip.vh.net à sip.ovh.fr. Il faut noter aussi qu'OVH n'a pas de tutoriel à jour et n'assure aucun support de ces configurations. D'autre part, il y a des variantes suivant les versions d'Asterisk et FreePbx qui font que la même configuration peut donner des résultats différents ! Là où l'on peut se poser des questions, c'est que TOUS les autres providers SIP fonctionnent bien avec Asterisk et qu'il n'y a qu'avec OVH qu'il y a des difficultés de paramétrage.

La bonne nouvelle, c'est que les appels sortants sont très stables ces derniers temps chez OVH et que, pour faire 30 appels simultanés, je suis obligé de panacher OVH et OpenIP car avec un trunk 30 canaux chez OpenIP il y a beaucoup d'appels sortants en erreur (au moins 10 à 15%).
Avec les deux fournisseurs (répartis 50% - 50%), même pas 1% d'erreurs.

Je précise que j'utilise une SDSL perso OVH à 25 euros ht/mois (4 Mb/s symétriques) et que j'ai les mêmes résultats qu'avec la SDSL 4 paires à 14 Mb/s...
Avec cette SDSL low cost dédiée exclusivement à la voip, pas besoin de faire de QOS...
Par contre, il faut être en zone dégroupée totalement par OVH pour bénéficier de la SDSL à 25 euros ht.

tqnguy
21/01/2015, 08h58
Merci je vais essayer de tester
pour qualifyfreq=30 je pense que j'ai essayer a un moment donné ...
mais je vais retester je remets ce param aujourd'hui et j'attends
Merci en tout a vous
J'avais vu aussi la piste du router mais je ne vois pas dans ce cas la pourquoi la config zoiper remet en fonctionnement et pour plusieurs jours en plus

un certains nombre de piste que j'avais suivi pour info
http://forums.whirlpool.net.au/archive/1238961
http://kb.smartvox.co.uk/voip-sip/to...ip-calls-drop/
http://www.dslreports.com/forum/r249...ilite=tag+time
http://www.3cx.com/forums/remote-ext...nds-37396.html
http://stackoverflow.com/questions/2...ter-30-seconds
https://www.google.fr/search?client=...drop+hangup+32
https://sysadminman.net/blog/2013/as...d_methods-5597
http://forum.ovh.com/archive/index.php/t-81878.html

Gaston_Phone
19/01/2015, 21h59
Voir aussi --> SIP - OVH - Communication coupée au bout de 32 secondes.

laurentm
19/01/2015, 20h35
Je ne crois pas que les ennuis viennent du codec, j'ai toujours été en G711 et j'ai rencontré les mêmes ennuis pendant des mois.
C'est plutôt un problème de temporisation du NAT du routeur qui ne reste pas ouvert pour laisser passer les paquets UDP.
Cela dépend du modèle de routeur et des réglages mystérieux du firewall de sip.ovh.fr

Mes problèmes ont disparu depuis que j'utilise la configuration suivante pour le Trunk dans FreePbx :

username=003397xxxxxx
type=friend
secret=xxxxxx
restrictid=no
qualify=yes
qualifyfreq=30

nat=yes
insecure=port,invite
host=sip.ovh.fr
fromuser=003397xxxxx
dtmfmode=inband
disallow=all
context=custom-get-did-ovh
canreinvite=no
allow=alaw&ulaw



C'est le "qualifyfreq=30" qui a tout solutionné pour moi ! Je n'utilise pas de Stun ni de port spécial de proxy.
J'avais installé un script pour reloader automatiquement en cas de perte d'enregistrement SIP détectée et il se déclenche une fois tous les 10 jours
au lieu de 10 fois par jour...

Gaston_Phone
19/01/2015, 17h15
La solution codec g711

- - - Mise à jour - - -

La solution évidente codec g711 (comme ZOIPER)

tqnguy
19/01/2015, 15h19
Bonjour,
Je suis en train de tester le trunk sip d'ovh
( principalement pour utiliser la fonction de présentation de numéro )
J'ai un asterisk installé

en fait la config fonctionne bien quelque temps ( des fois plusieurs jours )
et ponctuellement l'appel via ce trunk entraine une déconnexion au bout de 32 secondes

le fait de me connecter en direct via zoiper ( directement sur le trunk chez ovh )
rétablit la situation ( sans rien changer à la config asterisk )
pour 1 ou plusieurs jours ...

j'ai pensé a un probleme de ack quelque part mais comme le probleme est aléatoire
c'est pas simple de tester
donc si quelqu'un a eu ce type de problématique ou une idée

Merci à tous d'éventuel hypothèse ou test à faire