OVH Community, votre nouvel espace communautaire.

user PHP


Titeuf
08/07/2005, 07h00
Hello !

Perso je passe par les fonctions "ftp" de php.
Niveau sécurité c'est ok et niveau mise en place c'est assez facile, le tout est de le faire une fois.

Info sur les fonctions en questions :
http://fr2.php.net/manual/fr/ref.ftp.php

@++

Daweb
23/06/2005, 03h26
Oui c'est agaçant, sans passer PHP en CGI, y a t'il une solution si on a plusieurs sites avec plusieurs users...

Ce n'est pas catastrophique, mais du coup on ne connait pas les bons quotas des sites...

Pourtant on renseigne bien l'user dans la config du virtual host... Doit bien y avoir une manip !

Adilo
22/06/2005, 20h17
Bonjour,
Moi aussi j'ai le même problème dans mon hébergement 240Pack.
Est ce que vous pouvez m'aider.
Merci d'avance.

D.L
19/04/2004, 17h48
bon, ok, je vais essayer de voir (genre apprendre à créer un utilisateur avec des droits )

sinon, quand tu dis "Losrque j'upload mes fichiers sur le site, j'utilise cette utilisateur", tu veux dire que tu as créé un compte ftp avec "web" en login?

Edit:
çaaa maaaaaaaaaaaarche

alllléluya


shdck
19/04/2004, 16h41
Oui c'est ca.

Il vaut mieux éviter de mettre root, pour la sécurité c'est vraiment pas top. De toute facon il me semble qu'apache refuse de tourner avec l'utilisateur root.

D.L
19/04/2004, 13h50
pas tout compris (gros noob inside)

mais ça me donne déjà une piste

créer un utilisateur X, lui donner les droits d'écriture, et dire dans mon httpd.conf que PHP tourne avec ce user, c'est ça l'esprit?

et si je met root comme user PHP dans le httpd.conf, ça doit pas etre top je suppose niveau sécu...

shdck
18/04/2004, 23h33
Perso j'ai essayer suphp, mais malgrès que l'installation s'est déroulé correctement, mes script php fonctionnait toujours avec l'utilisateur nobody.

Ne trouvant pas de solution, j'ai modifié mon approche, en faisant fonctionner apache avec un utilisateur "web".

Losrque j'upload mes fichiers sur le site, j'utilise cette utilisateur (j'ai du mettre son rep home sur /home, pas terrible mais bon). Etant owner des repertoires du site, il peut lire ecrire et executer les fichiers du site.

Cette solution ne me plait pas enormement, mais au moins elle résoud mes petits soucis.

D.L
18/04/2004, 14h09
mettre php en cgi

comment on fais ça?
j'ai le même probleme

Elgi
14/03/2004, 00h32
mettre php en cgi ou utiliser le module suPHP

sinon tu dois utiliser php en module d'apache et dans ce cas php tourne sous le user d'apache que tu as definit dans ton httpd.conf

shdck
13/03/2004, 20h48
Bonjour,

Je viens d'installer un domaine sur mon serveur dédié. J'ai défini un utilisateur pour ce domaine (par webmin).

Pourtant lorsque j'essais d'uploader un fichier par php c'est nobody qui est utilisé. Y a t-il une option a renseigner quelque part pour que PHP utilise l'utilisateur du domaine ?