OVH Community, votre nouvel espace communautaire.

phpMyAdmin sur son hébergement


Abazada
18/03/2010, 01h53
Citation Envoyé par nectar
Je remonte ce vieux poste car je viens d'essayer la méthode et cela ne fonctionne pas.
Tu récupères des infos qui datent de 2006
et tu t'étonnes que ça ne marche plus en 2010 ???

benka
17/03/2010, 16h01
Salut

as tu un "_" (underscore) dans le nom de ta base?

http://guides.ovh.com/InstallPhpMyAdmin

Si oui, il faut le précéder de \

nectar
16/03/2010, 20h29
Bonsoir à tous,

Je remonte ce vieux poste car je viens d'essayer la méthode et cela ne fonctionne pas.
J'arrive bien à accèder à phpmyadmin, mais je ne vois pas ma base : "Aucune base de données"

J'ai rentré les infos suivante :
$cfg['Servers'][$i]['host'] = mysql5-6.pro';
$cfg['Servers'][$i]['user'] = 'nombase';
$cfg['Servers'][$i]['password'] = 'motdepassebase';
$cfg['Servers'][$i]['only_db'] = 'nombase';

Est ce que quelqu'un à une idée ?

Merci à tous.

pégé
11/02/2007, 01h05
Citation Envoyé par Bh@Mp0
Oui, il suffit de faire ça.

Par contre, personnellement, je met $cfg['Servers'][$i]['auth_type'] = 'cookies';
et je ne renseigne pas $cfg['Servers'][$i]['password'].
Ainsi, pas besoin d'un htaccess, il te demande ton mot de passe lors de la connexion ...
ok. Merci ! :-)

Bh@Mp0
10/02/2007, 23h15
Oui, il suffit de faire ça.

Par contre, personnellement, je met $cfg['Servers'][$i]['auth_type'] = 'cookies';
et je ne renseigne pas $cfg['Servers'][$i]['password'].
Ainsi, pas besoin d'un htaccess, il te demande ton mot de passe lors de la connexion ...

pégé
10/02/2007, 23h02
Citation Envoyé par ALeX!S
Si vous voulez la dernière version de phpMyAdmin sur votre hébergement,
[...]
Des questions ?
oui :-)
90PLAN, 1 base, phpmyadmin installé sans pb grâce entre autres à ton aide :-)
je viens de créer une nouvelle base et j'aimerais y accéder à partir du même phpmyadmin. Comment faire ? suffit-il de modifier le config.inc.php en y ajoutant les infos de la deuxième base :
$cfg['Servers'][$i]['host'] = 'nomduhostbase2';
$cfg['Servers'][$i]['user'] = 'nombase2';
$cfg['Servers'][$i]['password'] = 'motdepassebase2';
$cfg['Servers'][$i]['only_db'] = 'nombase2';
etc...

merci pour vos réponses

Ketchup
21/12/2006, 08h52
Bonsoir,

j'ai également tenté d'installer la dernière version stable de phpmyadmin qui est la 2.9.1.1. et j'obtiens comme NicoMX:

Code:
Fatal error: Class 'PMA_Config' not found in /home/t/a/n/tanguy/www/phpMyAdmin-2.9.1.1/libraries/session.inc.php on line 46
Je n'ai pas à l'aide des login et pass fourni par mail pu me logger sur la version par défaut de phpmyadmin qui est la 2.8.2.4. et cela même en changeant mon password au travers du manager.v3.

Merci de votre aide,

Tanguy Mezzano

NicoMX
19/11/2006, 22h00
Bonsoir,

Je viens à l'instant d'installer la dernière version de phpMyadmin sur mon 60gp, et lorsque j'essai d'y accéder, voici l'erreur qu'il me retourne:

Code:
Fatal error: Undefined class name 'pma_config' in ***/libraries/session.inc.php on line 46
J'ai pourtant tout bien configuré dans les régles de l'art, mais là j'avous que je seche...

duplex13
28/09/2006, 13h26
Salut et merci pour cette réponse qui m'a permis de passer à la version 2.8.2.4

J'ai quand du apporter même quelques modifications à mon installation :
- pour le style, je n'ai eu qu'à modifier le fichier ./css/phpmyadmin.css.php qui s'applique partout
- en fait j'ai fait un petit plus : dans le fichier précédent, j'ai mis la police à "body { font-size: 0.6em; }" et dans le fichier ./libraries/left_header.inc.php, j'ai mis "body { font-size: 0.8em; }".

Un petit rappel pour les personnes qui ne connaissent pas : le code suivant :
Code:
AuthUserFile /home.2/x/y/z/monlog/htpasswd
AuthType Basic
require valid-user
AuthName "Accès limité !"
permet de s'authentifier avec le user qui sert à se connecter à la base et le fichier .htpasswd est généré grâce au programme "htpasswd" qui se trouve dans le répertoire bin de apache.

Par contre, le style reste pas beau sous IE.

Vincent

ALeX!S
19/09/2006, 11h43
Si vous voulez la dernière version de phpMyAdmin sur votre hébergement, téléchargez la sur le site officiel.
Décompressez ensuite, et envoyez le tout par ftp (à vous de voir si vous voulez un sous-domaine phpmyadmin.monsite.tld ou non).

Comme expliqué dans la documentation de phpmyadmin, reprennez le fichier libraries/config.default.php et placez le à la racine de phpmyadmin avec comme nom : config.inc.php.

Les paramètres à renseigner dedans sont les suivants :

Code:
$cfg['PmaAbsoluteUri'] = 'http://www.monsite.tld/phpMyAdmin/';

$cfg['Servers'][$i]['auth_type']     = 'config';
$cfg['Servers'][$i]['user']          = 'monlogin';
$cfg['Servers'][$i]['password']      = 'monpass';
$cfg['Servers'][$i]['only_db']       = 'madb';
Voila, cela vous permet d'avoir un accès direct à votre db avec votre propre version de phpMyAdmin.

Reste que la, c'est pas secure du tout !
Je vous conseille un petit htaccess à la racine de phpMyAdmin avec dedans :

( En savoir plus sur les fichiers htaccess ... )

Code:
AuthUserFile /home.2/x/y/z/monlog/htpasswd
AuthType Basic
require valid-user
AuthName "Accès limité !"
En prenant soin de mettre un fichier htpasswd avec vos paramètres de connexion, hors www !

PS. AuthUserFile doit bien évidement correspondre au path de votre hébergement, voir realpath pour le trouver ...

Dernier détail, dans les dernières versions des phpMyAdmin la police est assez grosse (pseudo effet web2.0 ?!), c'est pas très cool pour les plus petites résolutions, et puis même ... c'est simplement moche !

Un petit FIX CSS va arranger ça.
Editez le fichier left.php à la racine et le fichier header.inc.php dans libraries.

Ajoutez le code suivant dans les balises head de ces pages.

Code:
> Voir le résultat (c'est la 2.8.2.4, car c'est la dernière stable)

Des questions ?