OVH Community, votre nouvel espace communautaire.

Ajout IPV6 avec interface non prise en compte


PatrickGilbert
12/01/2015, 17h56
Lorsque je mets la commande d'ajout ipv6 sans || true avant les commandes de route qui sont paramétrées par défaut ça fonctionne c'est donc une des commandes situées après l'ajout de mon ipv6::3 qui pose problème je pense. Je testerai dans la semaine et je vous ferai un retour

post-up /sbin/ifconfig eth0 inet6 add 2001:41D0:2:AD41::3/64



iface eth0 inet static
address 188.165.226.65
netmask 255.255.255.0
network 188.165.226.0
broadcast 188.165.226.255
gateway 188.165.226.254

iface eth0 inet6 static
address 2001:41D0:2:AD41::1
netmask 64
post-up /sbin/ifconfig eth0 inet6 add 2001:41D0:2:AD41::3/64
pre-down /sbin/ifconfig eth0 inet6 del 2001:41D0:2:AD41::3/64
post-up /sbin/ip -family inet6 route add 2001:41D0:2:ADff:ff:ff:ff:ff dev eth0 || true
post-up /sbin/ip -family inet6 route add default via 2001:41D0:2:ADff:ff:ff:ff:ff || true
pre-down /sbin/ip -family inet6 route del default via 2001:41D0:2:ADff:ff:ff:ff:ff || true
pre-down /sbin/ip -family inet6 route del 2001:41D0:2:ADff:ff:ff:ff:ff dev eth0 || true
post-up /sbin/ifconfig eth0 inet6 add 2001:41D0:2:AD41::2/64 || true
pre-down /sbib/ifconfig eth0 inet6 del 2001:41D0:2:AD41::2/64 || true

Nowwhat
12/01/2015, 17h26
Ok, merci pour le retour.

Quand même une question.
Je part du principe que ça marche pour toi maintenant.
Alors, pourquoi ceci est ok (j'ai copié des fragments de ton /etc/network/interfaces):
Citation Envoyé par PatrickGilbert
post-up /sbin/ifconfig eth0 inet6 add 2001:41D0:2:AD41::3/64
mais ici il faut un " || true" à la fin (ça force le résultat de la commande "/sbin/ifconfig ....... " comme "true" donc ok):
Citation Envoyé par PatrickGilbert
post-up /sbin/ifconfig eth0 inet6 add 2001:41D0:2:AD41::2/64 || true
D'ailleurs, après la commande
ipconfig
sur mon serveur j'ai ceci (coté IPv6):
Code:
          inet6 addr: 2001:41d0:2:927b::1/64 Scope:Global
          inet6 addr: 2001:41d0:2:927b::2/128 Scope:Global
          inet6 addr: 2001:41d0:2:927b::3/128 Scope:Global
          inet6 addr: 2001:41d0:2:927b::4/128 Scope:Global
          inet6 addr: 2001:41d0:2:927b::16/128 Scope:Global
          inet6 addr: 2001:41d0:2:927b::15/128 Scope:Global
          inet6 addr: 2001:41d0:2:927b::14/128 Scope:Global
          inet6 addr: 2001:41d0:2:927b::13/128 Scope:Global
          inet6 addr: 2001:41d0:2:927b::12/128 Scope:Global
          inet6 addr: 2001:41d0:2:927b::11/128 Scope:Global
          inet6 addr: 2001:41d0:2:927b::10/128 Scope:Global
Implicitement, il a ajouté des /128 partout, sauf pour l'adresse
2001:41d0:2:927b::1
cet adresse est paramétré comme ça pendant l'install de mon dédié par OVH (avec Debian 7.x) - netmask /64, genre:
Code:
iface eth0 inet6 static
        address 2001:41D0:2:927B::1
        netmask 64

PatrickGilbert
12/01/2015, 16h53
C'est Ok ca fonctionne, et j'ai pu aussi faire un test en mettant une commande d'ajout d'ipv6 avant les commandes d'ajout de route d'origine dans le fichier interfaces. Il y a donc une des commandes qui ne plait pas au serveur:

Ci-dessous le fichier interfaces

# The loopback network interface
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
address 188.165.226.65
netmask 255.255.255.0
network 188.165.226.0
broadcast 188.165.226.255
gateway 188.165.226.254

iface eth0 inet6 static
address 2001:41D0:2:AD41::1
netmask 64
post-up /sbin/ifconfig eth0 inet6 add 2001:41D0:2:AD41::3/64
pre-down /sbin/ifconfig eth0 inet6 del 2001:41D0:2:AD41::3/64
post-up /sbin/ip -family inet6 route add 2001:41D0:2:ADff:ff:ff:ff:ff dev eth0 || true
post-up /sbin/ip -family inet6 route add default via 2001:41D0:2:ADff:ff:ff:ff:ff || true
pre-down /sbin/ip -family inet6 route del default via 2001:41D0:2:ADff:ff:ff:ff:ff || true
pre-down /sbin/ip -family inet6 route del 2001:41D0:2:ADff:ff:ff:ff:ff dev eth0 || true
post-up /sbin/ifconfig eth0 inet6 add 2001:41D0:2:AD41::2/64 || true


Encore merci à tous les deux,

Patrick

captainadmin
12/01/2015, 13h26
J'ai surtout mis une solution de contournement sans vraiment résoudre le problème

tu mets "|| true " à la fin de chaque ligne
cette commande indique soit il execute la commande soit il renvoit true

iface eth0 inet6 static
address 2001:41D0:2:AD41::1
netmask 64
post-up /sbin/ip -family inet6 route add 2001:41D0:2:ADff:ff:ff:ff:ff dev eth0 || true
post-up /sbin/ip -family inet6 route add default via 2001:41D0:2:ADff:ff:ff:ff:ff || true
pre-down /sbin/ip -family inet6 route del default via 2001:41D0:2:ADff:ff:ff:ff:ff || true
pre-down /sbin/ip -family inet6 route del 2001:41D0:2:ADff:ff:ff:ff:ff dev eth0 || true
post-up /sbin/ifconfig eth0 inet6 add 2001:41D0:2:AD41::2/64 || true
pre-down /sbin/ifconfig eth0 inet6 del 2001:41D0:2:AD41::2/64 || true


Il doit y avoir un retour d'erreur sur une des lignes que j'ai pas pris le temps d'identifier
perso, je fais plutot des fichiers avec cette monenclature:

iface eth0 inet6 static
address 2001:41D0:2:AD41::1
netmask 64
up route add 2001:41D0:2:ADff:ff:ff:ff:ff dev eth0 || true
up route add default via 2001:41D0:2:ADff:ff:ff:ff:ff || true
down route del default via 2001:41D0:2:ADff:ff:ff:ff:ff || true
down route del 2001:41D0:2:ADff:ff:ff:ff:ff dev eth0 || true
up ip route add 2001:41D0:2:AD41::2/64 || true
down ip route del 2001:41D0:2:AD41::2/64 || true

Et le || true est une bonne habitude, quand tu ajoutes des lignes sur ton fichier interface, tu es sur de ne pas casser l'intégralité des interfaces.

Bonne journée
http://www.captainadmin.com

Nowwhat
12/01/2015, 13h09
Ah, t'as trouvé le soucis ? Avec l'aide de captainadmin ?

Il y a eu quoi comme problème ?

PatrickGilbert
12/01/2015, 10h32
Merci SUPER Captain admin,

C'est super ça marche!
Mais pourquoi doit-on mettre ¦¦ true ?

Merci encore Patrick

Ps Je suis en Haute-Savoie si tu passes dans la région fais-moi signe.

captainadmin
11/01/2015, 08h51
J'oubliais que mon site était en mode charlie

jr@captainadmin.com pour toutes demandes

Je remets à la normale demain, ca va faciliter la prise de contact

Bonne journée
http://www.captainadmin.com

Nowwhat
10/01/2015, 22h52
Désolé.
Même si Ubuntu ressemble à Debian, ce n'est pas Debian.
Je ne 'touche' jamais ou serveurs qui ne sont pas les miennes.

Mais, s'il n'y rien dessus, installé un Debian 7.x - upgrade directement vers 7.7
apt-get update
apt-get upgrade

Puis retente d'ajouter un IPv6 ...::2

PatrickGilbert
10/01/2015, 09h01
Avec ton ip ca fonctionne :

root@ns348884:~# ping6 2001:41d0:2:927b::15
PING 2001:41d0:2:927b::15(2001:41d0:2:927b::15) 56 data bytes
64 bytes from 2001:41d0:2:927b::15: icmp_seq=1 ttl=62 time=8.21 ms
64 bytes from 2001:41d0:2:927b::15: icmp_seq=2 ttl=62 time=0.317 ms
64 bytes from 2001:41d0:2:927b::15: icmp_seq=3 ttl=62 time=0.335 ms

J'ai essayé sans le /64 mais cela ne fonctionne toujours pas.
Je ne sais plus quoi faire

Patrick

- - - Mise à jour - - -

Si tu as un mail je peux t'envoyer les codes du serveur il n'y a rien dessus pour le moment je fais des test pour migrer d'un windows vers un linux.
Merci
Patrick

captainadmin
09/01/2015, 19h34
Personnellement je ne vois pas ton problème et surtout je n'arrive pas à le reproduire.
Peut-être qu'en ayant la main sur ton serveur je verrai une évidence qui n'est pas mise en avant actuellement

Pour le moment, je ne peux pas plus t'aider que ça

Bon courage et bonne soirée
http://www.captainadmin.com

Nowwhat
09/01/2015, 18h30
Citation Envoyé par PatrickGilbert
J'ai aussi fait un ls du répertoire /etc/network/ Est-ce normal que les droits d'execution sur le fichier interfaces ne soit pas activé?
.....
-rw-r--r-- 1 root root 879 janv. 9 12:57 interfaces
Noop, c'est ok comme ça.
Il s'agit d'un fichier de 'config' ou paramétrage.

Il ne s'agit pas d'un script PHP, perl, ou autre.

Par contre, qu'un
ping6 2001:41d0:2:ad41::1
vers ton propre IPv6 marhce, c'est ok, mais t'as testé d'autres IPv6, genre
ping6 2001:41d0:2:927b::15
(un IPv6 à 'moi')
ou
ping6 google.com
Puis, t'as testé avec:
/sbin/ifconfig eth0 inet6 add 2001:41d0:2:ad41::2
au lieu de
/sbin/ifconfig eth0 inet6 add 2001:41D0:2:AD41::2/64
dans ton
/etc/network/interfaces

Moi, j'ai:
Code:
post-up /sbin/ifconfig eth0 inet6 add 2001:41D0:2:927b::2
post-up /sbin/ifconfig eth0 inet6 add 2001:41D0:2:927b::3
post-up /sbin/ifconfig eth0 inet6 add 2001:41D0:2:927b::4
post-up /sbin/ifconfig eth0 inet6 add 2001:41D0:2:927b::5
post-up /sbin/ifconfig eth0 inet6 add 2001:41D0:2:927b::6
post-up /sbin/ifconfig eth0 inet6 add 2001:41D0:2:927b::7
post-up /sbin/ifconfig eth0 inet6 add 2001:41D0:2:927b::8
post-up /sbin/ifconfig eth0 inet6 add 2001:41D0:2:927b::9
post-up /sbin/ifconfig eth0 inet6 add 2001:41d0:2:927b::10
post-up /sbin/ifconfig eth0 inet6 add 2001:41d0:2:927b::11
post-up /sbin/ifconfig eth0 inet6 add 2001:41d0:2:927b::12
post-up /sbin/ifconfig eth0 inet6 add 2001:41d0:2:927b::13
post-up /sbin/ifconfig eth0 inet6 add 2001:41d0:2:927b::14
post-up /sbin/ifconfig eth0 inet6 add 2001:41d0:2:927b::15
post-up /sbin/ifconfig eth0 inet6 add 2001:41d0:2:927b::16
et ... ça marche.

PatrickGilbert
09/01/2015, 16h51
J'ai aussi fait un ls du répertoire /etc/network/ Est-ce normal que les droits d'execution sur le fichier interfaces ne soit pas activé?

root@ns348884:/etc/network# ls -l
total 24
drwxr-xr-x 2 root root 4096 janv. 6 15:21 if-down.d
drwxr-xr-x 2 root root 4096 avril 16 2014 if-post-down.d
drwxr-xr-x 2 root root 4096 avril 16 2014 if-pre-up.d
drwxr-xr-x 2 root root 4096 janv. 6 15:21 if-up.d
-rw-r--r-- 1 root root 879 janv. 9 12:57 interfaces
drwxr-xr-x 2 root root 4096 mars 21 2014 interfaces.d
lrwxrwxrwx 1 root root 12 avril 16 2014 run -> /run/network
root@ns348884:/etc/network#

PatrickGilbert
09/01/2015, 16h23
Citation Envoyé par captainadmin
Donne moi le résultat des commandes suivantes:

ip -6 r
route -6 -n
ifconfig
root@ns348884:/var/log# ip -6 r
2001:41d0:2:ad41::/64 dev eth0 proto kernel metric 256
2001:41d0:2:adff:ff:ff:ff:ff dev eth0 metric 1024
fe80::/64 dev eth0 proto kernel metric 256
default via 2001:41d0:2:adff:ff:ff:ff:ff dev eth0 metric 1024
root@ns348884:/var/log# ^C
root@ns348884:/var/log# route -6 -n
Table de routage IPv6 du noyau
Destination Next Hop Flag Met Ref Use If
2001:41d0:2:ad41::/64 :: U 256 0 0 eth0
2001:41d0:2:adff:ff:ff:ff:ff/128 :: U 1024 0 4 eth0
fe80::/64 :: U 256 0 0 eth0
::/0 2001:41d0:2:adff:ff:ff:ff:ff UG 1024 0 0 eth0
::/0 :: !n -1 1 19 lo
::1/128 :: Un 0 1 4 lo
2001:41d0:2:ad41::1/128 :: Un 0 1 30 lo
fe80::7254:d2ff:fe1a:b8a2/128 :: Un 0 1 6 lo
ff00::/8 :: U 256 0 0 eth0
::/0 :: !n -1 1 19 lo
root@ns348884:/var/log#

- - - Mise à jour - - -

Voila ipconfig

root@ns348884:/var/log# ifconfig
eth0 Link encap:Ethernet HWaddr 70:54:d2:1a:b8:a2
inet adr:188.165.226.65 Bcast:188.165.226.255 Masque:255.25 5.255.0
adr inet6: fe80::7254:d2ff:fe1a:b8a2/64 Scope:Lien
adr inet6: 2001:41d0:2:ad41::1/64 Scope:Global
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Packets reçus:5272 erreurs:0 :0 overruns:0 frame:0
TX packets:5437 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
Octets reçus:442960 (442.9 KB) Octets transmis:1039467 (1.0 M B)
Interruption:20 Mémoire:fe500000-fe520000

lo Link encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
adr inet6: ::1/128 Scope:Hôte
UP LOOPBACK RUNNING MTU:65536 Metric:1
Packets reçus:56 erreurs:0 :0 overruns:0 frame:0
TX packets:56 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
Octets reçus:5106 (5.1 KB) Octets transmis:5106 (5.1 KB)

root@ns348884:/var/log#

captainadmin
09/01/2015, 16h10
Donne moi le résultat des commandes suivantes:

ip -6 r
route -6 -n
ifconfig

PatrickGilbert
09/01/2015, 16h04
Citation Envoyé par captainadmin
tu arrives a activer la partie ipv4 sans problème ?
Je peux faire un ping6 ça marche:

root@ns348884:/var/log# ping6 2001:41d0:2:ad41::1
PING 2001:41d0:2:ad41::1(2001:41d0:2:ad41::1) 56 data bytes
64 bytes from 2001:41d0:2:ad41::1: icmp_seq=1 ttl=64 time=0.023 ms
64 bytes from 2001:41d0:2:ad41::1: icmp_seq=2 ttl=64 time=0.018 ms

Ii-je une commande spéciale a faire ?

C'est la 2eme ipv6 qui fonctionne pas quand elle est dans le fichier interfaces
2001:41d0:2:ad41::2

captainadmin
09/01/2015, 15h53
tu arrives a activer la partie ipv4 sans problème ?

PatrickGilbert
09/01/2015, 15h50
Résultat pour le ifup eth0:

root@ns348884:/var/log# ifup eth0
RTNETLINK answers: File exists
Failed to bring up eth0.

- - - Mise à jour - - -

Resultat pour ifdown eth0

root@ns348884:/var/log# ifdown eth0
ifdown: interface eth0 not configured

- - - Mise à jour - - -

Merci Nowwhat, mais je n'ai pas compris ta réponse peux-tu m'expliquer ?

Nowwhat
09/01/2015, 15h38
Si, t'as
Starting configure network device^[[74G[ OK ]
ce qui me semble est la même chose.

Ce "^[[74G" sont ds codes 'terminal' pour que le texte OK s'affiche en gras, ou en couleur.

captainadmin
09/01/2015, 15h29
Hello,

Lorsque je mets ta conf en place chez moi, ca fonctionne, j'ai bien les routes sur l'interface etc...
ifdown eth0; ifup eth0 donne quoi ?

Attention de faire la manip en console ou en étant connecté depuis une autre interface

Bonne journée
http://www.captainadmin.com

PatrickGilbert
09/01/2015, 15h09
Merci pour ton aide voici le fichier log boo.log je n'ai pas vu les éléments que tu mentionnes

root@ns348884:~# nano /var/log/boot.log
GNU nano 2.2.6 Fichier*: /var/log/boot.log

* Starting save udev log and update rules^[[74G[ OK ]
* Stopping save udev log and update rules^[[74G[ OK ]
* Starting Send an event to indicate plymouth is up^[[74G[ OK ]
* Stopping Send an event to indicate plymouth is up^[[74G[ OK ]
* Stopping userspace bootsplash^[[74G[ OK ]
* Starting configure network device^[[74G[ OK ]
* Starting Mount network filesystems^[[74G[ OK ]
* Starting Failsafe Boot Delay^[[74G[ OK ]
* Stopping Mount network filesystems^[[74G[ OK ]
* Starting Bridge socket events into upstart^[[74G[ OK ]
* Starting Mount network filesystems^[[74G[ OK ]
* Stopping Mount network filesystems^[[74G[ OK ]
* Stopping Failsafe Boot Delay^[[74G[ OK ]
* Starting System V initialisation compatibility^[[74G[ OK ]
* Starting set sysctls from /etc/sysctl.conf^[[74G[ OK ]
* Stopping set sysctls from /etc/sysctl.conf^[[74G[ OK ]
Skipping profile in /etc/apparmor.d/disable: usr.sbin.rsyslogd
* Starting AppArmor profiles ^[[128G
^[[122G[ OK ]
* Stopping System V initialisation compatibility^[[74G[ OK ]
* Starting System V runlevel compatibility^[[74G[ OK ]
* Starting ACPI daemon^[[74G[ OK ]
* Starting save kernel messages^[[74G[ OK ]
* Starting OpenSSH server^[[74G[ OK ]
* Starting regular background program processing daemon^[[74G[ OK ]
* Starting deferred execution scheduler^[[74G[ OK ]
* Starting CPU interrupts balancing daemon^[[74G[ OK ]
* Starting automatic crash report generation^[[74G[ OK ]
* Stopping save kernel messages^[[74G[ OK ]
* Starting domain name service... bind9 ^[[128G
^[[122G[ OK ]
* Starting MD monitoring service mdadm --monitor ^[[128G
^[[122G[ OK ]
* Stopping System V runlevel compatibility^[[74G[ OK ]

Nowwhat
09/01/2015, 14h35
Ce sujet est différent que http://forum.ovh.com/showthread.php?...018#post631018 ?

Si j'ai bien compris, au démarrage de ton serveur, le fichier /etc/network/interfaces n'est pas intégralement ou mal exécuté ?
L'IPv4 fonctionne.
L'IPv6 ......::1 fonctionne
L'IPv6 .....::2 ne fonctionne pas.

T'as un fichier log nommé
/var/log/boot (comme moi) ?
J'ai ceci dans ce fichier
.....
Mon Dec 15 08:49:47 2014: [....] Setting up resolvconf... ok done.
Mon Dec 15 08:49:49 2014: [....] Configuring network interfaces... ok done.
Mon Dec 15 08:49:50 2014: [....] Cleaning up temporary files... ok
.....
ou autre fichier log qui mentionne un erreur pendant l'activation du "network/interfaces" ?

PatrickGilbert
09/01/2015, 12h46
Bonjour,

Je suis sous Ubuntu Server 14.04 "Trusty Tahr" LTS (64bits)

Lorsque j'utilise le fichier interfaces pour ajouter une adresse ipv6 ca ne fonctionne pas mais quand j'ecris la commande directement dans la console SSH ca fonctionne je peux faire un ping6 et l'adresse IPV6 est visible dans ifconfig

Quelqu'un a t-il une idée ?

Ci dessous le fichier interfaces:

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
address 188.165.226.65
netmask 255.255.255.0
network 188.165.226.0
broadcast 188.165.226.255
gateway 188.165.226.254

iface eth0 inet6 static
address 2001:41D0:2:AD41::1
netmask 64
post-up /sbin/ip -family inet6 route add 2001:41D0:2:ADff:ff:ff:ff:ff dev eth0
post-up /sbin/ip -family inet6 route add default via 2001:41D0:2:ADff:ff:ff:ff:ff
pre-down /sbin/ip -family inet6 route del default via 2001:41D0:2:ADff:ff:ff:ff:ff
pre-down /sbin/ip -family inet6 route del 2001:41D0:2:ADff:ff:ff:ff:ff dev eth0
post-up /sbin/ifconfig eth0 inet6 add 2001:41D0:2:AD41::2/64
pre-down /sbin/ifconfig eth0 inet6 del 2001:41D0:2:AD41::2/64


Merci,
Patrick