OVH Community, votre nouvel espace communautaire.

Voir le site hébergé sur ovh pour vérification avant la migration dns


ddommii
15/01/2015, 08h19
Bonjour,
Oui, je souffle ! ! !
L'échéance chez hosteur : le 15 janvier ! ! !
J'ai commencé la migration du site le 23 décembre...
Ca devenait juste !


La nuit dernière (lundi -> mardi) je m''étais relevé à 4 h du mat pour trouver une solution....
Cette nuit-ci, j'ai mieux dormi.

Ceci dit, c'est effectivement Belgacom qui a fait la correction : d'une part, c'est eux qui sont à l'origine de l'erreur et d'autre part, il faut savoir que c'est Belgacom qui gère le nom de domaine pour nous.
Or, je leur avais précisé que nous changions d'hébergeur pour le site et "toutefois, nous souhaitons garder les adresses mails chez vous (Belgacom via Outlook web access) ...."

Par ailleurs, pour la navigation, il faut que je fasse des corrections, et des mises à jour.
Je vais pouvoir m'en occuper aujourd'hui et demain car hier, il y avait une formation organisée dans nos locaux pour les internautes lambda, je n'ai pas eu l'occasion de reprendre le site en main.
Je devais installer un mini-réseau avec accès wifi pour 20 machines : pc portables et tablettes Samsung et I Pad confondus...

Bref, j'ai un peu de mal avec certains scripts d'update...
Je vais me pencher dessus.
Mais les choses finissent par s'arranger.
Encore merci.
Je craignais d'être abandonné ici-même parce que le problème ne venait pas de chez OVH ! ! !
Mais votre patience m'a permis de rester plus calme et gérer jusqu'à ce que la solution soit trouvée.

Vous êtes en Belgqiue?
Dominique

- - - Mise à jour - - -

Vous avez dit :
ah bon ? il faut 4 choses:
- un serveur mysql
- un nom de database
- un user
- un password

Souvent la database et le user sont identiques. "

Effectivement, le nom de la db est identique au user, le nom de serveur contient 3 éléments qui se termine par mysql.db

Bonne journée.

fritz2cat
14/01/2015, 22h28
Je vois que tu es reparti sur les serveurs DNS de Skynet.
Ce choix est aussi valable.

Par la même occasion mes souvenirs mx1 et mx2.bgc.be se sont avérés corrects.

Dans la navigation du site il y a un petit couac -> les services communaux (http://www.pepinster.be/page.php?id=12§ion=2) renvoie sur une liste de ramoneurs.
Mais la navigation est fluide.

Si je comprends bien tu souffles un grand coup avant la fin de l'autre contrat ...

fritz2cat
14/01/2015, 10h48
Citation Envoyé par ddommii
Le problème relatif aux mails sera géré en direct à mon avis par Belgacom skynet.
J'attends de leurs nouvelles à cet égard.
Non, ils ne pourront pas faire ce que vous devez faire vous-même maintenant.

1) il faut vous faire confirmer par Belgacom que les MX des clients avec un hébergement mail Skynet/publilink c'est bien mx1.bgc.be et mx2.bgc.be
2) ensuite VOUS (et pas OVH ni Belgacom) allez dans votre espace client, zone DNS de votre domaine, retirer les 3 lignes mx1, mx2 et mxb.ovh.net, et mettre ce que Belgacom vous aura donné en (1)

- - - Mise à jour - - -

Citation Envoyé par ddommii
je dois me connecter à un autre serveur qui porte un nom commençant par le nom de mon domaine.
ah bon ? il faut 4 choses:
- un serveur mysql
- un nom de database
- un user
- un password

Souvent la database et le user sont identiques.

ddommii
14/01/2015, 09h42
Fritz2cat !

Trouvé ! ! !
Vous avez raison, vous aviez mille fois raison.
C'était les infos de connexion à la db.
J'avais une aide en ligne qui disait qu'il fallait me connecter au serveur mysql51-sql.bdb
c'est une erreur.
je dois me connecter à un autre serveur qui porte un nom commençant par le nom de mon domaine.

C'est résolu !
Encore merci mille fois pour votre patience.
Le problème relatif aux mails sera géré en direct à mon avis par Belgacom skynet.
J'attends de leurs nouvelles à cet égard.

Merci encore.
Ca s'appelle "l'expérience" , je ne me rendais pas bien compte que c'était de ce côté que le problème se trouvait mais votre obstination à eu raison de mes doutes.
Bonne journée et je vous souhaite comme à tout le monde une excellente année 2015 ! ! !

Dominique

ddommii
14/01/2015, 08h43
Bonjour,

Merci de me suivre. c'est sympa.

En effet, nous avons un contrat chez Belgacom skynet qui assure la gestion des mails et nous protège des virus, spams et autres difficultés parce que nous travaillons dans (sous la protection de) leur réseau publilink.

J'ai enfin eu il y a quelques minutes, un contact chez Belgacom qui semble prendre mon problème au sérieux pour les mails.

En ce qui concerne le site :

les scripts php sont d'une génération plutôt ancienne.
Par exemple, j'ai lu que les fonctions "include" doivent être remplacées par "include_once".
J'ai corrigé ces erreurs et j'ai créé le fichier .ovhconfig ce matin.


La base de données est bien celle qui se trouve sur ovh.
La connexion se fait avec mes identifiants sql pour ovh.
La page d'accueil contient un i-frame qui affiche la météo, c'est la seule liaison avec un site extérieur.

D'autres liens existent mais en target ="_blank"
Les requêtes se font bien vers le serveur sql de ovh.

Seul détail évident : les pages html fonctionnent et s'affichent normalement.
Le problème vient des scripts php.
On peut voir en allant sur www.pepinster.be/default.html

Je continue à chercher des pistes de remède à ces lenteurs.

Dominique

fritz2cat
14/01/2015, 07h02
Je reviens à une question de base:
- comptez-vous conserver les mails chez skynet/belgacom/proximus ? vous avez un contrat pour ça ? Est-ce coûteux ?
vous avez le choix entre dire aux serveurs DNS d'OVH que vos mails sont chez Bgc, pas chez OVH
ou créer vos boîtes mail chez OVH, ce sera déjà un problème de réglé.
voir mon message précédent

- pour votre site qui ne fonctionne pas comme il faut et que vous avez mis en maintenance ce serait bien de trouver quelle étape provoque ce fonctionnement erratique et bloquant. En particulier votre site ouvre-t-il des connexions TCP vers d'autres serveurs ? Ma question vers un serveur externe mysql rentrait dans cette catégorie.

ddommii
13/01/2015, 21h32
Bonjour Fritz2cat,
Merci pour votre intervention.
Je sais que c'est malin, ce n'est pas la meilleure raison de remuer le couteau dans la plaie.

Je me dois quand-même de corriger quelques infos.

1. Notre site était hébergé chez Hosteur et fonctionnait normalement jusqu'à ce matin.
2 les mails étaient gérés chez Belgacom - skynet jusqu'à ce matin. (NB. Belgacom s'apelle maintenant Proximus)
3. le nom de domaine www.pepinster.be est réservé/géré par Belgacom - skynet (devenu depuis quelques temps : proximus)
4. Suite à une augmentation du prix d'hébergement demandé par hosteur sans qu'il n'y ait de raison apparente, j'ai dû demander des prix ailleurs pour les mêmes services. (je travaille dans une administration, il y a des procédures)

L'offre de ovh semble la plus intéressante.

5. partie technique : j'utilise les tables qui tournaient chez hosteur et j'ai modifié les paramètres de connexion sql en les remplaçant par ceux de OVH.
J'ai en fait, exporté la base de donnée qui se trouvait chez hosteur, puis je l'ai importée par phpmyadmin pour qu'elle soit maintenant sur le serveur sql de OVH.

Dès lors, j'ai signalé hier lundi, par mail à dnsmaster@proxximus.com que nous allions passer chez ovh pour l'hébergement mais que nous gardions les mails chez Belgacom (donc : chez eux) et j'ai demandé combien de temps il faudrait si il fallait faire marche arrière au cas où les scripts ne tourneraient pas comme prévu.
J'ai communiqué les dns pour qu'ils disposent de l'info, simplement.

Ce matin : 11 heures, sans réponse de leur part à mon mail, je leur ai envoyé un mail (car ils est impossible d'avoir une communication verbale par téléphone avec eux, je ne sais pas pourquoi)
je leur ai donc demandé le délai nécessaire pour la modification des pointeurs afin de savoir quand je pourrais faire les essais de mes scripts.

J'ai précisé que l'hébergement chez l'ancien hébergeur arrive à terme ce jeudi et que ça ne me laisse que peu de temps pour apporter les éventuelles corrections.

Ils n'ont pas répondu mais ont fait pointer le nom de domaine sur les serveurs d'OVH sans m'en parler! ! !
Je leur ai posé une question pour mon info et ils sont passé à l'action sans m'en aviser : voilà l'erreur.

Ils n'ont apparemment rien fait pour les mails qui sont hébergés chez eux.
C'est peut-être normal, je n'en sais rien. (puisqu'ils géraient déjà les mails lorsque le domaine pointait vers l'hébergeur hosteur jusqu'à ce matin encore.)

J'ai découvert le problème grâce à une personne qui nous a envoyé un mail et qui a reçu en réponse un messagequi précisait que l'adresse mail n'existe pas...
La personne nous a téléphoné et dès lors, j'ai compris qu'il y avait eu un malentendu.

De mon côté, n'ai jamais demandé à dndmaster@proximus de modifier les dns, j'ai demandé qu'ils me disent combien de temps serait nécessaire pour changer les dns et combien de temps il faudrait s'il devaient faire marche arrière et donc refaire pointer les serveurs vers l'ancien hébergeur. Ce qui me donnait l'occasion d'adapter les scripts sans que ce ne soit visible pour le public.

La situation en est là maintenant.
Les mails n'arrivent toujours pas.
L'hébergement chez hosteur arrive à son terme jeudi, donc dernier jour actif demain mercredi.
Autrement dit, plus trop de temps pour corriger les scripts sur ovh, et je ne comprends pas pourquoi l'affichage est si lent, puisque les scripts tournent chez hosteur...
Bref, si vous voyez une piste que je pourrai suivre, je vous en serai reconnaissant.

Merci.
Dominique

fritz2cat
13/01/2015, 20h49
Concernant la (non) performance de ton site, foce est de constater qu'il y a un sévère problème. C'est parfaitement inutilisable. Tu n'aurais jamais dû mettre en production dans cet état (et plus haut dans la discussion on a donné des conseils pour te permettre de tester).

Hop coup de pub gratuite pour hosteur.com, sans le faire exprès. Si le même site tournait bien là bas, que se passe-t-il chez OVH ?? Qu'as-tu utilisé pour construire ton site ? Tu es certain que tu n'utilises plus la base de données chez Hosteur ?

fritz2cat
13/01/2015, 20h41
C'est malin, ça.

Récapitulons:
le domaine est enregistré auprès de Belgacom.

Belgacom dit (sur tes instructions) que les name server du domaine sont (d)ns110.ovh.net.
A partir de maintenant tout changement dans l'adresse IP du serveur web soit se faire dans le panneau de contrôle d'OVH (l'espace client, anciennement appelé "manager").
Il en est de même pour désigner le serveur qui prend en charge tes e-mails entrants. On parle de serveurs MX.

Et ici ce n'est plus les serveurs mails de Bgc mais ceux d'OVH. Chez OVH tu n'as pas configuré de boîtes mail donc "user unknown" et retour à l'expéditeur.

Tu as 2 possibilités:
- vite retrouver dans tes contrats bgc quel était le nom du serveur MX de chez eux. Je ne le connais plus avec certitude. Ce pourrait être mx1.bgc.be et mx2.bgc.be. Les remettre dans la zone DNS de ton domaine à la place des 3 enregistrements à supprimer mx1.ovh.net (et mx2 et mxb)
- ou décider d'utiliser les mails d'OVH au lieu de ceux de Belgacom, il faut créer toutes tes adresses e-mail chez OVH. Ensuite aller chercher les nouveaux mails chez OVH au lieu de Skynet (et éventuellement pendant quelques jours vérifier s'il n'y a plus rien qui tombe encore dans les inbox Skynet).

Est-ce clair ?

ddommii
13/01/2015, 19h26
Bonjour,
J'ai signalé à Belgacom (skynet est un pendant de Belgacom) par mail, que nous allions changer d'hébergeur mais que nous garderions les mals chez eux et je leur ai communiqué les infos suivantes :
dns110.ovh.net
et
ns110.ovh.net
J'ai demandé à Belgacom de me prévenir lorsqu'ils modifieraient les pointeurs et le temps qu'il faudrait si les scripts contenaient des erreurs pour remettre les anciens paramètres. (donc vers les serveurs hosteur)
Il ne m'ont pas répondu : ils ont procédé aux changements sans me prévenir...
Le nom de domaine pointe maintenant vers vos serveurs.
Nos mails arrivaient, jusqu'à ce matin, Belgacom-skynet.

Ce n'est plus le cas depuis la modification, et comme vous le dites des mails se perdent : les gens qui nous écrivent reçoivent une réponse qui dit que l'adresse mail n'existe pas.

Par ailleurs, l'affichage du site est : lent, très lent, trop lent. On croit qu'il ne va pas tellement les page sont longues à s'afficher. (parfois, elles ne s'affichent pas, mais c'est le code du script qui apparait.
Il y a donc un réel problème à résoudre .

Désolé de vous soliciter dans d'aussi mauvaises conditions.
J'espère avoir bientôt une solution définitive.
A vous lire.
Dominique

fritz2cat
12/01/2015, 09h38
Avant de toucher à ça, est-ce que vous recevez des e-mails xxx@pepinster.be sur les serveurs de Belgacom Skynet ? (xxx étant n'importe quelle adresse)

AVERTISSEMENT:: si vous changez les 4 serveurs DNS ns(1 à 4).skynet.be par les 2 serveurs DNS dns110.ovh.net et ns110.ovh.net sans d'abord changer la destination des mails entrants, VOUS ALLEZ PERDRE des e-mails.

Autre chose: que vient faire hosteur.com là-dedans ?

Frédéric, Bruxelles

ddommii
12/01/2015, 07h30
Bonjour,

Ok pour visualiser la version de test depuis mon PC.

Par ailleurs, je demandais (je n'ai pas été clair) si les informations à communiquer pour le changement de DNS étaient bien les suivantes, à savoir :
pour que le public puisse voir le site, qui est maintenant sur vos serveurs, par le biais de www.pepinster.be
les infos suivantes :
dns110.ovh.net
et
ns110.ovh.net
ils comprendront?
Merci.
Bonne journée.
Dominique

fritz2cat
07/01/2015, 16h04
Non, non
c:\windows\system32\drivers\etc\hosts
sur la plupart des systèmes Windows modernes

tu ouvres une session avec les droits local admin
tu édites ce fichier
tu mets sur une nouvelle ligne:
213.186.33.40 www.pepinster.be
si ton site est sur cluster011
et tu sauves
puis tu tapes IPCONFIG /FLUSHDNS

Ton PC (et rien que ton PC) ne verra que la version de test

ddommii
07/01/2015, 13h27
Je suis à l'origine des scripts php et tu dis qu'il faut ajouter une ligne dans mon fichier 'hosts'.
Je n'ai pas de fichier 'hosts' dans aucun répertoire?!?
Je suis perplexe.
J'imagine que tu parles sur mon pc de la version de test juste avant l'envoi sur le site en production...
Sur mon PC j'ai d'autres paramètres de connexion MySQL que ceux en service sur votre serveur...
Mais ce n'est peut-être pas de ça qu'il est question.

J'ai cru bien faire en modifiant les droits des fichiers php en les mettant en 755.
Est-ce une erreur?
Tous les autres sont en 604 sauf les sous répertoires qui sont en 705 mais c'est d'origine. :-)

Faut-il remettre tous les scripts php en 604 sauf les répertoires?

Par ailleurs, je vais faire la demande de redirection à Belgacom vers vos serveurs.
Trop lourd de modifier l'url puis remettre...

Donc, je leur donne les infos suivantes?
dns110.ovh.net
et
ns110.ovh.net
ils comprendront?
Pour les mails, je leur précise qu'il convient de modifier le type A du domaine par l'adresse IP suivante : 213.186.33.40
C'est bon?

Si j'ai commis une erreur, pouvez-vous me la corriger?
Merci encore une fois.
Bonne fin de journée

Dominique

fritz2cat
07/01/2015, 13h21
Si tu es développeur web, une manière de tester un site est d'ajouter une ligne dans ton fichier 'hosts' avec l'adresse IP du mutu OVH où est hébergé ton site en test.
Ce changement de fichier 'hosts' doit être fait sur ton PC.
Voir Google pour les détails, où il se trouve, droits admin, etc.

JuGU
07/01/2015, 13h05
Cela est dû au fait que le rss appel le nom de domaine, mais comme l'url est celle du cluster, ton site ne s'affichera pas correctement.

Il faudrait modifier temporairement l'url principale de ton site pour ensuite la modifier à nouveau lorsque le domaine pointera vers ton hébergement.

Si tu souhaites conserver les mails chez belgacom, il te faudra leur demander de modifier le type A du domaine par l'adresse IP de ton hébergement., qui est la suivante : 213.186.33.40

ddommii
07/01/2015, 11h50
Bonjour Julien,

Un grand merci !

Les habitudes changent de manière très impressionnantes lorsqu'on change d'hébergeur et les infos sont difficiles à trouver quand on n'est habitué à trouver les ressources et infos nécessaires.
J'ai l'impression que ces infos sont dispersées sans une organisation évidente.

Il manque une personne dans mon service et le temps me manque...
Bref, j'ai pu afficher la page d'accueil en direct sur le serveur ! ! !

Maintenant, je vais remettre les fichiers d'illustrations.
Mais j'ai constaté que lorsque je clique sur un lien, au lieu d'afficher la page: j'affiche tout le code de cette page.
Très embarrassant...
Qu'Est-ce qui m'échappe?

Ceci dit, nous garderons les mails chez Belgacom.
Par ailleurs, je pense que je devrai donner les infos suivantes pour le domaine.
La cible serait :
dns110.ovh.net
et
ns110.ovh.net
Comment puis-je afficher les pages plutôt que le code?
Merci encore pour votre efficacité.
Dominique

ddommii
07/01/2015, 11h35
Citation Envoyé par JuGU
Bonjour ddommii.

Pour l'affichage de ton site sans passer par le domaine, il te suffit de taper l'url ;avec l'exemple suivant : http://loginftp.clusterXXX.ovh.net

Pour retrouver le numéro de ton cluster, tu peux le voir dans l'espace client dans la partie plateforme.

En ce qui concerne le pointage de ton domaine vers ton hébergement une fois que tout est prêt, cela dépend également du service de mail que tu souhaites utiliser.

Vas-tu utiliser l'offre de mails associée à ton hébergement, ou souhaites-tu les conserver chez Belgacom ?
Bonjour Julien,

Un grand merci pour ton intervention.

C'est très difficile de s'y retrouver lorsqu'on quitte un hébergeur pour un autre : les habitudes sont très différentes, il manque une personne dans mon service, et le temps de chercher des solutions me manque.
Par ailleurs, je n'ai pas obtenu de réponse dans les contact avec le support à ce sujet...

Ceci dit, J'ai pu afficher mon site ! ! ! Merci vraiment!!!

Par ailleurs, nous prévoyons de garder les mails chez Belgacom qui nous protège contre les spams, les virus et autres worms...
Je crois avoir trouvé une piste : à savoir la cible dns110.ovh.net et ns110.ovh.net pour le site
il faut peut-être ajouter : mxb / mx2 / mx1.ovh.net lorsque je devrai transmettre les infos pour le serveur à Belgacom?

Merci encore.

Dominique

JuGU
07/01/2015, 11h02
Bonjour ddommii.

Pour l'affichage de ton site sans passer par le domaine, il te suffit de taper l'url ;avec l'exemple suivant : http://loginftp.clusterXXX.ovh.net

Pour retrouver le numéro de ton cluster, tu peux le voir dans l'espace client dans la partie plateforme.

En ce qui concerne le pointage de ton domaine vers ton hébergement une fois que tout est prêt, cela dépend également du service de mail que tu souhaites utiliser.

Vas-tu utiliser l'offre de mails associée à ton hébergement, ou souhaites-tu les conserver chez Belgacom ?

ddommii
07/01/2015, 08h43
Bonjour,
Meilleurs vœux pour 2015 !

Notre site www.pepinster.be est hébergé chez hosteur.com pendant encore quelques jours.

Le nom de domaine www.pepinster.be est géré (réservé) chez Belgacom.

Je dispose d'un hébergement mutualisé chez ovh auquel je peux me connecter par ftp et gestion de base de donnée par phpmyadmin.

Je voudrais savoir deux choses :
1. Comment afficher le site hébergé chez ovh pour corriger les éventuelles erreurs avant mise en production (changement de redirection du nom de domaine vers cet hébergement) ?
2. Une fois le site fonctionnel et vérifié par mes soins, quelles infos devrais-je communiquer à Belgacom pour que le nom de domaine pointe effectivement sur mon hébergement chez vous (ovh)?

Merci.
Dominique