OVH Community, votre nouvel espace communautaire.

URGENT ! Problème de télécargement de vidéos sur site de vente en ligne


janus57
05/01/2015, 14h26
Bonjour,

je viens de m'inscrire avec l'identifiant janus57.

Cependant je ne suis pas sur mon PC habituel pour le moment donc je ne pourrais pas faire de tests dans l'immédiat avec un gestionnaire de DL, je pourrais néanmoins tester avec firefox/IE ainsi qu'un outils de téléchargement en ligne de commande sous windows pour déjà faire quelques tests.

Cordialement, janus57

urbanrel
05/01/2015, 09h40
Janus,

Désolé je n'avais pas vu cette réponse !
Le plus simple afin que je vous montre est de vous inscrire sur mon site tutoriels-mao dat com et de me donner votre identifiant !
Nous pouvons continuer cet échange par mail si vous le souhaitez ?
Mon adresse est bigsoundfrance(at)gmail(dot)com

Cordialement,

Urbanrel

Gaston_Phone
04/01/2015, 20h58
C'est à mon tour d'avoir, à priori, des problèmes de réception de MAIL sur cette adresse.

Je viens de vous envoyer un autre MAIL avec une 2ème adresse de contact.

urbanrel
04/01/2015, 20h34
J'ai répondu a votre vrai mail !

Gaston_Phone
04/01/2015, 20h29
Citation Envoyé par urbanrel
De même ! Je viens de renvoyer mon adresse email en pv !
Ce n'est pas un message privé que je vous envoyé sur le forum OVH, mais un vrai MAIL à l'adresse MAIL que vous m'avez donné.

- - - Mise à jour - - -

Citation Envoyé par urbanrel
Il va falloir que je modifie le code php du composant joomla ! Y'a beaucoup beaucoup de boulot !
Modifier un script PHP de JOOMLA, cela craint.
En effet, à la prochaine mise à jour de JOOMLA, la modification sera écrasée.

urbanrel
04/01/2015, 20h15
Je crois que la différence entre vous et moi et que vous êtes programmeur et pas moi ! J'aurais dû faire une formation avant de me lancer la dedans !
Il va falloir que je modifie le code php du composant joomla ! Y'a beaucoup beaucoup de boulot !
Mon adresse mail est 'big sound france at gmail dat com' (tout attaché)

urbanrel
04/01/2015, 20h12
Mais qu'est ce que vous téléchargez exactement ? Quel fichier ? Quel site ?

- - - Mise à jour - - -

De même ! Je viens de renvoyer mon adresse email en pv !

Gaston_Phone
04/01/2015, 20h12
Un gros fichier d'un de mes sites chez OVH.

Gaston_Phone
04/01/2015, 20h09
Je viens de faire le test via un script PHP tel que décris au dessus :
-> Téléchargement d'un fichier de 1,1 Go en 36 minutes : OK.

- - - Mise à jour - - -

Citation Envoyé par urbanrel
Par contre je n'ai pas reçu votre mail en PV ?
C'est curieux je n'ai pas eu de rejet.
Je viens de le renvoyer à l'instant.

urbanrel
04/01/2015, 20h04
Je vais voir ça demain matin pour le script, je pense que de toute façon une simplification du script sera le minimum requis...! Dommage que je ne comprenne pas le PHP...
Par contre je n'ai pas reçu votre mail en PV ?

Gaston_Phone
04/01/2015, 19h42
Citation Envoyé par urbanrel
Avez-vous lu mon dernier post concernant la première série de test ?
Oui, mais trop tard.

Citation Envoyé par urbanrel
Qu'est ce que vous appelez telechargement normal ?
Un script PHP contenant simplement la ligne :

echo " Fichier de 1 Go
\n";

- - - Mise à jour - - -

Avez-vous reçu mon MAIL ?

urbanrel
04/01/2015, 19h25
Gaston,

Qu'est ce que vous appelez telechargement normal ?

Gaston_Phone
04/01/2015, 19h19
Et alors où en êtes vous ?

Houps! Je viens de voir votre réponse :

Citation Envoyé par urbanrel
On est quand même pas mal entre 3m30 et 3m50 quand même...
Faut-il que je refasse une série de test ?
Non. Mais pour préciser où se situe votre problème, il serait intéressant de tester un script avec un téléchargement normal et de voir si le problème existe toujours.

urbanrel
04/01/2015, 18h24
Re !

Et bien ça y est, j'ai fait une première série de test chronométrée sur 4 navigateurs différents + une tablette android, le résultat est sensiblement le même...
Voici quand le téléchargement est abandonné :

Firefox :
3m40s et 168 Mo
3m30s et 159 Mo

Chrome :
3m47s et 155Mo
3m32s et 148Mo

Internet explorer :
3m02s et 133Mo
3m00s et 134Mo

Thor :
3m38s et 127Mo
3m29s et 113Mo

Tablette Android 4.2 (ne dit pas combien il a télécharger, en abandonnant il supprime le fichier) :
3m27s
3m37s

On est quand même pas mal entre 3m30 et 3m50 quand même...

Faut-il que je refasse une série de test ?

Merci encore :-)

urbanrel
04/01/2015, 16h12
Je suis en train de faire les tests :-)
Je te tiens au courant !

J'ai peut-être oublié de préciser que la seule manière de télécharger complètement les vidéos est de passer par Mozilla et d'utiliser le plugin "Free download Manager".
Mais ça ne marche que sur Mozilla, sur Chrome ou internet explorer ça ne fonctionne pas...!

J'ai bien entendu supprimé ces plugins hier, j'effectue aujourd'hui les tests sans sur différents navigateurs...

janus57
04/01/2015, 16h00
Bonjour,

non c'est pas un php.ini qu'il fallait créer, mais genre phpinfo.php et mettre le code donnée par gaston dedans.

Ensuite faut pas prendre exemple sur des site qui sont conçus pour le téléchargement de masse comme uploaded.net, uptobox et tout les autres, ils ont leur propre réseau à eux, leur propre serveurs, leur propre config etc...

Enfin je rappel que ici vous êtes en mutualisé donc il y a des timeout PHP, des limitation de bande passante (lié à l'utilisation des autres clients) etc...

Pouvez-vous essayer de télécharger ces fichiers avec un gestionnaire de DL qui utilise plusieurs connexions ? ou est-il possible de nous donner un lien pour tester de notre côté ?

Perso une micro-coupure qui intervient +/- au même moment j'y crois en ce moment avec les problèmes de VAC (anti-ddos) et surtout car c'est du mutualisé.

Cordialement, janus57

Gaston_Phone
04/01/2015, 15h57
Citation Envoyé par urbanrel
Gaston : Je viens donc de chronométrer deux téléchargements sur la même vidéo, j'ai effectué les téléchargement l'un après l'autre :
- premier téléchargement interrompu à 3m40s (168Mo)
- deuxième téléchargement interrompu à 3m30s (159Mo)
Deux tests, ce n'est pas suffisant pour définir une règle, un constat avec certitude.

Il faudrait que tu fasses deux séries de 10 tests sur des machines et navigateurs différents.

Je viens de mettre un message sur ton profil.

urbanrel
04/01/2015, 15h41
Je vais peut-être passé pour un imbécile, mais ne sachant pas ou mettre se code, j'ai créé un php.ini et je l'y ai inséré dans mon /www (racine du site).

Gaston : Je viens donc de chronométrer deux téléchargements sur la même vidéo, j'ai effectué les téléchargement l'un après l'autre :
- premier téléchargement interrompu à 3m40s (168Mo)
- deuxième téléchargement interrompu à 3m30s (159Mo)

Si vous avez besoin d'autres infos, n'hésitez pas...

Merci beaucoup !

Gaston_Phone
04/01/2015, 15h20
Code PHP:

   phpinfo
();

?>
- - - Mise à jour - - -

Citation Envoyé par urbanrel
Ceci dit, ce qui est étonnant, c'est que la coupure aujourd'hui par exemple à lieu systématiquement en 145 et 150Mo, pas de place pour le hasard !
Des micro-coupures qui causent toujours des problèmes au même niveau de téléchargement : je n'y crois pas trop.

Par contre, un time-out sur ton type de téléchargement : oui, j'y crois plus.

Au bout de combien de temps le téléchargement s'arrête-t-il en moyenne ?

urbanrel
04/01/2015, 15h10
Merci à tous les deux,

Janus, c'est ce qu'il me semble... mais lorsque je télécharge sur d'autres site en ce qui me concerne, comme uploaded.net je n'ai aucun problème, donc en effet le script php ne doit pas supporter les micros coupures et donc pas de reprise !
Ceci dit, ce qui est étonnant, c'est que la coupure aujourd'hui par exemple à lieu systématiquement en 145 et 150Mo, pas de place pour le hasard !

Gaston, il me semble aussi que le code PHP doit poser problème, mais mon plus gros problème est qu'aujourd'hui j'utilise ce système de mise en vente pour tout le site et depuis des mois ! Passer par un autre composant me prendrais des semaines de reconstruction :-(

Pour le PHPinfo, je ne sais pas comment faire, je n'ai jamais utilisé cette technique.
Janus, pourriez-vus m'en dire plus ?

Une idée peut-être pour les reprises lors des coupures ?

Encore merci :-)

urbanrel
04/01/2015, 15h02
Merci à tous les deux,

Janus, c'est ce qu'il me semble... mais lorsque je télécharge sur d'autres site en ce qui me concerne, comme uploaded.net je n'ai aucun problème, donc en effet le script php ne doit pas supporter les micros coupures et donc pas de reprise !
Ceci dit, ce qui est étonnant, c'est que la coupure aujourd'hui par exemple à lieu systématiquement en 145 et 150Mo, pas de place pour le hasard !

Gaston, il me semble aussi que le code PHP doit poser problème, mais mon plus gros problème est qu'aujourd'hui j'utilise ce système de mise en vente pour tout le site et depuis des mois ! Passer par un autre composant me prendrais des semaines de reconstruction :-(

Pour le PHPinfo, je ne sais pas comment faire, je n'ai jamais utilisé cette technique.
Janus, pourriez-vus m'en dire plus ?

Une idée peut-être pour les reprises lors des coupures ?

Encore merci :-)

janus57
04/01/2015, 14h47
Bonjour,

si vous mettez un PHPinfo en place sur le site est-ce que vous voyez PHP en mode FPM ?

Sinon les erreurs que vous donnez indique que c'est le client (donc vous ?) qui coupez la connexion.

Les téléchargement avec 1seule connexion et passant par ce genre de script sont généralement très sensible aux micro-coupure, pour pallier au problème il faudrait tester en multi-connexions.

Cordialement, janus57

Gaston_Phone
04/01/2015, 14h47
Citation Envoyé par urbanrel
Il n'y a pas d'URL directe. L'URL est cryptée avec un script PHP afin que les utilisateurs/clients ne puissent pas retrouver le dossier...!
Le téléchargement direct fonctionne, c'est via ce script que ça ne fonctionne pas. J'ai pas mal consulté le forum pour mon problème, apparemment je ne suis pas le seul, mais pas de réponse.
Si le téléchargement direct fonctionne , comme chez moi, et que tu utilises un script PHP spécial avec une URL cryptée, je pense que le problème est plutôt chez toi.
Je te propose de te tourner vers le fournisseur de ton script PHP spécial.

urbanrel
04/01/2015, 14h25
Janus57,

Merci.
Rien n'y fait malheureusement... j'ai déjà essayé avant ! (depuis hier je suis sur ce problème)
Du côté des logs, j'ai une erreur qui revient souvent :

Handler for fastcgi-script returned invalid result code 1
(104)Connection reset by peer: FastCGI: comm with server ".../www/index.php"

ainsi que :

(104)Connection reset by peer: FastCGI: comm with server ".../www/index.php" aborted: read failed, referer:.../index.php/component/quicksell/?view=quicksell&Itemid=652

Je pense comprend que la connection est interrompue ?

janus57
04/01/2015, 14h03
Bonjour,

voici le guide OVH : https://www.ovh.com/fr/g1175.optimisation-php-fpm

Par contre si cela passe par PHP je crois que ce sera limité à 512Mo, je ne suis vraiment pas sûr de ce que j'avance car cela dépend de comment le script PHP est conçus (bien optimisé ou non et comment il envoie le fichier).

Regarder aussi les logs apache/php pour voir si y a des des erreurs dans les logs (regarder dans le panel OVH je sais pas ou sont les logs).

Vous pouvez donner des liens sous forme "masqué" genre : example[point]com/monfichier.zip

Cordialement, janus57

urbanrel
04/01/2015, 13h31
Merci pour vos réactions !

J'ai publié deux autres messages entre temps qui n'ont pas été publiés , ne comprends pas...

Un des deux messages :

"Bonjour Gaston,

Merci pour ta réponse rapide.
Il n'y a pas d'URL directe. L'URL est cryptée avec un script PHP afin que les utilisateurs/clients ne puissent pas retrouver le dossier...!
Le téléchargement directe fonctionne, c'est via ce script que ça ne fonctionne pas. J'ai pas mal consulté le forum pour mon problème, apparemment je ne suis pas le seul, mais pas de réponse.
Le plus simple pour te montrer mon problème serait de te fournir un accès sur mon site.
Si tu veux, inscris-toi sur mon site et donne moi ton identifiant, je te donnerai l'accès au téléchargement d'un fichier dans ton espace utilisateur.
Je peux peut-être t'envoyer le lien en MP ? (apparemment les liens ne sont pas acceptés sur le forum)

Merci encore :-)"

Janus57, merci aussi de participer.
Pourrais-tu m'en dire plus sur le PHP-FPM ? Je ne sais pas ce que c'est et comment faire pour l'activer...

Merci !

janus57
04/01/2015, 12h39
Bonjour,

vous avez basculé en PHP-FPM ou cas ou ce soit le script PHP qui entre en défaut à cause d'une sur-consommation par rapport à la config de PHP ?

Cordialement, janus57

Gaston_Phone
04/01/2015, 12h23
Téléchargement des 1,2 Go terminés avec succès.

urbanrel
04/01/2015, 12h01
Bonjour Gaston,

Merci pour ta réponse rapide.
Il n'y a pas d'URL directe. L'URL est cryptée avec un script PHP afin que les utilisateurs/clients ne puissent pas retrouver le dossier...!
Le téléchargement directe fonctionne, c'est via ce script que ça ne fonctionne pas. J'ai pas mal consulté le forum pour mon problème, apparemment je ne suis pas le seul, mais pas de réponse.
Le plus simple pour te montrer mon problème serait de te fournir un accès sur mon site.
Si tu veux, inscris-toi sur mon site et donne moi ton identifiant, je te donnerai l'accès au téléchargement d'un fichier dans ton espace utilisateur.
Le plus simple pour retrouver mon site de MAO est de taper "vps tutoriels mao" dans google, ça sera le premier lien, ou cliques ici .

Merci encore :-)

Gaston_Phone
04/01/2015, 12h00
A cet instant, avec un téléchargement via Firefox, j'en suis à 335 Mo.

Gaston_Phone
04/01/2015, 11h54
URL ?
De mon coté je lance un téléchargement d'un fichier de 1,2 Go.

urbanrel
04/01/2015, 11h20
Bonjour à tous,

J'ai un problème depuis que je suis passé chez OVH.

Je vous explique ma situation :
J'hébergeais mon site de vente de tutoriels jusqu'à hier matin chez 1&1.
J'ai basculé chez OVH parce que chez 1&1 le téléchargement des vidéos côté clients s'arrêtait au bout de 500Mo environ...
Ce qui est très embêtant commercialement parlant !!!
J'ai perdu de nombreux clients à cause de ça...
Donc, j'ai fini par appeler OVH en leur demandant si en passant chez eux le problème serait résolu, la réponse a été clairement "OUI" et pour des fichiers allant jusqu'à 1.5Go.
Résultat : après deux semaines de transfert de site chez OVH, je me retrouve avec le même problème sauf que maintenant le téléchargement s'interrompe à 140Mo environ !!! Du grand n'importe quoi !
Je précise que je le téléchargement se déroule en HTTP et non en FTP et que j'utilise Joomla 2.5 et un composant de vente de fichiers de tous types. Le téléchargement passe par un script PHP.

C'est très URGENT !!! Je perd des clients toutes les heures...

Merci d'avance !