OVH Community, votre nouvel espace communautaire.

Upgrade FC4 à FC5 erreurs dépendances de packages


buddy
11/12/2014, 18h11
Bonjour,

je ne suis même pas sur que les serveurs dépôts pour Fédora 4 et Fedora 5 soit encore en ligne / accessible avec les adresse "normales". Donc ton serveur ne trouve pas les fichiers ...

Le plus simple comme j'ai dit et de louer un nouveau serveur, d'installer le nouveau serveur et de migrer petit à petit (en plus tu auras un serveur forcément plus puissant ... )

captainadmin
11/12/2014, 10h21
Bonjour,

En effet tu as tout intérêt à partir d'une installation compléte de ta fedora, la dernière étant la 21, tu vas ouvoir des soucis à chaque niveau entre la V4 et la V21
Par contre, il risque d'y avoir quelques aménagement de code, il faut voir ce que tu utilises comme applicatif pour adapter tes configuration.
Par exemple pour php tu passes de php5.0 à php5.6, tu auras forcément des revues de code à voir.
Pour plesk, tu passes à la version 11 il me semble.

Tu auras moins de galère en installant un nouveau serveur en parallèle sur lequel tu as tout à jour et tu transfères les données dessus.
Sur ta FC4, tu dois avoir beaucoup d'autres failles moins médiatique que Shellshock mais tout aussi dangereuse.

Bonne courage
http://www.captainadmin.com

bbr18
11/12/2014, 07h57
En partant d'aussi loin (v4 vers une version à 2 chiffres !) je pense que tu vas perdre beaucoup de temps pour un résultat plus qu'aléatoire et bancal, le plus judicieux serait de sauvegarder toutes tes données (web, bdd) puis réinstaller complètement, d'autre part vu l'ancienneté de ce serveur, tu dois le payer au prix fort, en changer te ferait faire des économies substantielles avec en plus un matériel bien plus performant.
Autre solution : mettre les sites de ce serveur vers un de tes autres serveurs préalablement mis à jour.
Enfin dernière solution : prendre un infogérant au moins ponctuellement afin qu'il te remettre tout ça d'aplomb, il faut être conscient de ses limites et tu as atteint les tiennes, sur ce forum il y a plein de pros qui pourraient certainement le faire.
PS Utilise la balise code (à mettre entre crochets) lorsque tu mets des tas de lignes comme au-dessus, c'est plus lisible

mazo0012
11/12/2014, 06h01
Bonjour,

Suite à un message récemment posté sur ce forum, relative à la faille Shellshock (et d'autres) qui rend mon serveur dédié vulnérable, beaucoup de gens m'ont conseillé de mettre à jour mon serveur.

Pour cause, ils ont raison car je n'ai jamais mis à jour la distribution, par méconnaissance et par peur de tout perdre. J'ai uniquement fait les mises à jour de Plesk qui est actuellement en 9.5.4. La distribution du serveur est : Fedora Core release 4 (Stentz) 2.6.24.2-xxxx-std-ipv4-32.

J'ai décidé de me lancer dans la mise à jour des versions, en allant le plus loin possible (pourquoi pas mettre à jour jusqu'à la v20, gardons espoir), malheureusement dès le premier "yum upgrade" pour passer de la FC4 à FC5, j'obtiens des erreurs de dépendances, et après de longues recherches je ne trouve pas de solution.

Il se peut que le fait d'avoir mis à jour Plesk sans mettre à jour la distrib serveur fait que Plesk 9.5.4 est trop récent pour la FC5 et que les packages nécessaires à cette version de Plesk n'existent pas dans la FC5 ? Dans ce cas, comment downgrader Plesk, il m'a semblé lire qu'on ne peut pas le downgrader parque ça pose de gros problèmes... Et de plus, j'ai acquis le serveur dédié via OVH, si je désinstalle Plesk qui a été installé au départ par OVH, pourrais-je le réinstaller ensuite en téléchargeant le rpm (je veux dire ce n'est pas une version "spéciale") ?

Voici les résultats du yum upgrade :
[......]
--> Running transaction check
--> Processing Dependency: libmysqlclient.so.14(libmysqlclient_14) for package: psa-fileserver
--> Processing Dependency: libssl.so.5 for package: psa-proftpd
--> Processing Dependency: libcrypto.so.5 for package: php51-openssl
--> Processing Dependency: libssl.so.5 for package: ruby-mysql
--> Processing Dependency: libssl.so.5 for package: psa-mail-qc-driver
--> Processing Dependency: libssl.so.5 for package: sw-engine
--> Processing Dependency: libcrypto.so.5 for package: ruby-mysql
--> Processing Dependency: libcrypto.so.5 for package: courier-imap
--> Processing Dependency: libssl.so.5 for package: psa-bf2
--> Processing Dependency: libcrypto.so.5 for package: cs-gs
--> Processing Dependency: libcrypto.so.5 for package: psa-autoinstaller
--> Processing Dependency: libcrypto.so.5 for package: psa-bf2
--> Processing Dependency: libssl.so.5 for package: psa-spamassassin
--> Processing Dependency: libmysqlclient.so.14(libmysqlclient_14) for package: psa-drweb-configurator
--> Processing Dependency: libssl.so.5 for package: php51-openssl
--> Processing Dependency: libboost_filesystem.so.1 for package: sw-engine
--> Processing Dependency: libcrypto.so.5 for package: miva-ssl-stub
--> Processing Dependency: libcrypto.so.5 for package: psa
--> Processing Dependency: libssl.so.5 for package: psa-backup-manager
--> Processing Dependency: libssl.so.5 for package: psa
--> Processing Dependency: libcrypto.so.5 for package: sw-engine
--> Processing Conflict: hal conflicts kernel < 2.6.15
--> Processing Dependency: libssl.so.5 for package: psa-autoinstaller
--> Processing Dependency: libcrypto.so.5 for package: php5sb
--> Processing Dependency: libcrypto.so.5 for package: php51-mysqli
--> Processing Dependency: libcrypto.so.5 for package: sw-sso-migrate
--> Processing Dependency: libssl.so.5 for package: PPWSE
--> Processing Conflict: kudzu conflicts kernel < 2.6.13
--> Processing Dependency: php <= 5.1.0 for package: php-sqlite2
--> Processing Dependency: libssl.so.5 for package: sw-cp-server
--> Processing Dependency: libssl.so.5 for package: psa-qmail
--> Processing Dependency: libc-client.so.0 for package: sw-engine
--> Processing Conflict: initscripts conflicts kernel < 2.6.12
--> Processing Dependency: libcrypto.so.5 for package: psa-bf1942
--> Processing Dependency: libmysqlclient.so.14(libmysqlclient_14) for package: ruby-mysql
--> Processing Dependency: libssl.so.5 for package: sw-sso-migrate
--> Processing Dependency: libcrypto.so.5 for package: sw-cp-server
--> Processing Dependency: libcrypto.so.5 for package: psa-mail-driver-common
--> Processing Dependency: libssl.so.5 for package: psa-bf1942
--> Processing Dependency: libcrypto.so.5 for package: psa-qmail
--> Processing Dependency: libssl.so.5 for package: psa-kav
--> Processing Dependency: libcrypto.so.5 for package: psa-drweb-configurator
--> Processing Dependency: libcrypto.so.5 for package: psa-fileserver
--> Processing Dependency: libmysqlclient.so.14(libmysqlclient_14) for package: cs-gs
--> Processing Dependency: libcrypto.so.5 for package: psa-proftpd
--> Processing Dependency: libssl.so.5 for package: cs-gs
--> Processing Dependency: libcrypto.so.5 for package: psa-watchdog
--> Processing Dependency: libssl.so.5 for package: courier-imap
--> Processing Dependency: libssl.so.5 for package: php51-pdo_mysql
--> Processing Dependency: libcrypto.so.5 for package: php51-curl
--> Processing Dependency: libssl.so.5 for package: miva-ssl-stub
--> Processing Dependency: libssl.so.5 for package: psa-fileserver
--> Processing Dependency: libssl.so.5 for package: psa-mail-driver-common
--> Processing Dependency: libcrypto.so.5 for package: psa-hotfix3-9.2.3
--> Processing Dependency: libssl.so.5 for package: psa-drweb-configurator
--> Processing Dependency: libssl.so.5 for package: php51-mysqli
--> Processing Dependency: libcrypto.so.5 for package: psa-spamassassin
--> Processing Dependency: libssl.so.5 for package: psa-watchdog
--> Processing Dependency: libssl.so.5 for package: psa-hotfix3-9.2.3
--> Processing Dependency: libcrypto.so.5 for package: psa-backup-manager
--> Processing Dependency: libcrypto.so.5 for package: php51-pdo_mysql
--> Processing Dependency: libssl.so.5 for package: php51-curl
--> Processing Dependency: libcrypto.so.5 for package: psa-migration-manager
--> Processing Dependency: libcrypto.so.5 for package: psa-vpn
--> Processing Dependency: libssl.so.5 for package: php51-ftp
--> Processing Dependency: libcrypto.so.5 for package: PPWSE
--> Processing Dependency: libssl.so.5 for package: php5sb
--> Processing Dependency: libssl.so.5 for package: psa-migration-manager
--> Processing Dependency: libcrypto.so.5 for package: psa-mail-qc-driver
--> Processing Dependency: libboost_date_time.so.1 for package: sw-engine
--> Processing Dependency: libcrypto.so.5 for package: psa-kav
--> Processing Dependency: libcrypto.so.5 for package: php51-ftp
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
--> Running transaction check
Error: Missing Dependency: libmysqlclient.so.14(libmysqlclient_14) is needed by package psa-fileserver
Error: Missing Dependency: libssl.so.5 is needed by package psa-fileserver
Error: Missing Dependency: libcrypto.so.5 is needed by package cs-gs
Error: Missing Dependency: libcrypto.so.5 is needed by package php51-mysqli
Error: Missing Dependency: libcrypto.so.5 is needed by package sw-sso-migrate
Error: Missing Dependency: libssl.so.5 is needed by package psa-backup-manager
Error: Missing Dependency: libcrypto.so.5 is needed by package ruby-mysql
Error: Missing Dependency: libc-client.so.0 is needed by package sw-engine
Error: Missing Dependency: libcrypto.so.5 is needed by package psa-spamassassin
Error: Missing Dependency: libcrypto.so.5 is needed by package php51-curl
Error: Missing Dependency: libssl.so.5 is needed by package php51-curl
Error: Missing Dependency: libcrypto.so.5 is needed by package psa
Error: Missing Dependency: libssl.so.5 is needed by package psa-bf2
Error: Missing Dependency: libmysqlclient.so.14(libmysqlclient_14) is needed by package ruby-mysql
Error: Missing Dependency: libcrypto.so.5 is needed by package php51-openssl
Error: Missing Dependency: libcrypto.so.5 is needed by package psa-autoinstaller
Error: Missing Dependency: libcrypto.so.5 is needed by package psa-bf2
Error: Missing Dependency: libssl.so.5 is needed by package ruby-mysql
Error: Missing Dependency: libcrypto.so.5 is needed by package miva-ssl-stub
Error: Missing Dependency: libssl.so.5 is needed by package sw-engine
Error: Missing Dependency: php <= 5.1.0 is needed by package php-sqlite2
Error: Missing Dependency: libssl.so.5 is needed by package sw-cp-server
Error: Missing Dependency: libcrypto.so.5 is needed by package psa-bf1942
Error: Missing Dependency: libssl.so.5 is needed by package psa-drweb-configurator
Error: Missing Dependency: libcrypto.so.5 is needed by package psa-qmail
Error: Missing Dependency: libcrypto.so.5 is needed by package psa-fileserver
Error: Missing Dependency: libcrypto.so.5 is needed by package psa-watchdog
Error: Missing Dependency: libssl.so.5 is needed by package miva-ssl-stub
Error: Missing Dependency: libcrypto.so.5 is needed by package psa-backup-manager
Error: Missing Dependency: libssl.so.5 is needed by package psa-spamassassin
Error: Missing Dependency: libssl.so.5 is needed by package php51-pdo_mysql
Error: Missing Dependency: libboost_date_time.so.1 is needed by package sw-engine
Error: Missing Dependency: libssl.so.5 is needed by package php51-mysqli
Error: Missing Dependency: libboost_filesystem.so.1 is needed by package sw-engine
Error: Missing Dependency: libcrypto.so.5 is needed by package sw-engine
Error: Missing Dependency: libssl.so.5 is needed by package PPWSE
Error: Missing Dependency: libssl.so.5 is needed by package psa-mail-qc-driver
Error: Missing Dependency: libcrypto.so.5 is needed by package psa-migration-manager
Error: Missing Dependency: libssl.so.5 is needed by package psa-proftpd
Error: Missing Dependency: libcrypto.so.5 is needed by package psa-mail-driver-common
Error: Missing Dependency: libcrypto.so.5 is needed by package psa-drweb-configurator
Error: Missing Dependency: libssl.so.5 is needed by package cs-gs
Error: Missing Dependency: libssl.so.5 is needed by package courier-imap
Error: Missing Dependency: libssl.so.5 is needed by package psa-mail-driver-common
Error: Missing Dependency: libcrypto.so.5 is needed by package psa-hotfix3-9.2.3
Error: Missing Dependency: libssl.so.5 is needed by package psa-qmail
Error: Missing Dependency: libssl.so.5 is needed by package psa-hotfix3-9.2.3
Error: Missing Dependency: libcrypto.so.5 is needed by package php51-pdo_mysql
Error: Missing Dependency: libcrypto.so.5 is needed by package psa-mail-qc-driver
Error: Missing Dependency: libssl.so.5 is needed by package php5sb
Error: Missing Dependency: libcrypto.so.5 is needed by package php51-ftp
Error: Missing Dependency: libcrypto.so.5 is needed by package psa-proftpd
Error: Missing Dependency: libcrypto.so.5 is needed by package courier-imap
Error: Missing Dependency: libcrypto.so.5 is needed by package psa-kav
Error: Missing Dependency: libmysqlclient.so.14(libmysqlclient_14) is needed by package psa-drweb-configurator
Error: Missing Dependency: libssl.so.5 is needed by package php51-openssl
Error: Missing Dependency: libssl.so.5 is needed by package psa-kav
Error: Missing Dependency: libmysqlclient.so.14(libmysqlclient_14) is needed by package cs-gs
Error: Missing Dependency: libssl.so.5 is needed by package sw-sso-migrate
Error: Missing Dependency: libssl.so.5 is needed by package psa-bf1942
Error: Missing Dependency: libcrypto.so.5 is needed by package sw-cp-server
Error: Missing Dependency: libssl.so.5 is needed by package psa-migration-manager
Error: Missing Dependency: libcrypto.so.5 is needed by package PPWSE
Error: Missing Dependency: libssl.so.5 is needed by package psa-watchdog
Error: Missing Dependency: libssl.so.5 is needed by package psa-autoinstaller
Error: Missing Dependency: libcrypto.so.5 is needed by package psa-vpn
Error: Missing Dependency: libssl.so.5 is needed by package php51-ftp
Error: Missing Dependency: libcrypto.so.5 is needed by package php5sb
Error: Missing Dependency: libssl.so.5 is needed by package psa
Error: Unable to satisfy dependencies
Error: Package psa-fileserver needs libmysqlclient.so.14(libmysqlclient_14), this is not available.
Error: Package psa-proftpd needs libssl.so.5, this is not available.
Error: Package php51-openssl needs libcrypto.so.5, this is not available.
Error: Package ruby-mysql needs libssl.so.5, this is not available.
Error: Package psa-mail-qc-driver needs libssl.so.5, this is not available.
Error: Package sw-engine needs libssl.so.5, this is not available.
Error: Package ruby-mysql needs libcrypto.so.5, this is not available.
Error: Package courier-imap needs libcrypto.so.5, this is not available.
Error: Package psa-bf2 needs libssl.so.5, this is not available.
Error: Package cs-gs needs libcrypto.so.5, this is not available.
Error: Package psa-autoinstaller needs libcrypto.so.5, this is not available.
Error: Package psa-bf2 needs libcrypto.so.5, this is not available.
Error: Package psa-spamassassin needs libssl.so.5, this is not available.
Error: Package psa-drweb-configurator needs libmysqlclient.so.14(libmysqlclient_14), this is not available.
Error: Package php51-openssl needs libssl.so.5, this is not available.
Error: Package sw-engine needs libboost_filesystem.so.1, this is not available.
Error: Package miva-ssl-stub needs libcrypto.so.5, this is not available.
Error: Package psa needs libcrypto.so.5, this is not available.
Error: Package psa-backup-manager needs libssl.so.5, this is not available.
Error: Package psa needs libssl.so.5, this is not available.
Error: Package sw-engine needs libcrypto.so.5, this is not available.
Error: Package hal conflicts with kernel < 2.6.15.
Error: Package psa-autoinstaller needs libssl.so.5, this is not available.
Error: Package php5sb needs libcrypto.so.5, this is not available.
Error: Package php51-mysqli needs libcrypto.so.5, this is not available.
Error: Package sw-sso-migrate needs libcrypto.so.5, this is not available.
Error: Package PPWSE needs libssl.so.5, this is not available.
Error: Package kudzu conflicts with kernel < 2.6.13.
Error: Package php-sqlite2 needs php <= 5.1.0, this is not available.
Error: Package sw-cp-server needs libssl.so.5, this is not available.
Error: Package psa-qmail needs libssl.so.5, this is not available.
Error: Package sw-engine needs libc-client.so.0, this is not available.
Error: Package initscripts conflicts with kernel < 2.6.12.
Error: Package psa-bf1942 needs libcrypto.so.5, this is not available.
Error: Package ruby-mysql needs libmysqlclient.so.14(libmysqlclient_14), this is not available.
Error: Package sw-sso-migrate needs libssl.so.5, this is not available.
Error: Package sw-cp-server needs libcrypto.so.5, this is not available.
Error: Package psa-mail-driver-common needs libcrypto.so.5, this is not available.
Error: Package psa-bf1942 needs libssl.so.5, this is not available.
Error: Package psa-qmail needs libcrypto.so.5, this is not available.
Error: Package psa-kav needs libssl.so.5, this is not available.
Error: Package psa-drweb-configurator needs libcrypto.so.5, this is not available.
Error: Package psa-fileserver needs libcrypto.so.5, this is not available.
Error: Package cs-gs needs libmysqlclient.so.14(libmysqlclient_14), this is not available.
Error: Package psa-proftpd needs libcrypto.so.5, this is not available.
Error: Package cs-gs needs libssl.so.5, this is not available.
Error: Package psa-watchdog needs libcrypto.so.5, this is not available.
Error: Package courier-imap needs libssl.so.5, this is not available.
Error: Package php51-pdo_mysql needs libssl.so.5, this is not available.
Error: Package php51-curl needs libcrypto.so.5, this is not available.
Error: Package miva-ssl-stub needs libssl.so.5, this is not available.
Error: Package psa-fileserver needs libssl.so.5, this is not available.
Error: Package psa-mail-driver-common needs libssl.so.5, this is not available.
Error: Package psa-hotfix3-9.2.3 needs libcrypto.so.5, this is not available.
Error: Package psa-drweb-configurator needs libssl.so.5, this is not available.
Error: Package php51-mysqli needs libssl.so.5, this is not available.
Error: Package psa-spamassassin needs libcrypto.so.5, this is not available.
Error: Package psa-watchdog needs libssl.so.5, this is not available.
Error: Package psa-hotfix3-9.2.3 needs libssl.so.5, this is not available.
Error: Package psa-backup-manager needs libcrypto.so.5, this is not available.
Error: Package php51-pdo_mysql needs libcrypto.so.5, this is not available.
Error: Package php51-curl needs libssl.so.5, this is not available.
Error: Package psa-migration-manager needs libcrypto.so.5, this is not available.
Error: Package psa-vpn needs libcrypto.so.5, this is not available.
Error: Package php51-ftp needs libssl.so.5, this is not available.
Error: Package PPWSE needs libcrypto.so.5, this is not available.
Error: Package php5sb needs libssl.so.5, this is not available.
Error: Package psa-migration-manager needs libssl.so.5, this is not available.
Error: Package psa-mail-qc-driver needs libcrypto.so.5, this is not available.
Error: Package sw-engine needs libboost_date_time.so.1, this is not available.
Error: Package psa-kav needs libcrypto.so.5, this is not available.
Error: Package php51-ftp needs libcrypto.so.5, this is not available.

Alors faut-il supprimer complètement Plesk et les autres packages qui posent problème, quitte à les réinstaller après la fin de toutes les mises à jour de versions ? Et dans le cas où cela fonctionne, est ce que je pourrais réinstaller Plesk via rpm après, en récupérant la clé de licence du serveur actuel, et retrouver un Plesk fonctionnel contenant les infos du serveur, les domaines, emails, etc ?

Je sais qu'il vaudrait mieux tout réinstaller sur un nouveau serveur, mais j'aimerais quand même essayer de mettre à jour s'il y a une solution.

Un grand merci à tous de votre aide.