OVH Community, votre nouvel espace communautaire.

sdns1.ovh.net refuse de se mettre à jour.


Petit Bonhomme
10/12/2014, 09h37
Bonjour,
Merci pour ces précisions concernant OVHM (my bad).
Pas de soucis concernant les autres configurations, celle utilisée en ce moment n'était que pour arriver à faire déménager sdns2.ovh.net vers le nouveau serveur avec une config minimale.
Ma configuration contient bien hostname.domain.tld ainsi qu'une zone reverse DNS et tout et tout, ainsi que le MX, SPF etc
Le GLUE est là car sinon, j'ai une boucle sur les DNS ns1.domain.tld -> DNS primaire de domain.tld
Et ce matin, ô joie !

Code:
$ dig @sdns2.ovh.net domain.tld

; <<>> DiG 9.10.1 <<>> @sdns2.ovh.net domain.tld
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 38974
;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1
;; WARNING: recursion requested but not available

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;domain.tld.              IN      A

;; ANSWER SECTION:
domain.tld.       3600    IN      A       1.2.3.4

;; Query time: 40 msec
;; SERVER: 213.251.188.141#53(213.251.188.141)
;; WHEN: Wed Dec 10 09:20:59 Eur 2014
;; MSG SIZE  rcvd: 61
Le seul problème étant ici l'oublie de supprimer le sdns1.ovh.net dans OVH ManagerV6 ( Dédié > Infrastructure > ns000000.ovh.net > DNS secondaires, puis supprimer domain.tld) et ensuite dans SoYouStart, DNS secondaire > Ajouter un DNS secondaire > Faire la modification TXT dans Bind (incrémenter/redémarer), et valider le formulaire.

Quelques heures plus tards, tout est bon

Je tiens à vous remercier tout les deux. Vous m'avez permis en 3-4 heures de corriger un problème sur lequel je bloque depuis plusieurs jours.
J'ai contacté le support OVH vendredi dernier ... je n'ai toujours pas de réponse :/
Maintenant, je sais que le forum est bien plus efficace (et puis ça permet de laisser une trace du problème et de la résolution pour les autres).

Merci encore

bbr18
10/12/2014, 06h39
Plusieurs choses, déjà OVHM ce n'est pas un manager mais une partie du panel de la Release 2 ou 3, ne pas confondre avec manager v3 ou v6
Pour ton domaine tu dois configurer plusieurs choses :
sur le manager V3 ou V6 pour le nom de domaine, tu dois mettre en DNS primaire le nom de ton serveur (c'est fait) et en DNS secondaire sdns2.ovh.net (l'as-tu fait ?)
Sur le serveur dans Bind, mettre le bon dns secondaire (c'est fait je crois), et ne pas oublier de redémarrer le service
j'ai configuré un GLUE record "ns1.domain.tld" ce n'était pas indispensable
sur le manager du serveur (soyoustart), tu dois ajouter le nom de domaine dans les dns secondaires de ce serveur (c'est fait)
Pense aussi dans le manager SYS à mettre le nom du domaine en reverse sur l'ip
et pour tes envois de mails, pense à changer le hostname, la config du serveur de mail, ajouter un spf, etc.

Petit Bonhomme
09/12/2014, 23h15
Une heure après les changements... sdns2 vient de faire une "query" sur mon serveur.

après un "dig @sdns2.ovh.net domain.tld"
le statut change de "status: REFUSED" à "status: SERVFAIL".

J'imagine qu'il faut attendre encore un peu que sdns2 lance un transfert de zone...
A suivre.

Petit Bonhomme
09/12/2014, 22h27
Bonsoir à tout les deux,

Pour le "allow-transfer" aucun problème.

Par contre, effectivement comme bbr18 me l'a dit c'est les DNS secondaire de l'ancien serveur.
J'avais jamais fait attention que dans le ManagerV3, partie Dédié, il y avait une partie DNS secondaires.
J'avais toujours configuré les DNS primaire et secondaire dans la partie "nom de domaine", et le reste sur mon serveur dédié.

Donc, pour les autres qui auraient le même problème que moi, voici ce que j'ai fait :
Sur OVH Manager (V6)
Partie Dédié > Infrastructure > ns0000000.ovh.net
Onglet : DNS secondaire
(Dans mon 2e post je disais que "Aucun DNS secondaire n'a été configuré." j'ai du aller dans le OVHM v3 car un autre domaine en double (???) et résilié depuis longtemps causait une erreur, une fois supprimé la liste est enfin apparue)
J'ai supprimé le domaine domain.tld de l'ancien serveur.

J'ai enfin pu ajouter le domain.tld dans l'interface SoYouStart > DNS secondaires
Le DNS secondaire a correctement été ajouté
Concernant sdns1 ou sdns2, tout mes domaines (sauf 2-3 plus vieux) sont sur sdns2.
Comme domain.tld était sur sdns1 à l'origine, j'ai cru que lors du transfert vers le nouveau serveur, il devait rester sur sdns1.

J'ai changé sdns1 par sdns2 dans bind (changé le serial of course) redémarré....
Changé sdns1 par sdns2 dans OVHM.
Tout semble bien configurer, je vais attendre la propagation...
Je vous tiens au courant

bbr18
09/12/2014, 21h15
as-tu encore l'ancien serveur dans ton manager V6
si oui dans dédié, infrastructures, ton ancien serveur puis DNS secondaire de ce serveur tu dois avoir le domaine, tu cliques sur la poubelle pour le virer
et mets sdns2 en secondaire sur le nouveau

buddy
09/12/2014, 21h05
Il faut aussi bien régler le "allow-transfer"
Tu es sur que c'est sdns1.ovh.net toujours ? maintenant c'est passé à sdns2.ovh.net

Petit Bonhomme
09/12/2014, 21h00
Bonsoir et merci pour ton aide

J'ai vu à plusieurs reprise sur les forums qu'on parlait d'enlever les DNS secondaires d'un serveur et les ajouter sur le nouveau. Mais je ne savais pas s'ils parlaient de Bind ou autre chose.

Sur le Manager SoYouStart, il y a un onglet "DNS Secondaires".
Je crois comprendre que ça permet à OVH de déterminer qui sont ses clients afin d'éviter que n'importe qui utilise leurs serveurs comme DNS Secondaire (ou pas?).

Dans tout les cas, j'avais tenté d'ajouter domain.tld ainsi que son ip 1.2.3.4, et j'ai suivi le message :
Avant de continuer, vous devez rajouter un champ de type TXT dans la zone DNS du domaine "domain.tld", avec le sous-domaine ownercheck et la valeur suivante : xxxxxxxxxx.
Mais j'ai l'erreur :
This domain is already configured on secondary dns server
J'en conclus que je dois l'enlever de l'ancien serveur, sauf que ... je vois pas sur le ManagerV6 où changer cela.
J'ai regardé dans l'onglet "Dédié" > "Infrastructure" > "DNS secondaire" :
"Aucun DNS secondaire n'a été configuré."

Peux-tu m'en dire plus sur comment retirer le domaine des dns secondaires de l'ancien serveur ?

bbr18
09/12/2014, 17h38
et as-tu retiré le domaine des dns secondaires de l'ancien serveur ? puis ajouté ce domaine dans les dns secondaires du nouveau ?

Petit Bonhomme
09/12/2014, 17h08
Bonjour à tous,

Je migre d'un vieux serveur dédié OVH à un serveur SoYouStart et les dns secondaires OVH refuse de communiquer avec le nouveau serveur.
Le serveur "sdns1.ovh.net" continue de tenter les transferts de zone depuis l'ancien serveur.
Je constate donc toujours des requêtes dans les logs depuis l'ancien, et aucune requête sur le nouveau (même dans les logs de refus).
A savoir qu'il n'y a pas de pare-feu (serveur de test pour le moment ^^ ) donc pas de soucis de ce côté.

Posons le tableau :
Code:
FQDN                   : domain.tld

Ancien serveur         : ns0000000.ovh.net
Ancien DNS primaire    : ns0000000.ovh.net
Ancien DNS secondaire  : sdns1.ovh.net

Nouveau serveur        : ns0000000.ip-1-2-3.eu
Nouveau DNS primaire   : ns1.domain.tld
Nouveau DNS secondaire : sdns1.ovh.net
J'ai commencé par configurer Bind sur le nouveau serveur (et le serial qui augmente bien sûr),
j'ai configuré un GLUE record "ns1.domain.tld" dans OVHM (Managerv3 puisque ce n'est pas possible depuis la V6),
j'ai ajouté les dns primaire et secondaire dans OVHM,
j'ai redémarré Bind, augmenté le serial, cherché, forum, vérifié, réaugmenté le serial, redémarré Bind, etc, etc....
j'ai pris des dolipranes pendant 15 jours....

D'avance merci pour vos conseils... là, je sais plus quoi faire.



Pour aller plus vite, voici toutes les configurations ainsi que les dig ci-dessous :

named.conf.options
Code:
options {
  directory "/var/cache/bind";

  auth-nxdomain no;    # conform to RFC1035
  
  listen-on { any; };  
  allow-query { any; };  
  allow-query-cache { any; };  
  allow-recursion { localhost; };  
  allow-transfer { any; };  

  notify yes;
  notify-source 1.2.3.4;
  
  version none;
  
};

logging {
   ...
};
named.conf.local
Code:
include "/etc/bind/zones.rfc1918";
zone "domain.tld" { type master; file "/etc/bind/zones/domain.tld"; };
zone domain.tld
Code:
$TTL 1H
domain.tld. IN SOA ns1.domain.tld. postmaster.domain.tld. (
  2014120901  ; Serial
  1H          ; Refresh
  15M         ; Retry
  1W          ; Expire
  1H          ; Minimum
)

      IN      NS      ns1.domain.tld.
      IN      NS      sdns1.ovh.net.

      IN      A       1.2.3.4
ns1   IN      A       1.2.3.4
Et les dig sur les deux serveurs DNS :

Code:
$ dig @ns1.domain.tld domain.tld

; <<>> DiG 9.10.1 <<>> @ns1.domain.tld domain.tld
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 54600
;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 4
;; WARNING: recursion requested but not available

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;domain.tld.                    IN      A

;; ANSWER SECTION:
domain.tld.             3600    IN      A       1.2.3.4

;; AUTHORITY SECTION:
domain.tld.             3600    IN      NS      sdns1.ovh.net.
domain.tld.             3600    IN      NS      ns1.domain.tld.

;; ADDITIONAL SECTION:
sdns1.ovh.net.          84872   IN      A       213.251.188.140
sdns1.ovh.net.          84872   IN      AAAA    2001:41d0:1:4a8c::1
ns1.domain.tld.         3600    IN      A       1.2.3.4

;; Query time: 50 msec
;; SERVER: 1.2.3.4#53(1.2.3.4)
;; WHEN: Tue Dec 09 16:09:32 Eur 2014
;; MSG SIZE  rcvd: 169
Code:
$ dig @sdns1.ovh.net domain.tld

; <<>> DiG 9.10.1 <<>> @sdns1.ovh.net domain.tld
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 52402
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1
;; WARNING: recursion requested but not available

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;domain.tld.                    IN      A

;; Query time: 40 msec
;; SERVER: 213.251.188.140#53(213.251.188.140)
;; WHEN: Tue Dec 09 16:03:58 Eur 2014
;; MSG SIZE  rcvd: 45