OVH Community, votre nouvel espace communautaire.

Tache Cron - Release 3 - Spam Assassin - Argument "perl_version" isn't numeric


Eclipse68
19/01/2015, 06h57
Resolu

Eclipse68
19/01/2015, 03h06
Resolu

Eclipse68
12/12/2014, 06h52
Idem, c'est jhonbauwens qui m'a ouvert la voie, merci à lui, car je me serais senti bien seul.

Enfin, un collègue SysAdmin m'avait répondu le jour même, mais je n'avais pas pris le temps de poster ( désolé jhonbauwens ).

Pas de quoi y passer du temps.
C'est une erreur sur l'update quotidienne de spamassassin.
Si cela ne se reproduit pas, problème fini.

Merci Nowwhat pour le complément que tu as pris le temps de poster, je vais lire cela et m'instruire un petit peu.

jhonbauwens
04/12/2014, 11h53
Pareil, le sujet n'était pas encore abordé quand je l'ai vu

Plus de problème pour ma part ! Ils ont probablement corrigé le bug

fritz2cat
01/12/2014, 10h16
Bien sûr que je l'ai vu. Mais quand je l'ai vu samedi matin Google n'a pas été mon ami sur ce coup-là.
Faut dire qu'on se lève 6 heures plus tôt que les ricains.
/etc/cron.daily/99sa-update:
Argument "perl_version" isn't numeric in numeric ge (>=) at (eval 610) line 1.
Argument "perl_version" isn't numeric in numeric ge (>=) at (eval 1094) line 1.
Stopping spam checking proxy daemon: spampd .
Starting spam checking proxy daemon: spampdArgument "perl_version" isn't numeric in
numeric ge (>=) at (eval 511) line 1.
Argument "perl_version" isn't numeric in numeric ge (>=) at (eval 995) line 1.

Nowwhat
01/12/2014, 08h38
Citation Envoyé par jhonbauwens
.....
Code:
Argument "perl_version" isn't numeric in numeric ge (>=) at (eval 624) line 1. 
Argument "perl_version" isn't numeric in numeric ge (>=) at (eval 1108) line 1.
Quelqu'un a-t-il également cette erreur? Et quelle solution?
Yep.
Facile.
Car:
Google Argument "perl_version" isn't numeric in numeric ge et bingo: il s'agit d'un situation introduit vers le 29 novembre 2014.
La mise à jour des règles de spamassassin introduit un règle qui utilise le variable "perl_version", ce qui fait que leur compilation se plante - et le cron pleure. Un mail est le résultat.

Normalement, il suffit d'utiliser une version récente de Spamassassin, et le soucis disparaitra.
Mais bon, Il s'agit d'un R3 - donc ... négatif. Il faut dire que j'utilise sur mon Debian 7.7 aussi la version préconisé de Spamassassin (un vieille version) , donc j'ai vu exactement la même chose que toi.
Une réponse sur le comment et pourquoi débute ici: http://askubuntu.com/questions/55453...val-534-line-1
Mais le sujet existe un peu partout sur le net depuis Vendredi dernier.

J'ai utilisé ceci https://svn.apache.org/viewvc?view=r...vision=1642207 pour patcher les deux fichiers concernant.

Je suis un peu surpris que le sujet s’affiche que maintenant sur ce forum ..... (et forum.kimsufi.com). Tout le monde Google maintenant avant de poser des questions ?

edit:
Citation Envoyé par fritz2cat
Je confirme. Ce message d'erreur se produit aussi bien avec les distrib Ubuntu, Debian, Redhat, SLES, et d'autres.

Sur la mailing list Spamassassin c'est même la *grosse chaude discussion* entre partisans de fonctionnalités améliorées et partisans du zéro warning.

Entretemps il faut ignorer le message car ça ne casse aucune fonctionnalié.
Ok, ça me rassure.
Tu l'a vu aussi.

Mais ignorer ? Non. Il s'agit d'un mail chaque 3 heures sur ma boite "bobo-sur-serveur" donc ça me gonfle.
Les divers discussions chez apache/spamassassin ne vont penser qu'un mise à jour va être pondu de toute façon bientôt, j'ai patché moi même le truc.

fritz2cat
01/12/2014, 08h12
Je confirme. Ce message d'erreur se produit aussi bien avec les distrib Ubuntu, Debian, Redhat, SLES, et d'autres.

Sur la mailing list Spamassassin c'est même la *grosse chaude discussion* entre partisans de fonctionnalités améliorées et partisans du zéro warning.

Entretemps il faut ignorer le message car ça ne casse aucune fonctionnalié.

jhonbauwens
30/11/2014, 22h02
Ils en parlent sur le forum de Spamassassin. Ils sont au courant... C'est juste une alerte. Rien de grave probablement rétabli dans la prochaine MAJ

Eclipse68
30/11/2014, 16h15
+1 Alerte Daemon Cron

/usr/share/spamassassin/sa-update.cron 2>&1 | tee -a /var/log/sa-update.log
Argument "perl_version" isn't numeric in numeric ge (>=) at (eval 624) line 1.
Argument "perl_version" isn't numeric in numeric ge (>=) at (eval 1108) line 1.

jhonbauwens
30/11/2014, 13h59
Bonjour à tous,

Depuis la mise à jour des packets de ma release 3, j'ai ce problème avec cette taches cron:

Code:
Cron  /usr/share/spamassassin/sa-update.cron 2>&1 | tee -a /var/log/sa-update.log
Code:
Argument "perl_version" isn't numeric in numeric ge (>=) at (eval 624) line 1. 
Argument "perl_version" isn't numeric in numeric ge (>=) at (eval 1108) line 1.
Quelqu'un a-t-il également cette erreur? Et quelle solution?

Merci à tous!

Bon dimanche,

Jhon