OVH Community, votre nouvel espace communautaire.

Page affiché sans soucis, mais erreur 500 retournée dans la console o.0


Gaston_Phone
04/03/2015, 13h46
Citation Envoyé par miekal33
fait qu'une erreur 500 soit généré empêche le bon fonctionnement de mon javascript.
Je n'ai pas compris.

miekal33
04/03/2015, 07h25
fait qu'une erreur 500 soit généré empêche le bon fonctionnement de mon javascript.

Maz83
29/11/2014, 19h48
J'ai trouvé ce qui faisait plantait mon script, mais ce n'était pas un caractère non ASCII, mais des requête SQL avec un nom de table différent en local et sur le site, aucune erreur PHP n'était pourtant rapporter... Problème résolu.

Merci.

Gaston_Phone
29/11/2014, 19h47
Citation Envoyé par Maz83
EDIT: Je viens de remarquer en regardant le code source de la page affiché que la moitié de mon script est exécuté... J'ai essayé de voir s'il y avait une erreur avec error_reporting(E_ALL); mais rien...
Je me demande si, dans la 2ème partie de ton script, il n'y a pas un caractère NON ASCII qui empêcherai l'exécution de la suite du script.

Maz83
29/11/2014, 19h32
Citation Envoyé par Gaston_Phone
Qu'appelles-tu la console ?
J'ai mis une image pour la montrer, j'utilise les outils de développement intégré à Chrome.

Le log d'Apache aussi montre l'erreur 500:

78.249.217.128 devis.2b-alu.fr - [29/Nov/2014:19:27:25 +0100] "GET /formulaire_produit.php?id_form=1&id_produit=3&nom_ produit=Coffre+tunnel HTTP/1.1" 500 459 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.71 Safari/537.36"


EDIT: Je viens de remarquer en regardant le code source de la page affiché que la moitié de mon script est exécuté... J'ai essayé de voir s'il y avait une erreur avec error_reporting(E_ALL); mais rien...

Gaston_Phone
29/11/2014, 19h26
Qu'appelles-tu la console ?

Maz83
29/11/2014, 19h05
Bonjour,
je viens vers vous car j'ai un petit soucis avec un de mes script, tout simple pourtant, il s'agît d'un tout petit formulaire qui se trouves ici: http://devis.2b-alu.fr/formulaire_pr...=Coffre+tunnel

Le plus étrange, c'est que la page s'affiches correctement, mais dans la console, il me retournes une erreur 500.



Vous me direz: pas de soucis, tant que ça s'affiches... Oui mais... Ce bout de formulaire est appelé puis affiché via une requête AJAX, et le fait qu'une erreur 500 soit généré empêche le bon fonctionnement de mon javascript.

D'autres script sur le même serveur sont appelé via AJAX de la même manière sans aucun soucis.

Avez-vous déjà rencontré ce problème?

Merci