OVH Community, votre nouvel espace communautaire.

Pourquoi la Propagation DNS de mon Sous-domaine tombe-t'elle en panne régulièrement ?


ManuTOO
21/11/2014, 02h57
Yup, maintenant quasi tous les serveurs sont verts tout le temps, encore merci pour le coup de main !

fritz2cat
20/11/2014, 11h11
A mon avis, c'est réglé.

ManuTOO
20/11/2014, 10h46
@fritz2cat,
ok merci.
Le fichier zone a bien cette ligne :
static.managames.com. IN A 91.121.132.12
Mais j'imagine que le prb est que mes sous-domaines ne sont pas propagés au NS d'OVH avec les params par défaut de Virtualmin/Webmin...
Enfin là "static" est un peu spécial, vu qu'il se retrouve avec son propre fichier zone (comme ks201441.managames.com), alors que mes autres sous-domaines sont juste listés dans le fichier zone de managames.com .
Je viens de le rajouter manuellement dans l'onglet "DNS secondaire" de mon manager OVH, on verra si cela règle le problème ou pas...

fritz2cat
20/11/2014, 09h53
Non ce n'est pas normal.
Et un sous-domaine c'est simplement une ligne 'A' dans ton fichier zone.

ManuTOO
20/11/2014, 09h46
fritz2cat,
je viens de changer la méthode de numérotation pour le serial (c'état bien planqué dans => Webmin -> Servers -> BIND DNS Server -> Module Config -> Zone File Options -> Serial number style ! ).
Sinon, ce n'est pas normal que ks201441 & ns soient différents ? Il me semblait que ns ne devait pas contenir les sous-domaines ; en tout cas, aucun n'est listé dans l'onglet "DNS secondaire" de mon manager OVH à l'expection de ks201441.managames.com , mais j'aurais p'tet du y ajouter manuellement static.managames.com (et mes autres sous-domaines) ..?

fritz2cat
20/11/2014, 08h03
Tu devrais vérifier si tu incrémentes bien le serial number de ta zone, car ks201441.kimsufi.com et ns.kimsufi.com ne contiennent pas la même info, mais ont le même serial 1371547569.
D'ailleurs tu ne respectes pas les conventions d'écriture yyyymmddnn pour le serial. Ce n'est pas une obligation mais c'est plus lisible.

ManuTOO
20/11/2014, 02h56
Bonjour,

j'utilise static.managames.com pour servir les images, .css & autres choses statiques, mais régulièrement, certains serveurs DNS mondiaux ne savent plus où se trouve ce sous-domaine !
Je vérifie la propagation ici => https://www.whatsmydns.net/#A/static.managames.com .
Il me semble que généralement cela revient au bout de moins d'1h, puis ça repart à nouveau.
Ce n'est jamais l'ensemble des serveurs qui sont problématiques, seulement certains d'entre eux.

Ma config : Virtualmin avec Debian 6.
Note: static.managames.com est un "Virtual Server" et non pas un "Sub-server" ; cela me permet de le mapper sur le contenu de managames.com facilement, et de passer de l'un à l'autre selon les cas.

Est-ce que quelqu'un aurait une idée de la cause de ce phénomène ?

Merci d'avance pour toute aide !