OVH Community, votre nouvel espace communautaire.

Une adresse ip bloquée et une autre adresse ip SMTP (25) bloqué sur un serveur ovh


martro
18/11/2014, 13h52
Bon je me répond
suite à l'intervention du service technique de OVH (merci) c'est la config du network (interface).
(cela est du à votre configuration pour vos ips failovers qui n'est pas correcte) mea-culpa

http://guide.ovh.com/AjouterAliasIp

version original:
auto eth0
iface eth0 inet static
address 37.187.160.71
netmask 255.255.255.0
network 37.187.160.0
broadcast 37.187.160.255
gateway 37.187.160.254

auto eth0:0
iface eth0:0 inet static
address 188.165.33.55

auto eth0:1
iface eth0:1 inet static
address 46.105.55.171

version corrigée:
auto eth0
iface eth0 inet static
address 37.187.160.71
netmask 255.255.255.0
network 37.187.160.0
broadcast 37.187.160.255
gateway 37.187.160.254

auto eth0:0
iface eth0:0 inet static
address 188.165.33.55
netmask 255.255.255.255
broadcast 188.165.33.55

auto eth0:1
iface eth0:1 inet static
address 46.105.55.171
netmask 255.255.255.255
broadcast 46.105.55.171

martro
14/11/2014, 19h36
Merci pour ta réponse j'ai des informations au sujet de l'adresse de mon client (46.14.38.213) il semble que c'est swisscom qui bloque l'adresse pour cause de virus

Par contre je n'ai toujours pas de solution pour le port 25 bloqué sur mx1.lenzlinger.com 25 (46.140.90.148) et j'ai trouvé une nouvelle adresse qui est bloquée mail1.openerp.com (46.105.124.125)

avec ou sans firewall toujours le même comportement ! je suppose que c'est l'adresse ip ou le serveur chez ovh ?

j'ai des adresses ip virtuels et je voulais permuter une adresse virtuel sur l'interface eth0 pour voir si le problème persiste !
remplacé 37.187.160.71 par 46.105.55.171, mais je ne sais pas si je peut utiliser la passerelle (37.187.160.254) où si ça pose un problème !
peut-être c'est la passerelle qui à un problème ?

root@bk0001:~# ifconfig
eth0 Link encap:Ethernet HWaddr 00:25:90:f1:06:d4
inet adr:37.187.160.71 Bcast:37.187.160.255 Masque:255.255.255.0
adr inet6: fe80::225:90ff:fef1:6d4/64 Scope:Lien
adr inet6: 2001:41d0:d:47::/64 Scope:Global
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1152090 errors:0 dropped:0 overruns:0 frame:0
TX packets:482157 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:197566950 (188.4 MiB) TX bytes:179695765 (171.3 MiB)
Mémoire:df260000-df280000

eth0:0 Link encap:Ethernet HWaddr 00:25:90:f1:06:d4
inet adr:188.165.33.55 Bcast:178.33.243.158 Masque:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Mémoire:df260000-df280000

eth0:1 Link encap:Ethernet HWaddr 00:25:90:f1:06:d4
inet adr:46.105.55.171 Bcast:46.255.255.255 Masque:255.0.0.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Mémoire:df260000-df280000


root@bk0001:~# route
Table de routage IP du noyau
Destination Passerelle Genmask Indic Metric Ref Use Iface
default 37.187.160.254 0.0.0.0 UG 0 0 0 eth0
37.187.160.0 * 255.255.255.0 U 0 0 0 eth0
46.0.0.0 * 255.0.0.0 U 0 0 0 eth0
178.32.0.0 * 255.255.0.0 U 0 0 0 eth0
188.165.33.0 * 255.255.255.0 U 0 0 0 eth0

elouez
14/11/2014, 16h39
Ce ne serait pas son antivirus ou fw qui bloque plutot !
Demande lui de faire des tests telnet sur les ports 110, 25 etc de ton serveur puis ceux d'Orange.fr par exemple.

martro
14/11/2014, 16h26
encore des test !
Sur: root@services:/# traceroute 46.140.90.148
traceroute to 46.140.90.148 (46.140.90.148), 30 hops max, 60 byte packets
1 37.187.129.253 (37.187.129.253) 0.278 ms * *
2 gra-g1-a9.fr.eu (178.33.103.225) 0.702 ms 0.756 ms 0.811 ms
3 37.187.36.47 (37.187.36.47) 2.705 ms 2.770 ms rbx-g2-a9.fr.eu (37.187.36.5) 2.498 ms
4 * fra-1-6k.de.eu (94.23.122.209) 98.011 ms *
5 * * *
6 zur-1-6k.ch.eu (94.23.122.146) 19.012 ms * *
7 * * *
8 ch-zrh02a-ra1-xe-3-2-0.aorta.net (84.116.134.21) 22.317 ms 19.183 ms 21.208 ms
9 84.116.202.226 (84.116.202.226) 21.563 ms 21.721 ms 20.907 ms
10 84.116.211.22 (84.116.211.22) 19.681 ms 21.422 ms 21.864 ms
11 * * *
12 * * *
13 * * *
14 * * *
15 * * *
16 * * *
17 * * *
18 * * *
19 * * *
20 * * *
21 * * *
22 * * *
23 * * *
24 * * *
25 * * *
26 * * *
27 * * *
28 * * *
29 * * *
30 * * *

Sur: root@bk0001:~# traceroute 46.140.90.148
traceroute to 46.140.90.148 (46.140.90.148), 30 hops max, 60 byte packets
1 maila.martronic.ch (46.105.55.171) 2997.699 ms !H 2997.648 ms !H 2997.636 ms !H

puis plus rien !

martro
14/11/2014, 14h45
Bonjour,

Voici mon problème: j'ai un un serveur dédiés chez ovh. j'ai installer un serveur Mail Postfix, Amavisd, Mysql, Spamassassin, Dspam, Dovecot avec ce tuto: http://www.starbridge.org/spip/spip.php?article12.

sur quelques quelque dizaine il y a un client qui ne parviens pas à utiliser le pop3, imap, smtp et webmail sont ip 46.14.38.213 avec cet ip il accède a la banque, google, etc. en https.

adresse du serveur (37.187.160.71)

extrait du firewall:
smtpimappop=46.105.55.171
webmailadm=178.32.173.204

# HTTP / HTTPS
iptables -A INPUT -i eth0 -d $webmailadm -p tcp --dport 80 -m state --state NEW,ESTABLISHED -j ACCEPT
iptables -A INPUT -i eth0 -d $webmailadm -p tcp --dport 443 -m state --state NEW,ESTABLISHED -j ACCEPT

#Pour les services mails
iptables -A INPUT -i eth0 -d $smtpimappop -p tcp --dport 25 -m state --state NEW,ESTABLISHED -j ACCEPT
iptables -A INPUT -i eth0 -d $smtpimappop -p tcp --dport 143 -m state --state NEW,ESTABLISHED -j ACCEPT
iptables -A INPUT -i eth0 -d $smtpimappop -p tcp --dport 110 -m state --state NEW,ESTABLISHED -j ACCEPT
iptables -A INPUT -i eth0 -d $smtpimappop -p tcp --dport 995 -m state --state NEW,ESTABLISHED -j ACCEPT
iptables -A INPUT -i eth0 -d $smtpimappop -p tcp --dport 993 -m state --state NEW,ESTABLISHED -j ACCEPT
iptables -A INPUT -i eth0 -d $smtpimappop -p tcp --dport 587 -m state --state NEW,ESTABLISHED -j ACCEPT

le deuxième truc blizzard:

impossible d’envoyer un mail à a.amstutz@lenzlinger.com depuis ce serveur (37.187.160.71)

voici les tests avec telnet depuis plusieurs machines et le test qui ne fonctionne pas sur le serveur de mail:

une piste ?

Test depuis: 37.187.160.71 ns3440634.ip-37-187-160.eu
root@bk0001:~# telnet mx1.lenzlinger.com 25
Trying 46.140.90.148...
telnet: Unable to connect to remote host: No route to host

root@bk0001:~# telnet smtp.worldcom.ch 25
Trying 212.74.176.16...
Connected to smtp.worldcom.ch.
Escape character is '^]'.
220 smtp1.ipworldcom.ch ESMTP
quit
221 smtp1.ipworldcom.ch SMTP closing connection
Connection closed by foreign host.
root@bk0001:~#


#### Test sur: 37.187.129.185 ns316510.ip-37-187-129.eu
root@services:/# telnet mx1.lenzlinger.com 25
Trying 46.140.90.148...
Connected to vk.lenzlinger.com.
Escape character is '^]'.
220 vk.lenzlinger.com ESMTP
quit
221 2.0.0 Bye
Connection closed by foreign host.

root@services:/# telnet smtp.worldcom.ch 25
Trying 212.74.176.17...
Connected to smtp.worldcom.ch.
Escape character is '^]'.
220 smtp2.ipworldcom.ch ESMTP
quit
221 smtp2.ipworldcom.ch SMTP closing connection
Connection closed by foreign host.
root@services:/#


#### Test sur: 37.187.24.236 ns2266750.ip-37-187-24.eu
root@ns4:/etc/init.d# telnet mx1.lenzlinger.com 25
Trying 46.140.90.148...
Connected to vk.lenzlinger.com.
Escape character is '^]'.
220 vk.lenzlinger.com ESMTP
quit
221 2.0.0 Bye
Connection closed by foreign host.

root@ns4:/etc/init.d# telnet smtp.worldcom.ch 25
Trying 212.74.176.16...
Connected to smtp.worldcom.ch.
Escape character is '^]'.
220 smtp1.ipworldcom.ch ESMTP
quit
221 smtp1.ipworldcom.ch SMTP closing connection
Connection closed by foreign host.
root@ns4:/etc/init.d#


#### Test sur 192.168.15.89 -> 192.168.15.200 -> 212.74.132.29
martial@pc-100:~$ telnet mx1.lenzlinger.com 25
Trying 46.140.90.148...
Connected to vk.lenzlinger.com.
Escape character is '^]'.
220 vk.lenzlinger.com ESMTP
quit
221 2.0.0 Bye
Connection closed by foreign host.

martial@pc-100:~$ telnet smtp.worldcom.ch 25
Trying 212.74.176.16...
Connected to smtp.worldcom.ch.
Escape character is '^]'.
220 smtp1.ipworldcom.ch ESMTP is glad to see you!
quit
221 smtp1.ipworldcom.ch SMTP closing connection
Connection closed by foreign host.