OVH Community, votre nouvel espace communautaire.

release 3 Envoi mail impossible depuis client messagerie


jexl
13/11/2014, 11h56
Bon, c'était plus simple que cela.
Rien a voir avec les paramètres postfix que j'ai remis comme à l'origine.
C'est tout simplement le paramétrage Outlook.
Maintenant il faut faire parametre de compte / modifier /parametres supplémentaires /serveur sortant (cocher mon serveur requiert une authentification / options avancées (mettre le port smtp 587) puis utiliser une connexion chiffrée automatique.

voila, un grand merci a Maiko de la hotline qui a pris le temps d'aller jusqu'au bout des choses.
en espérant que cela aide quelqu'un :O)

sloboman
12/11/2014, 01h45
J'ai trouvé le pourquoi du comment :

Microsoft gère la sécurité proprement du coup, c'est à nous de nous adapter (ou d'acheter un certificat validé par une autorité connue de Windows)

J'ai pu envoyer des mails sans problèmes depuis Windows Live Mail sous Windows 7 et Windows Courrier sous Windows 8
(pour thunderbird, ça passe tout seul sans rien modifier nulle part)

Je ne saurai trop vous conseiller d'éviter de modifier des fichiers de conf de vos serveurs sans savoir ce qui peut en résulter...

STARTTLS fait appel au certificat du serveur, vu qu'il est auto signé sur le nom du serveur, il ne valide les connections que sur tonserveur.ovh.net et non smtp.tondomaine.com

Aller sur https://tonserveur.ovh.net avec internet explorer
aller dans les options internet, onglet sécurité, choisir Sites de confiance, cliquer sur sites, cliquez sur ajouter.
Relancer internet explorer, revenir sur https://tonserveur.ovh.net, cliquer dans la barre d''adresse là où c'est en rouge, cliquer sur afficher les certificats, choisir installer un certificat, utilisateur actuel, Placer tous les certificats dans le magasin suivant, Parcourir et choisir Autorités de certification racines de confiance, puis faire ok, suivant, valider si demandé l'importation.

Une fois cette petite procédure - lol - effectuée, vous pouvez envoyer des mails depuis Windows Live Mail ou Windows Courrier en indiquant tonserveur.ovh.net comme serveur smtp.

Sinon utilisez Thunderbird, conseillez le à vos clients, ou valorisez une éventuelle prise en main à distance pour configurer leur bouse sous windows si ils y tiennent

- - - Updated - - -

Et pour ceux qui veulent envoyer du mail via PHP sur la release 3 sans se retrouver dans les spams systématiquement, je prépare un tuto DKIM / PHP release 3

Nowwhat
11/11/2014, 21h14
Citation Envoyé par jexl
...... je fais un mail qui est présent sur la machine, ça part, mais ça passe en spam,
Fait le partir vers ici http://www.mail-tester.com/

jexl
11/11/2014, 20h31
impossible pour moi d'y arriver
la chose étrange, c'est que si je fais un mail qui est présent sur la machine, ça part, mais ça passe en spam, alors que si je fais un mail sur gmail par exemple j'ai mon erreur smtp...
fredlh => si ça marche chez toi, est-ce que tu peux poster tes fichiers master.cf, main.cf et me dire si tu as touché à dovecot ?

fredlh
11/11/2014, 18h31
Bon j'ai désactivé le TLS pour les pour les messages sortants :

-o smtpd_tls_security_level=none
-o smtpd_tls_auth_only=no


ça a l'air de fonctionner.

fredlh
11/11/2014, 18h00
Bonsoir,

même problème que je pensais avoir résolu en ajoutant la ligne suivante dans /etc/dovecot/dovecot.conf

auth_mechanisms = plain login

J'arrive à envoyer un mail mais j'ai un avertissement de sécurité avec demande de valider le certificat à chaque envoi/relevé d’email.

Donc je cherche toujours une solution.

jexl
11/11/2014, 17h27
j'avance un peu, mais je trouve toujours pas de solution.
Voici le message que j'ai dans mes logs :

Code:
Nov 11 18:19:24 nsxxxx dovecot: imap-login: Login: user=, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, mpid=26051, secured

jexl
11/11/2014, 16h54
Bonjour à tous,

Suite au hack des release 2, j'ai du installé une release 3 centos.
dans l'ensemble, tout s'est bien passé.
En revanche, j'ai créé tous les mails qui existaient sous QMAIL via POSTFIX.
l'envoi des mails fonctionne si je passe par Rouncube, en revanche j'ai une erreur si j'utilise Outlook :

Code:
Erreur serveur : '554 5.7.1 : Relay access denied'
dans main.cf j'ai :
Code:
relayhost =
et dans master.cf
Code:
smtp      inet  n       -       n       -       -       smtpd
submission      inet    n       -       -       -       -       smtpd
#587       inet  n       -       n       -       -       smtpd
#  -o smtpd_tls_security_level=encrypt
#  -o smtpd_sasl_auth_enable=yes
#  -o  smtpd_sasl_type=dovecot
#  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
#  -o milter_macro_daemon_name=ORIGINATING
vous voyez ce qu'il manque comme parametre ?
d'avance merci