OVH Community, votre nouvel espace communautaire.

Api Proxmox


InboX
09/11/2014, 12h10
c'est résolu ^^
l'extension dans php.ini c'est mal mis... j'ai pas compris pourquoi vu que j'ai pas touché
Bref il fonctionne le code.

Merci pour ton aide
Cordialement,

InboX
09/11/2014, 11h18
bonjour,

Oui ^^ page blanche quand même je comprend pas
j'ai mal configuré php.ini peut être ou il me manque des librairies

j'ai curl c'est sure après je vois pas il demande rien d'autre le script

NicolasFR
09/11/2014, 07h41
Tu as essayé d'activer les erreurs pour voir où ça pouvait clocher ?

Ajoute
ini_set('error_reporting', E_ALL);
ini_set('display_errors', 'on');
au début de ton fichier (après ton ouverture de balise PHP bien sur)

InboX
08/11/2014, 12h26
Bonjour,

je test l'api de proxmox depuis deux jours mais j'ai un problème
j'ai aucun résultat avec se code savez vous d’où peu venir le soucis ?

Code PHP:
require("./pve2-api-php-client/pve2_api.class.php");

$pve2 = new PVE2_API("blabla.fr""root""pam""*********");
# realm above can be pve, pam or any other realm available.

if ($pve2->constructor_success()) {
    
/* Optional - enable debugging. It print()'s any results currently */
    
$pve2->set_debug(true);

    if (
$pve2->login()) {
        foreach (
$pve2->get_node_list() as $node_name) {
            
print_r($pve2->get("/nodes/".$node_name."/status"));
        }
    } else {
        print(
"Login to Proxmox Host failed.\n");
        exit;
    }
} else {
    print(
"Could not create PVE2_API object.\n");
    exit;

en gros j'ai une page blanche quand je vais sur mon lien...

Merci
Cordialement,