OVH Community, votre nouvel espace communautaire.

Accès Webmin via HTTPS, certificat SSL


youki
14/07/2015, 16h17
Citation Envoyé par janus57
Bonjour,

non cela posera problème avec tous le sites qui utilise encore de vieux certificats 512bits.

Les 1024 sont encore valide (pour le moment) et 2048 c'est recommandé.

Après la question original c'était de savoir pourquoi chrome lui signalait un problème avec son SSL, la réponse était : certificat auto-signé => normal => exception => SSL opérationnel.

Cordialement, janus57
ah ben merci çà fonctionne comme avant "continuez mais il y a des risques"...

janus57
08/11/2014, 23h00
Citation Envoyé par laurentm
Il faut préciser que ce problème se pose avec la dernière version de Firefox pour les webmin dont la clé n'est pas en 2048 (les webmin installés depuis plusieurs années).
Bonjour,

non cela posera problème avec tous le sites qui utilise encore de vieux certificats 512bits.

Les 1024 sont encore valide (pour le moment) et 2048 c'est recommandé.

Après la question original c'était de savoir pourquoi chrome lui signalait un problème avec son SSL, la réponse était : certificat auto-signé => normal => exception => SSL opérationnel.

Cordialement, janus57

laurentm
08/11/2014, 21h30
Il faut préciser que ce problème se pose avec la dernière version de Firefox pour les webmin dont la clé n'est pas en 2048 (les webmin installés depuis plusieurs années).

aronce
08/11/2014, 19h25
Bonjour,
La solution : aller avec Chrome et Webmin sur la configuration SSL, il suffit de régénérer une nouvelle clé en 2048 (c'est le cas par défaut) en précisant le code de pays FR : puis créer une nouvelle clef qui sera alors affichée. Après l'accès par Firefox et internet explorer ne posera plus de problèmes.
Cordialement,
AR

farscape94
06/11/2014, 07h55
Bonjour,
non je n'ai pas de problème de sécurité, le certificat auto-signé correspond à mon besoin pour le moment.
Merci pour cette clarification.

Cordialement.

janus57
05/11/2014, 09h08
Citation Envoyé par farscape94
Bonjour,
Je serais curieux d'avoir une explication, quelle en est la cause ? pas moyen de corriger cela ?
Merci d'avance.
Bonjour,

car c'est un certificat auto-signé (ou self-signed) que tous les navigateur ne considère pas comme sûr car non signé par une CA.

Pour faire simple vous êtes en HTTPS, mais non reconnu comme sûr car signé par votre propre serveur, donc chrome (et d'autre navigateurs) barre le https.

Si vous passez sous firefox le HTTPS sera affiché mais si on regarde en détails on verra "vous avez ajoutés une exception de sécurité pour ce site, la connexion vers ce site est chiffré".
Donc vous serez bien en HTTPS, mais non reconnu de manière officiel par le navigateur.

Est-ce que cela pose un problème de sécurité ? non du moment que votre serveur ne se fait pas hack, si il se fait hack faudra créer un nouveau certificat auto-signé car l'ancien ne sera plus sûr.

Cordialement, janus57

farscape94
05/11/2014, 08h35
Bonjour,
Je serais curieux d'avoir une explication, quelle en est la cause ? pas moyen de corriger cela ?
Merci d'avance.

yves57
04/11/2014, 21h15
même si le symbole https est barré, on est tout de même en https

farscape94
04/11/2014, 20h29
Bonjour,

J'utilise un VPS Classic 2 sous une Release 3 OVH.

Ma problématique tourne autour de HTTPS et des certificats.

1/ Dès que j'essai de me connecter en https sur webmin (https://vpsXXXXXX.ovh.net:10000/) ou phpmyadmin, mon navigateur (Google Chrome sous Windows 8) m'indique que "la connexion n'est pas privée" et un lien vers "paramètres avances" me donne le message suivant:

"impossible de vérifier sur le serveur qu'il s'agit bien du domaine vpsXXXXXX.ovh.net, car son certificat de sécurité n'est pas considéré comme fiable par le système d'exploitation de votre ordinateur. Cela peut être dû à une mauvaise configuration ou bien à l'interception de votre connexion par un pirate informatique" NET::ERR_CERT_AUTHORITY_INVALID

En poursuivant je me connecte mais je ne suis pas en HTTPS !

En allant dans la configuration de webmin "chiffrement SSL" j'ai bien "Activer SSL si disponible ?" = Oui.

Comment activer mon accès en HTTPS pour webmin ?

Merci d'avance pour votre aide.

A bientôt.