OVH Community, votre nouvel espace communautaire.

[SMS] convertir des numéros au format international avec Excel


Charles.A
03/11/2014, 09h51
Bonjour,

La fonction d'envoi de SMS utilise les numéros au format international, voici quelques astuces pour convertir vos fichiers de numéros.

Dans Excel, si vos numéros sont importés en tant que nombre, le premier zéro disparait dans la cellule. Vous pouvez simplement convertir vos numéros en appliquant un format personnalisé :
  1. Click droit sur la cellule,
  2. Click sur Format de la cellule
  3. Click Personnalisée
  4. Saisissez pour la France : +33 #" "##" "##" "##" "##
  5. Click sur ok


Si vos numéros apparaissent avec le zéro, ils sont considérés comme une chaine de caractère, voici une formule pour convertir un numéro stocké dans la cellule A1 :
=SI(ET(NBCAR(A1)=10;GAUCHE(A1;1)="0");CONCATENER(" +33";DROITE(A1;9));"erreur")
-> Si le numéro fait 10 chiffres et qu'il commence par un zéro, alors concaténation de +33 et des 9 derniers chiffres, sinon erreur.

Assurez vous que vos numéros sont dans la 1ere colonne A. (si nécessaire faites un copié, collage spécial en tant que valeur).
Vous n'avez plus qu'à exporter vos numéros au format CSV avec un séparateur en point virgule ;