OVH Community, votre nouvel espace communautaire.

Postfix sur la release 3


bbr18
05/11/2014, 08h50
solution donnée sur le ML Releases
Solution:
- éditer /home/ovh/www/postfixadmin/config.inc.php, trouver la section suivante:

// Default Aliases
// The default aliases that need to be created for all domains.
$CONF['default_aliases'] = array (
'abuse' => 'abuse@',
'hostmaster' => 'hostmaster@',
'postmaster' => 'postmaster@',
'webmaster' => 'webmaster@'
);


commenter la ligne webmaster, et supprimer le virgule a la fin de la ligne
"postmaster", comme ceci:

$CONF['default_aliases'] = array (
'abuse' => 'abuse@',
'hostmaster' => 'hostmaster@',
'postmaster' => 'postmaster@'
# 'webmaster' => 'webmaster@'
);

tu pourras ensuite modifier les alias webmaster@ via l'interface postfixadmin.

Cordialement,
Félix

shark
05/11/2014, 08h37
Bonjour,

Merci pour cette réponse.
J'ai activé l'option et redémarré postfix mais ça ne fonctionne pas.
Je ne vois pas d'options supplémentaire dans l'interface d'admin postfix ...
De plus, l'alias de sous-domaine avait bien été créé en passant par ovhm sans activer cette option.
Je reçois bien les e-mails si j'envois sur adresse@domain.tdl ou sur adresse@alias.tdl.
Par contre, pas moyen de me connecter sur roundcube avec l'alias. Ni en pop d'ailleurs ...

yves57
04/11/2014, 17h22
Il faut éditer ça à présent sous postfixadmin, mais l'option n'est pas activée de départ.

En éditant config.inc.php dans /home/ovh/www/postfixadmin/ il faut éditer la ligne $CONF('alias_control') tu auras accès à ces options

Code:
$CONF('alias_control') = YES;

shark
04/11/2014, 16h13
Personne n'a rencontré ce problème ?

shark
03/11/2014, 09h20
Bonjour,

Sur la release 2, quand je créais un alias de domaine, je pouvais me connecter sur roundcube ou en pop via ces domaines.
Sur la release 3, ça ne fonctionne pas.
Est-ce un comportement normal ?