OVH Community, votre nouvel espace communautaire.

Serveur Bind avec Virtualmin/Webmin et Debian 7


Nowwhat
27/10/2014, 23h47
'Soir,

"nouveau serveur virtuel ", me semble une paramétrage de ton serveur web ....
Or,
listen-on { 127.0.0.1; }
fait partie de la paramétrage de ton DNS.

Disons qu'il est quasiment inutile de paramétrage Apache .... si la ménage coté DNS n'a pas a été fait

N'oublie pas: "Virtualmin/Webmin" ne sont QUE des éditeurs de luxe, façon 'clique' pour éditer des fichiers config des divers services de ton serveur.
Il y bien sur pas mal de vérifications supplémentaires qui sont offert par "Virtualmin/Webmin" mais trafiquer son serveur web ne va pas te mettre ton DNS en place.

D'ailleurs, quand t'as ceci:
listen-on { 127.0.0.1; }
ton DNS ne travaille que en tant que cache local, c'est le paramétrage par défaut si ton serveur n'est pas serveur DNS d'au moins UN nom de domaine.

PS: pour m'amuser j'ai installé WebMin sur mon serveur, pour voir comment il m'offre la possibilité de éditer mes fichiers.
VirtualMin, il faut que je goute encore ....

whynote
27/10/2014, 18h27
Bonjour à tous,

Pour quelle raison bind n'écoute qu'en local lorsque l'on crée un nouveau serveur virtuel ?
Dans le fichier named.conf.options
Code:
listen-on {
		127.0.0.1;
		};
Je pouvais attendre longtemps que le serveur réponde sur un nom de domaine !