OVH Community, votre nouvel espace communautaire.

Config version php via htaccess


hedon
19/10/2014, 09h36
Le problème principal a un peu dévié.
Il est devenu : comment afficher les erreurs
et ça m'aide car ça les affiche.

cavapulser
19/10/2014, 09h15
Bonne nouvelle

C'était quoi le problème principal, en quoi ça t'a aidé (ce dont je me doutais) ?

hedon
19/10/2014, 09h09
Citation Envoyé par cavapulser
Oui, c'est désactivé.
Sinon, pour les erreurs, ça devrait pouvoir t'aider :
https://www.ovh.com/fr/pdf/hosting/g...e_page_blanche
Et comment !!!
Ça fonctionne du feu de Dieu
Grand merci

(j'ai quelques sites chez OVH qui roulent tout seul depuis un ou deux lustres ; alors les nouveautés 2014, ça me surprend un peu

cavapulser
18/10/2014, 17h24
Citation Envoyé par hedon
J'ai bien l'impression qu'il est désactivé

Je sais que c'est dangereux pour la sécu () mais lorsqu'il s'agit de transférer un site php4, ça peut aider d'autant qu'aucune erreur n'est affichée (et que je ne sais pas comment faire)
Oui, c'est désactivé.
Sinon, pour les erreurs, ça devrait pouvoir t'aider :
https://www.ovh.com/fr/pdf/hosting/g...e_page_blanche

hedon
18/10/2014, 16h20
J'ai bien l'impression qu'il est désactivé

Je sais que c'est dangereux pour la sécu () mais lorsqu'il s'agit de transférer un site php4, ça peut aider d'autant qu'aucune erreur n'est affichée (et que je ne sais pas comment faire)

cavapulser
18/10/2014, 15h56
Register_Globals est un paramètre dégradé, et qui peut être dangereux pour la sécurité.
Je crois qu'il est maintenant désactivé chez OVH.

hedon
18/10/2014, 11h05
J'ai un mutualisé 2014.

Je dois migrer un site qui a été fait sous php 4 et voulais savoir si tout fonctionnait (et avec un peu de flemme j'aurai même laissé en l'état).

Merci donc pour l'info (plus de php 4 en 2014).
Je me suis donc mis en php 5.3 (qui accepte encore les session_register —que je n'ai pas le temps de changer car je suis dans l'urgence)

Mon gros problème chez OVH c'est que les erreurs ne sont plus affichées par défaut et il semble, à la lecture de ce post qu'on ne puisse pas configurer depuis un htaccess.

D'autre part SetEnv REGISTER_GLOBALS 1 dans le htaccess ne fonctionne pas.
Voila

buddy
18/10/2014, 09h20
Bonjour,

PHP 4 n'est pas dispo avec le .ovhconfig : https://www.ovh.com/fr/g1207.configurer-php-web
et ce n'est plus dispo sur les mutualisé 2014 : http://guide.ovh.com/Php4ChezOvh
tu as quel "mutualisé" ?

Pourquoi mettre un site en PHP 4 ? il n'est plus maintenu depuis 2008 ( http://developers.slashdot.org/story...e-announcement ) et sera surement bientôt enlevé ... c'est dommage de partir là dessus en 2014 ...

hedon
18/10/2014, 09h05
Hum, je reviens pour votre aide
Il faut que je teste mon site en php 4.
J'ai modifié ovhconfig en mettant app.engine.version=4 mais ça ne fonctionne pas et je n'ai même plus accès à mon site.
J'ai donc viré ovhconfig du dossier racine /
Dans www/ j'a créé un htaccess avec :
SetEnv PHP_VER 4
SetEnv REGISTER_GLOBALS 0

Options -Indexes
ErrorDocument 404 erreur.html
mais je me retrouve en version 5.4.30

Quoi se passe ?

hedon
17/10/2014, 10h23
Oui oui oui, ça fonctionne

cavapulser
17/10/2014, 10h17
J'avais seulement oublier de remettre le point !!!!!
J'adore le "seulement"...
Petite cause, grands effets.

Oui, honte à toi
Le principal, c'est que ça marche maintenant, en espérant que ça soit le cas.

hedon
17/10/2014, 10h13
3 fois Oooops !!
Oui je suis sur une version 2014 (depuis une semaine)
Le problème est que lorsque j'ouvrais le fichier depuis le serveur OVH, les modifs n'étaient pas prises en compte
Du coup j'avais enlevé le point précédent ovhconfig pour le balancer sur mon bureau d'où j'ai pu effectuer la modif etenregistrer avant de le replacer à la racine / du site
J'avais seulement oublier de remettre le point !!!!!

Merci Cavapulser pour la piste
Honte à moi

cavapulser
17/10/2014, 09h53
Tu es vraiment sur une offre 2014 ?
Il y a bien un point devant le nom de fichier ovhconfig, sans extension ?
Il est bien édité avec un outil "fiable" comme NotePad++ ?
Après édition, le fichier est bien transféré sur le serveur (FileZilla le demande) ?

hedon
17/10/2014, 09h40
Parce que j'ai essayé
:
Je change app.engine.version=5.3
j'enregistre
mais quand je réouvre il est toujours en 5.4

Daniel60
16/10/2014, 19h08
Citation Envoyé par hedon
Oui mais impossible à change
Pourquoi ?

cavapulser
16/10/2014, 18h52
Citation Envoyé par hedon
Oui mais impossible à changer
Du coup je l'ai viré et j'ai replace un SetEnv PHP_VER 5_3 dans mon htaccess, en vain
Je ne sais pas trop à quoi ça sert.
Je voudrais simplement utiliser la version 5.3 car cette dans cette version qu'a été créé un site que je voudrais migrer.
Je viens de faire le test...
En mettant ça dans mon .ovhconfig :
app.engine=php
app.engine.version=5.3
http.firewall=none
environment=production
Je bascule bien en version 5.3.28
Bon, je repasse en 5.6.0

PS : J'ai désactivé ces paramètres en les mettant en commentaires dans le .htaccess, afin d'éviter tout conflit avec le .ovhconfig qui est normalement prioritaire.
Options -Indexes
# SetEnv PHP_VER 5
# SetEnv REGISTER_GLOBALS 0

hedon
16/10/2014, 18h25
Oui mais impossible à changer
Du coup je l'ai viré et j'ai replace un SetEnv PHP_VER 5_3 dans mon htaccess, en vain
Je ne sais pas trop à quoi ça sert.
Je voudrais simplement utiliser la version 5.3 car cette dans cette version qu'a été créé un site que je voudrais migrer.

Daniel60
16/10/2014, 17h50
Il existe peut-être un .ovhconfig en racine /

hedon
16/10/2014, 17h40
Bonjour
Je viens d'acquerir un espace chez OVH

mon fichier htaccess (à la racine de www) contient ceci :
SetEnv PHP_VER 5
SetEnv REGISTER_GLOBALS 0
Options -Indexes
ErrorDocument 404 erreur.html
Mais lorsque je fais un php info j'obtiens toujours la version 5.4.30

J'ai essayé toutes les méthodes :
SetEnv PHP_VER 5_3
SetEnv PHP_VER 5_4

pas fichier htaccess pour être automatiquement en php 4 (selon le guide ovh)
et même SetEnv PHP_VER 4

Rien n'y fait.
J'ai manqué quelque chose ?

Merci pour votre aide