OVH Community, votre nouvel espace communautaire.

Urgent - Site Inaccessible même après restauration suite erreur de syntaxe


Hiboulot
07/10/2014, 15h29
Salut Fred;

OVH t'offre la possibilité de restaurer ton espace (tous les fichiers de ton site) à j-1, j-3, etc...

Le lien du manuel https://www.ovh.com/fr/hebergement-w...on_fichier.xml

fred.dp
07/10/2014, 00h17
Citation Envoyé par Gaston_Phone
Supprimez index.html qui donne "test" et qui ne sert à rien.
Fait.. même si pour le moment il est toujours disponible.

Pour info si je tape "prohacktive.be" dans la barre d'adresse le serveur répond correctement... mais pas lorsque je tape "www.prohacktive.be".

Je réessayerai demain.. mais je crains fortement un bug côté serveur.

Merci de votre aide en tout cas. Une bonne soirée,

Frédéric.

Gaston_Phone
06/10/2014, 23h47
Supprimez index.html qui donne "test" et qui ne sert à rien.

fred.dp
06/10/2014, 23h31
Citation Envoyé par Gaston_Phone
C'est quand même curieux. De mon cote http://www.prohacktive.be/ est OK.

Désactive l'option dont je ne me rappelle plus le nom, mais qui fait de multiples de copies dans le monde entier.
Fait. Désactivé l'option, et je pointe désormais vers une IP Anglaise.

Je test en "ligne de commande" pour éviter des problèmes de cache, le serveur me renvoie toujours l'ancienne page index.html:

Code PHP:
GET HTTP/1.1
Host
www.prohacktive.be
User
-AgentMozilla/5.0 (Windows NT 6.1WOW64rv:32.0Gecko/20100101 Firefox/32.0
Accept
text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: fr,fr-fr;q=0.8,en-us;q=0.5,en;q=0.3
Accept-Encoding: gzip, deflate
Connection: keep-alive 
Code PHP:
HTTP/1.1 200 OK
Server
Apache
Cache
-Controlmax-age=1209600
Expires
Mon20 Oct 2014 18:16:29 GMT
Vary
Accept-Encoding
Content
-Typetext/html
Content
-Length92
Accept
-Rangesbytes
Date
Mon06 Oct 2014 21:25:18 GMT
Age
11329
Connection
keep-alive
X
-Geovarn19.rbx5
X
-Geo-Port1015
X
-CacheableCacheablematched cache

<meta http-equiv="refresh" content="0"url="http://www.prohacktive.be/index2/index.html" /> 
Avez-vous un conseil à me donner? Là je suis a court d'idées.. Mais bon Je vais laisser passer la nuit..

Gaston_Phone
06/10/2014, 23h05
C'est quand même curieux. De mon cote http://www.prohacktive.be/ est OK.

Désactive l'option dont je ne me rappelle plus le nom, mais qui fait de multiples de copies dans le monde entier.

fred.dp
06/10/2014, 22h59
Citation Envoyé par Gaston_Phone
Essaie avec ton Smartphone en 3G (pas en Wifi).
Et pendant ce temps reboote ton modem (avec 2 minutes d'arrêt).
Idem ..

Même en allant sur google translate (translate.google.com) et insérant mon site "www.prohacktive.be"
Google fait pareil.. redirections en boucle en essayant de récupérer le contenu de ma page..

Je ne sais vraiment pas quoi faire.. j'ai l'impression qu'il y a un bug côté OVH ou des caches géographiques ou encore autre chose..

Gaston_Phone
06/10/2014, 22h45
Essaie avec ton Smartphone en 3G (pas en Wifi).
Et pendant ce temps reboote ton modem (avec 2 minutes d'arrêt).

fred.dp
06/10/2014, 22h42
Citation Envoyé par Gaston_Phone
Chez moi www.prohacktive.be est OK.
Vide le cache de ton navigateur.

- - - Mise à jour - - -

Par contre :
  • Il te manque la balise meta description
  • Il te faut utiliser l' URLRewinting avec des adresses de pages plus documentées.
Merci Gaston...

J'ai vidé tous mes caches, sur tous mes appareils et navigateurs ( explorer, firefox ) j'ai fais pareil sur mon iPhone (safari)
J'ai toujours le même soucis même problème sur tous mes devices même après suppression des caches. j'ai aussi vidé le géo cache dans le manager.. Rien y fait..

Aucune idée de ce que cela pourrait être?

J'ai fais ça à la va vite entre 2 rendez vous.. ca m'apprendra.

Gaston_Phone
06/10/2014, 22h33
Chez moi www.prohacktive.be est OK.
Vide le cache de ton navigateur.

- - - Mise à jour - - -

Par contre :
  • Il te manque la balise meta description
  • Il te faut utiliser l' URLRewinting avec des adresses de pages plus documentées.

fred.dp
06/10/2014, 22h23
Bonjour à tous,

J'ai fais une mauvaise manip en voulant insérer une redirection temporaire. J'avais mis un fichier index.html à la racine www contenant une erreur syntaxique (doubles quotes en trop dans un meta refresh). Ce qui a entraîné une redirection infinie:



Depuis lors, plus moyen d'accéder mon site avec l'URL racine : www.prohacktive.be

Je retombe sur la même page erronnée, malgré une restauration, suppression des caches etc. Le site marche lorsque j’atteins la page d'accueil standard www.prohacktive.be/index.php

J'ai également créé un nouveau fichier index.html mais cela n'y fait absolument rien.. l'ancien fichier est toujours retourné par le serveur.

Merci pour votre aide précieuse car mon site web n'est plus accessible et je ne sais pas comment régler le problème.

Frédéric.