OVH Community, votre nouvel espace communautaire.

SPAM Email, VPS reverse DNS - PTR et nom de serveur.


Saradimi
26/09/2014, 09h24
Citation Envoyé par Saradimi
Finalement, ce que j'ai fait a fonctionné. Donc plus de pb de DKIM et une note de 9.7 au test .
Par contre, toujours ce foutu message qui me dit "Votre reverse DNS ne correspond pas avec votre domaine d'envoi." et mes mails qui tombent tous le temps en spam sur gmail.
Slt,
Suite et (presque) fin, je vient de réessayer et ce coup ci, le reverse dns semble bien pris en compte sur www.mail-tester.com. J'obtient la note de 10/10 ... Par contre, les mails tombent toujours inéxorablement dans les spams sur gmail
Je pense que je vais lacher l'affaire pour gmail car là, je ne vois pas ce que je peux faire de plus...
En tt cas merci pour ton aide.

Saradimi
25/09/2014, 08h22
Au fait pourrais-tu m'indiquer comment tu as fait pour régler l'histoire du DKIM stp.
Je me rend compte que tout ce qui touche aux DNS me donne des boutons
Ce n'est pas mon métier de base, je suis dév. PHP...

[EDIT] J'avance un peu, apparemment, à création d'un domaine depuis webmin sur mon VPS, un champs TXT est automatiquement ajouté avec le nom default._domainkey.mondomaine.fr et contenant v=DKIM1; k=rsa; p=MIGfMA etc......
Le pb est que mes DNS sont gérer par OVH et que j'ai uniquement fait des redirection A vers l'IP de mon vps.
Du coup, j'ai créé côté DNS OVH un champs TXT similaire à celui créé automatiquement sur mon VPS.
Est-ce que jusqu'ici j'ai bon ?
Faut-il faire d'autres manip ?
Désolé, je sais, je suis relou

[EDIT 2] Finalement, ce que j'ai fait a fonctionné. Donc plus de pb de DKIM et une note de 9.7 au test .
Par contre, toujours ce foutu message qui me dit "Votre reverse DNS ne correspond pas avec votre domaine d'envoi." et mes mails qui tombent tous le temps en spam sur gmail.

Saradimi
24/09/2014, 22h58
Tu utilises quoi toi pour tester ?
Moi j'utilise http://www.mail-tester.com/
(j'ai enfin mon 9 / 10 ! en route pour le 10 !)
Pareil !

Normalement la vérif se fait sur le HELO je crois ...
http://remote.12dt.com/ te donne bien ton reverse ?
Oui, c'est bien ce que je trouve bizarre !
Merci quand même

Jack600
24/09/2014, 22h30
Tu utilises quoi toi pour tester ?
Moi j'utilise http://www.mail-tester.com/
(j'ai enfin mon 9 / 10 ! en route pour le 10 !)

Normalement la vérif se fait sur le HELO je crois ...
http://remote.12dt.com/ te donne bien ton reverse ?

Si t'as configuré ton reverse chez OVH, normalement t'as rien d'autre à faire !
C'est peut-être aussi ton site de test qui n'est pas terrible.

l'IP V6 je ne l'ai pas configuré tiens ... j'ai juste fait l'IP V4, mais tu m'y fais penser, et je vais aussi faire la V6 au cas où.

Saradimi
24/09/2014, 21h50
Citation Envoyé par Jack600
Je viens de tester sur un autre serveur,
Ça semble fonctionner.
1) j'ai donc un sous domaine serv1.test.com
2) j'ai configuré le reverse pour que l'ip donne bien serv1.test.com
3) dans POSTFIX j'ai changé :
- dans « mydestination » j'ai ajouté mon reverse serv1.test.com
- dans « myhostname » j'ai CHANGÉ pour serv1.test.com

Redémarrer POSTFIX, renvoyer un courriel au testeur de courriel

Ça semble réglé !
En régularisant tout ce qui concerne le courriel, je suis passé du score de 2.3 (j'en voit qui rigole !) à 8.3 !
Prochaine étape : configurer DKIM !

En ce qui me concerne, le reverse fut pris instantanément en compte.
Pour toi ça devrait fonctionner aussi !

Ayant ce retour sur expérience je vais passer aux autres serveurs ...
Nan jsuis deg !
jai toujours cette ligne : "Votre reverse DNS ne correspond pas avec votre domaine d'envoi."
avec les valeurs suivante :

IP: xx.xxx.xx.xxx (Mon IP)
HELO: reverse mon.adresse.com (Celle que j'ai mise dans postfix et comme rDNS)
rDNS: 149.ip-xx-xxx-xx.eu (Ancienne adresse)

Chez toi la ligne rDNS indique bien la valeur que tu as mise comme rDNS ?
Sur le manager, j'ai changer le rDNS pour l'adresse ipv4, dois je faire de même pour l'adresse ipv6 ?

Merci d'avance

Jack600
24/09/2014, 21h27
Je viens de tester sur un autre serveur,
Ça semble fonctionner.

1) j'ai donc un sous domaine serv1.test.com
2) j'ai configuré le reverse pour que l'ip donne bien serv1.test.com
3) dans POSTFIX j'ai changé :
- dans « mydestination » j'ai ajouté mon reverse serv1.test.com
- dans « myhostname » j'ai CHANGÉ pour serv1.test.com

Redémarrer POSTFIX, renvoyer un courriel au testeur de courriel

Ça semble réglé !
En régularisant tout ce qui concerne le courriel, je suis passé du score de 2.3 (j'en voit qui rigole !) à 8.3 !
Prochaine étape : configurer DKIM !

En ce qui me concerne, le reverse fut pris instantanément en compte.
Pour toi ça devrait fonctionner aussi !

Ayant ce retour sur expérience je vais passer aux autres serveurs ...

Saradimi
24/09/2014, 20h38
Citation Envoyé par Jack600
Regarde son fichier de config POSTFIX, il semble en parler :
http://www.tutoriels-video.fr/instal...ix-et-courier/
En effet, le hostname figure bien en début de fichier sur /etc/postfix/main.cf.
J'ai tenté le coup mais je me suis rendu compte que le reverse dns n'était pas encore pris en compte. La propagation prend apparemment pas mal de temps.
Je testerait plus tard mais si tu as d'autres pistes, je suis preneur.

EDIT :
Ce qui est quand même bizarre, c'est que tous les tests DNS me disent bien que mon ip est associé au nom de domaine que j'ai spécifié pour mon reverse DNS alors que sur le site http://www.mail-tester.com, ils me disent que mon adresse IP est encore associée à l'ancien domaine de mon reverse DNS (XXX.ip-XX-XXX-41.eu).

Jack600
24/09/2014, 19h58
Regarde son fichier de config POSTFIX, il semble en parler :
http://www.tutoriels-video.fr/instal...ix-et-courier/

Jack600
24/09/2014, 19h51
Justement, pour l'instant je ne sais pas.

En fait ce que j'essaie de trouver, c'est si c'est POSTFIX qui inclue le nom de machine dans l'en tête du mail, où un autre système.
Si c'est POSTFIX, j'imagine qu'il y a moyen de moyenner via sa config, le souci c'est que je ne peux pas me donner le luxe d'un test sur la machine dont je m'occupe.

J'ai cherché dans les guides, sur Google, j'obtiens des réponses plutôt, mais c'est plutôt flou, et / ou visiblement incomplet.

Me reste plus que ce forum ...

Si je trouve, je donnerai la solution.

Saradimi
24/09/2014, 17h25
Même souci que toi.
Apparemment, si j'ai bien compris, il faut bien configurer le reverse DNS en lui indiquant un sous domaine qu'on aurait créé en amont mais après faut-il changer le hostname complet ???

Jack600
24/09/2014, 17h18
Bonjour,

Les protections contre les spam incluent une vérification du serveur de courriel.

Ainsi, si j'envoie un courriel avec la machine vpsxxxxx.ovh.net et l'ip : 5.5.5.5 le recipiendaire va vérifier que 5.5.5.5 renvoie bien vers vpsxxx.ovh.net.

Le problème, c'est que les VPS livrés ont comme nom vpsxxx.ovh.net
Et le reverse et configuré sur un domaine type : 111.ip-5-196-6.eu

Du coup : pour une même IP, le reverse envoie 111.ip-5-196-6.eu alors qu'on envoie avec vpsxxx.ovh.net
111.ip-5-196-6 diffèrent de vpsxxx.ovh.net pour une même IP déclarée ... donc le score de spam grimpe !

J'ai bien sûr tenté de configuré le reverse sur vpsxxx.ovh.net, ce qui me semblait d'une logique et d'un simplicité évidente ... mais le manager m'indique qu'il n'est pas possible d'utiliser les adresses ovh.net !!!

Alors là, je ne comprends pas.

On nous livre un serveur avec une distribution (release 3) prête à l'emploi, mais avec des données techniques qui, de base, font monter le score de spam ! Incompréhensible !

Faut-il se taper le changement de nom de machine au complet ?
J'ai installé justement la release pour ne pas avoir à toucher la config ... changer le nom de machine me semble pour le moins complexe.

Avez-vous une autre solution ?

Merci d'avance !

Jack