OVH Community, votre nouvel espace communautaire.

VPS R3 et fonction mail php KO


ridhas
23/07/2015, 16h23
Bonjour,
Sur un vps classic 2 en release 3, la fonction mail de php bloque la page.
Sur webmin / configuration de webmin / sending email, pas de blocage mais l'email n'arrive jamais, même pas en spam.
Postfix fonctionne apparement comme j'arrive à récupérer les emails avec pop3
J'ai pensé à un blocage et j'ai exécuté ce code en ssh;

chown postfix.postfix -R /var/lib/postfix
/etc/init.d/postfix restart

mais ça ne change rien
quelqu'un aurait eu ce soucis ?

Saradimi
24/09/2014, 15h24
Je précise ma demande...

J'ai lu ici et là qu'il fallait modifier son reverse dns pour que tout soit niquel.
J'ai bien vu que l'on pouvait faire cette opération depuis le manager mais là je patauge
J'ai le choix entre 2 ip à configurer et je ne sait pas laquelle choisir,
l'étape suivante, on me demande d'indiquer le nouveau reverse dns et là je ne sait pas quoi mettre !!!
Si quelqu'un peut m'aider ce serait trop supeeeer

Saradimi
24/09/2014, 14h22
Je me répond à moi même :
C'était tout bête, postfix n'était pas démarré à cause d'une histoire de permission
Voici ce que j'ai fait :
Code:
chown postfix.postfix -R /var/lib/postfix
/etc/init.d/postfix restart
Par contre pour le moment, les mails finissent systématiquement dans les spams.

Saradimi
24/09/2014, 10h16
Bonjour à tous

Je viens d'installer une version toute fraiche de la release 3 sur mon VPS classic et jusqu'ici, tout se déroule sans problème.
Par contre je rencontre un souci d'envoi de mail et là, je sèche un peu !
Pour vérifier que ce n'était pas mon script qui était en cause, j'ai tenté d'envoyer un mail grace ce script, j'ai bien le message me disant : "*** CR_Mail=1 - Mail envoyé" mais rien n'arrive dans ma boite.
J'ai été vérifier les log dans /var/log/maillog mais aucune trace de l'envoi, les derniers messages sont les suivants :
Sep 24 11:03:54 vpsXXXXXX clamd[781]: SelfCheck: Database status OK.

Par avance merci.