OVH Community, votre nouvel espace communautaire.

Réglage pb CHMOD


franckhelin
08/09/2014, 12h01
Merci à toi.

Daniel60
07/09/2014, 20h49
Le contenu est tout simplement
Code:
Options -Indexes
A écrire avec un codage ASCII et avec des fins de ligne en "line feed"* et à placer en racine, ou dans www, ou dans le répertoire qui va bien.

* voir "Rédaction .htaccess" dans ma signature

franckhelin
07/09/2014, 20h24
Aucun message d'erreur. Mais j'ai un doute sur le contenu exact de htaccess, peux-tu me communiquer un modèle ?

Concernant les permissions, je t'assure que je n'ai aucun message d'erreur et que tout les fichiers sont lus ! En fait, je n'applique les permissions qu'aux répertoires et non aux fichiers... Du coup je ne sais plus trop que faire.

Daniel60
07/09/2014, 18h22
Citation Envoyé par franckhelin
Bonjour,

Je souhaiterai faire en sorte qu'aucun utilisateur ne puisse explorer mes répertoires (c'est le réglage par défaut chez OVH !) J'ai essayé de placer un htaccess à la racine contenant simplement : Options -Indexes mais ça ne fonctionne pas.
Cela fonctionne habituellement. Un message d'erreur ?
J'ai trouvé une solution qui si elle fonctionne bien pose peut-être problème. J'ai simplement modifié les permissions de certains répertoire en décochant 'lire' pour "tous le monde" Impossible donc d'explorer un répertoire avec un tel réglage (CHMOD 701), mais cela peut-il poser des problèmes ? Que me conseillez-vous ?
Si on ne peut pas lire tes fichiers, il n'apparaitrons pas sur le site et feront apparaitre une erreur. Ce n'est pas conseillé.
En remplacement du .htaccess tu peux aussi créer un fichier index.html vide ans le répertoire voulu. Cela empêche aussi d'en lister le contenu.

franckhelin
07/09/2014, 16h46
J'ai oublié de vous demandez si cela peut empêcher les robots de faire leur travail d'indexation des pages . Merci

franckhelin
07/09/2014, 16h14
Bonjour,

Je souhaiterai faire en sorte qu'aucun utilisateur ne puisse explorer mes répertoires (c'est le réglage par défaut chez OVH !) J'ai essayé de placer un htaccess à la racine contenant simplement : Options -Indexes mais ça ne fonctionne pas.

J'ai trouvé une solution qui si elle fonctionne bien pose peut-être problème. J'ai simplement modifié les permissions de certains répertoire en décochant 'lire' pour "tous le monde" Impossible donc d'explorer un répertoire avec un tel réglage (CHMOD 701), mais cela peut-il poser des problèmes ? Que me conseillez-vous ?

Merci par avance.