OVH Community, votre nouvel espace communautaire.

disparition de mes menus affichés par des includes


TTBC
02/11/2014, 22h30
doublon : répondu ici http://forum.ovh.com/showthread.php?...ionner-en-2014

jeanfran
30/08/2014, 13h20
bonjour,

En début d'année, lors du renouvellement de mon hébergement pour mon site amourerotique.com, les menus gauche et droite de mes pages (appelés par des include) ont cessé de s'afficher. Sur la page d'accueil, j'ai mis le menu en dur mais sur les autres pages, je n'ai pas eu le courage de le faire.

Or, je viens de renouvelé mon hébergement pour mon site : www.gnose-de-samael-aun-weor.fr et je constate le même problème. mon menu de gauche n'apparait plus. et j'ai énormément de page sur le site et les différents menus appelés par des includes n'apparaissent plus.

je n'ai pas modifié le code des pages des 2 sites, ça faisait plusieurs années que les menus s'affichaient correctement jusqu'à récemment.
j'ai contacté le service technique d'ovh. ils me disent qu'ils n'y sont pour rien, qu'ils ne constatent aucun dysfonctionnement sur mes sites.
pourtant je leur ai expliqué la différence.

je ne pense pas qu'il y ait de hasard, il se passe quelque chose lors du renouvellement de mes hébergements qui pose problème à la fonction include.

sur mon site : http://http://www.gnose-de-samael-aun-weor.fr/
le fichier index.php faisait afficher un menu dans la colonne de gauche par une fonction include qui pointait sur un fichier menugauche.html :

Code PHP:
include ("http://www.gnose-de-samael-aun-weor.fr/menugauche.html"); ?>
que se passe-t-il ? y a t-il un problème de changement d'environnement pour les sites d'OVH en 2014, dois-je modifier mon code.
les deux sites ont été suspendu quelques jours avant que je renouvelle l'hébergement, ont ils été mis sur d'autres serveurs...
je ne comprends rien.

Pouvez-vous m'aider à résoudre le problème ? voyez-vous des pistes ?
merci de vous être intéressé au sujet.