Page 2 sur 2 PremièrePremière 12
Affichage des résultats 11 à 14 sur 14

Discussion: problème changement dns vers kimsufi

  1. #11
    Membre
    Date d'inscription
    February 2008
    Messages
    104

    Re : problème changement dns vers kimsufi

    Merci donc je modifie ce même fichier comme ceci :

    Code:
    options {
        /* make named use port 53 for the source of all queries, to allow
             * firewalls to block all ports except 53:
             */
    
        // query-source    port 53;
    
        /* We no longer enable this by default as the dns posion exploit
            has forced many providers to open up their firewalls a bit */
    
        // Put files that named is allowed to write in the data/ directory:
        directory                "/var/named"; // the default
        pid-file                 "/var/run/named/named.pid";
        dump-file                "data/cache_dump.db";
        statistics-file          "data/named_stats.txt";
       /* memstatistics-file     "data/named_mem_stats.txt"; */
        allow-transfer {"none";};
        listen-on port 53 { any; };
    };
    Est ce correct ?
    Mes zones sont dans le même fichier c'est normal ?
    Elles sont toutes comme ceci :
    Code:
    zone "truc.fr" {
            type master;
            file "/var/named/truc.fr.db";
    };
    Magix cms, le cms optimisé pour le référencement
    et création de site internet

  2. #12
    Membre
    Date d'inscription
    December 2007
    Messages
    9 548

    Re : problème changement dns vers kimsufi

    Nope, relis le message de Nowwhat

    - soit tu n'as qu'un "allow-transfer" dans options qui doit autoriser le serveur
    DNS esclave/secondaire à venir se synchroniser.

    - soit tu laisses un "allow-transfer { "none"; };" dans options mais alors il faut
    autoriser le transfert de zone pour le serveur DNS esclave/secondaire dans chaque zone individuellement.

  3. #13
    Membre
    Date d'inscription
    January 2007
    Messages
    6 587

    Re : problème changement dns vers kimsufi

    Change
    Code:
    allow-transfer { "none"; };
    pour
    Code:
    allow-transfer { localnets; 213.186.33.199; };
    notify yes;
    Précision:
    "localnets" = correspond à toute adresse IP sur tout réseau auquel le système local est connecté
    "213.186.33.199" = ns.kimsufi.com

    Maintenant, dès que t'as redémarré bind, il va autoriser le sync entre lui-même et son esclave DNS, ns.kimsufi.com.
    24 heures max après tu sera bon.

  4. #14
    Membre
    Date d'inscription
    February 2008
    Messages
    104

    Re : problème changement dns vers kimsufi

    Merci j'ai appliquer la méthode, le zone check renvoi des avertissements, le premier je le connais mais pas le deuxième :

    L'hôte ne répond pas aux requêtes ICMP (présence d'un pare-feu?)

    ns.kimsufi.com/***********


    a: [TEST envoie de mél au "postmaster"]: Mail error (Timeout from SMTP server)

    générique
    EDIT: j'ai créer l'adresse postmaster et tout fonctionne bien
    Merci à vous deux, je garde précieusement cette procédure pour mes deux autres VPS
    Dernière modification par gtraxx ; 06/05/2012 à 23h13.
    Magix cms, le cms optimisé pour le référencement
    et création de site internet

Page 2 sur 2 PremièrePremière 12

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •