PDA

Voir la version complète : ipv6 sous FreeBSD : activation au redémarrage



hpcharles
27/10/2012, 17h04
Hello, j'ai un kimsufi sous FreeBSD 8.3.

J'ai activé ipv6 en suivant les indications du guide : http://guides.ovh.com/Ipv4Ipv6 donc ajouté :

ipv6_enable="YES"
ipv6_network_interface="em0"
ipv6_ifconfig_em0="2001:41d0:1:93b4::1 prefixlen 64"

Après avoir fait "rtsol -d em0", l'interface est up et tout va bien. Après un reboot, pas moyen d'accéder en ipv6 (en ssh).

J'ai essayé d'ajouter un ipv6_defaultrouter au /etc/rc.conf : nada

Le seul truc qui fonctionne est de refaire rtsol après chaque reboot.

Une idée pour rendre ça permanent ?

Faut il utiliser rtadvd(8) comme indiqué dans la bible ?
http://www.freebsd.org/doc/fr/books/handbook/network-ipv6.html

Cordialement

Daixiwen
28/10/2012, 10h38
J'ai eu pas mal de soucis aussi à configurer correctement l'ipv6 sous FreeBSD chez OVH, et je n'ai pas trop compris pourquoi. rtadvd ne marche pas du tout (si je me souviens bien ce n'est plus utilisé chez OVH mais ils n'ont pas mis à jour le guide).
J'ai fini par ajouter mon propre script au démarrage qui ajoute la route vers la passerelle à la main. (rtsol ne marchant pas non plus chez moi)

hpcharles
29/10/2012, 00h04
En fait rtsol fonctionne, mais qq minutes seulement. Au bout d'un moment, la route disparait et la machine devient inaccessible de l'extérieur.

Je n'ai pas réussi à mettre une route "manuelle" en ajoutant un ipv6_defaultrouter= dans le rc.conf.

Il y a d'autres façons de faire ?

Daixiwen
29/10/2012, 10h07
ipv6_defaultrouter ne marche pas chez moi non plus, peut-être une histoire de prefixlen qui devrait être à 56 au lieu de 64, mais je n'ai pas vraiment creusé la question. J'ai juste fini par mettre mon propre script. Voici mon script /usr/local/etc/rc.d/myip6route:

#!/bin/sh

# PROVIDE: myip6route
# REQUIRE: NETWORK
# BEFORE: SERVERS
#
# Add the following lines to /etc/rc.conf to enable myip6route:
#
# myip6route_enable="YES"

. /etc/rc.subr

name=myip6route
rcvar=myip6route_enable

start_cmd=start_cmd
stop_cmd=stop_cmd

start_cmd()
{
route add -inet6 2001:41d0:2:14ff:ff:ff:ff:ff -interface re0
route change -inet6 :: 2001:41d0:2:14ff:ff:ff:ff:ff
}

stop_cmd()
{
}

# read settings, set default values
load_rc_config $name
: ${myip6route_enable="NO"}

run_rc_command "$1"Remplace ce qui est en rouge l'ip6 de la passerelle, et le nom de ton interface. Ajoute myip6route_enable="YES" dans /etc/rc.conf et redémarre ou exécute /usr/local/etc/rc.d/myip6route start

Ceci dit je ne suis pas sûr que ca marche si on tente de contacter une autre ip6 qui est sur le même /56. Si quelqu'un a une ip6 dans la zone 2001:41d0:2:14:: je veux bien faire un essai :)