PDA

Voir la version complète : correspondant ne m'entends pas



kidy71
27/01/2009, 16h36
Bonjour a tous
Je cherche une solution a mon problème de téléphone SIP
Je suis gérant de ma société de conseils aux entreprises et je viens de prendre de nouveaux locaux. Pour ma téléphonie j'ai décide de me lancer dans la voix IP et j'ai choisi la solution Ip Centrex de chez OVH mon hébergeur. Ils m'ont donne un nouveau n° avec les codes d'accès. Ayant d'autres choses a penser et a faire j'ai utilisé ma ligne avec le logiciel x-lite et cela marchait relativement bien. Dernièrement j'ai pris la décision de m'équiper d'un vrai téléphone. j'ai donc acheter un Thomson st 2022 supportant le protocole SIP. J'ai appliquer les paramètres (qui sont ok dixit OVH) Mon problème est que je peux utiliser ma ligne normalement (appels rentrants et sortants sans problèmes) sauf que mes correspondants ne m'entendent pas alors que moi je les entends très bien.. Le vendeur du tel m'a dit que cela vient du paramétrage de la NAT du routeur adsl. Je suis incompétent pour ces bidouillages. Ma question est donc Est ce que quelqu'un connait ces paramètres ? Mon FAI est DartyBox
Un grand merci d'avance
Cordialement

kidy71
28/01/2009, 15h50
Bonjour a tous
Je cherche une solution a mon problème de téléphone SIP
Je suis gérant de ma société de conseils aux entreprises et je viens de prendre de nouveaux locaux. Pour ma téléphonie j'ai décide de me lancer dans la voix IP et j'ai choisi la solution Ip Centrex de chez OVH mon hébergeur. Ils m'ont donne un nouveau n° avec les codes d'accès. Ayant d'autres choses a penser et a faire j'ai utilisé ma ligne avec le logiciel x-lite et cela marchait relativement bien. Dernièrement j'ai pris la décision de m'équiper d'un vrai téléphone. j'ai donc acheter un Thomson st 2022 supportant le protocole SIP. J'ai appliquer les paramètres (qui sont ok dixit OVH) Mon problème est que je peux utiliser ma ligne normalement (appels rentrants et sortants sans problèmes) sauf que mes correspondants ne m'entendent pas alors que moi je les entends très bien.. Le vendeur du tel m'a dit que cela vient du paramétrage de la NAT du routeur adsl. Je suis incompétent pour ces bidouillages. Ma question est donc Est ce que quelqu'un connait ces paramètres ? Mon FAI est DartyBox
Un grand merci d'avance
Cordialement

Re bonjour
Darty viens de me contacter pour me dire que mes parametres routeur ne posait aucun probleme a mon compte SIP Tout etait bon pour utiliser mon tel correctement
Donc maintenant je me demande si cela ne viens pas du tel lui même
Si d'autres personne avait deja eu ce probleme ?
Merci

molux
28/01/2009, 17h07
Bonjour,

Je suis pas expert, mais voici quelques pistes :

* Concernant le Thomson ST 2022, je ne l'utilise pas moi même mais beaucoup de collaborateurs ou partenaires l'utilisent quotidiennement sans problème, il semble que ce soit un téléphone IP très correcte.

* Est ce que tu as fais tes essais sur plusieurs type de ligne ?
(RTC, VoIP et Mobile, est ce que tu constate le même problème ?)

* Concernant ton routeur, est ce que tu as fais des redirections de port ésotérique pour des applications qui avaient besoin de venir de l'extérieur sur ton LAN ?

* J'espère que je ne me trompe pas, mais à priori il y'a quand même une plage de port à ouvrir sur ton routeur me semble t'il, puisque c'est de l'UDP qui est envoyé sur ton IP externe sur un port donné, il faut que ton routeur sache a quelle IP de ton reseau local l'envoyer (et sur quel port)

* As tu vérifié la configuration de ton firewall ? laisse t'il passé l'UDP sur les ports qui vont bien ?

* Dernier truc bête, désolé, tu n'a pas coupé le micro de ton Thomson ?

* As tu la possibilité de tester un autre téléphone IP ?

* Depuis as tu restesté avec ton XLite ?

Si non, il te fraudait mettre ton Thomson (temporairement hein !) sur un "Hub" tout simple, et sur ce même "Hub" connecter un PC avec Ethereal mon M$ ou faire un tcpdump si c'est un linux. Ces outils permettent de voir les trames qui passe (ou ne passe pas), ça permet d'avoir des pistes de réflexion plus précises.

Bon courage

Molux

chrisdec
28/01/2009, 17h25
J'ai déjà eu et j'ai toujours ce problème.
J'ai acheté un pap2T chez OVH et depuis le 9 janvier je peux appeler mais mon correspondant ne m'entend pas. Les appels entrants ne fonctionnent pas.
OVH prétend que le problème est dans mon installation et n'en démord pas.
J'ai ouvert un ticket n°33564 et je suis toujours en rade.
FAI orange et routeur très bien configuré.

Tout cela me semble confirmer que le bug est bien chez OVH.

skyman
28/01/2009, 17h46
Les appels entrants ne fonctionnent pas.
OVH prétend que le problème est dans mon installation et n'en démord pas.
J'ai ouvert un ticket n°33564 et je suis toujours en rade.
FAI orange et routeur très bien configuré.
tu es sur qu'il est correctement configuré (juste pour confirmer, pas taper) ?
Pour les appels entrants, il faut paramétrer le nat pour le port SIP (5060) et pour les ports RTP (il me semble que chez OVH c'est 10000 a 20000) qui doit renvoyer sur l'adresse ip du pap2T.
Si l'appel ne rentre pas, c'est le nat du port SIP qui est souvent mal configuré.
Il faut aussi que le pap2T soit en IP fixe pour que le nat puisse faire son travail.


Tout cela me semble confirmer que le bug est bien chez OVH.
pas si sur, mais c'est un avis personnel.

oles@ovh.net
28/01/2009, 18h04
> J'ai ouvert un ticket n°33564 et je suis toujours en rade.
> FAI orange et routeur très bien configuré.

je vais regarder. la livebox reecrit les packets SIP mais avec
un telephone ça ne devrait pas poser de problemes. avec 2 postes
les communications passent pas sur le reseau local.

oles@ovh.net
28/01/2009, 18h12
kidy71 <kidy71.3moklb@no-mx.forums.ovh.com> a écrit:
>

juste pour info generale: tous le matos envoyés par Ovh est
configuré de la même maniere pour tous les clients. même
configuration, exactement la même. nous avons testé durant
plusieurs mois les confs et tout se passe bien. il y a un
ISP en Belgique où l'IP Centrex semble poser des problemes,
il y a un problemes de RTP lorsqu'on passe un coup de fil
entre 2 postes telephones qui se trouvent derriere la même
livebox (mais ça passe, juste ça va vers l'infra chez ovh
et ça revient au lieu de passer sur le reseau local). sinon
rien à signaler. tout fonctionne. nous avons plus de 1600
postes telephoniques envoyés chez les clients et qui sont
up dans nos stats de telephones connectés sur notre infra.
on a de l'Orange, SFR, Free, Numericable, Belgacom, Telenet,
DT, etc. Notre infra sait passer à travers les NAT, maintenir
les ports ouverts avec keepalive NAT etc etc.

maintenant, si vous avez un probleme,
- et si vous avez le matos acheté chez ovh, c'est dans 90% un
probleme de firewall ou d'autres problemes de routages chez
le client (genre un double NAT, le routage via un Windows etc).
dans 10% des cas, ça peut être la ligne ADSL utilisé à 100%
et les communications passent mal pendant que vous telechagez
vos DIVx ;)
- vous avez votre propre telephone SIP, et donc ce n'est pas
Ovh qui l'a configuré; dans 80% c'est un problemes de confs
18% un probleme de firewall et 2% une connexion ADSL surchargée.

Amicalement
Octave

chrisdec
28/01/2009, 18h45
tu es sur qu'il est correctement configuré (juste pour confirmer, pas taper) ?
Pour les appels entrants, il faut paramétrer le nat pour le port SIP (5060) et pour les ports RTP (il me semble que chez OVH c'est 10000 a 20000) qui doit renvoyer sur l'adresse ip du pap2T.
Si l'appel ne rentre pas, c'est le nat du port SIP qui est souvent mal configuré.
Il faut aussi que le pap2T soit en IP fixe pour que le nat puisse faire son travail.


pas si sur, mais c'est un avis personnel.


Un conseil avisé est toujours le bienvenu.
Je refais un tour du propriétaire sur le nat.

Mais le pap2T est configuré en DHCP.

chrisdec
28/01/2009, 18h57
DU NOUVEAU sous le soleil de Roubaix.

J'ai rebooté le pap2T et cette fois tout marche correctement : sortant dans les deux sens et entrant dans les deux sens. Un vrai miracle après 19 jours d'attente, 25 messages sur le forum et à peu près autant sur le ticket.

Je n'ai rien changé de mon coté, mais on aimerait bien savoir ce que OVH a fait.

Christophe

oles@ovh.net
28/01/2009, 19h22
chrisdec <chrisdec.3mqlqo@no-mx.forums.ovh.com> a écrit:
>
> DU NOUVEAU sous le soleil de Roubaix.
>
> J'ai rebooté le pap2T et cette fois tout marche correctement : sortant
> dans les deux sens et entrant dans les deux sens. Un vrai miracle après
> 19 jours d'attente, 25 messages sur le forum et à peu près autant sur le
> ticket.
>
> Je n'ai rien changé de mon coté, mais on aimerait bien savoir ce que
> OVH a fait.

si tu dis qui tu es, je pourrai te dire si on a changé qqchose pour toi.

chrisdec
28/01/2009, 21h17
chrisdec <chrisdec.3mqlqo@no-mx.forums.ovh.com> a écrit:
>
> DU NOUVEAU sous le soleil de Roubaix.
>
> J'ai rebooté le pap2T et cette fois tout marche correctement : sortant
> dans les deux sens et entrant dans les deux sens. Un vrai miracle après
> 19 jours d'attente, 25 messages sur le forum et à peu près autant sur le
> ticket.
>
> Je n'ai rien changé de mon coté, mais on aimerait bien savoir ce que
> OVH a fait.

si tu dis qui tu es, je pourrai te dire si on a changé qqchose pour toi.

OK je t'ai envoyé un mail sur l'adresse oles@ovh.net

skyman
29/01/2009, 09h56
DU NOUVEAU sous le soleil de Roubaix.

J'ai rebooté le pap2T et cette fois tout marche correctement : sortant dans les deux sens et entrant dans les deux sens. Un vrai miracle après 19 jours d'attente, 25 messages sur le forum et à peu près autant sur le ticket.

Je n'ai rien changé de mon coté, mais on aimerait bien savoir ce que OVH a fait.

Si, tu as changer quelquechose de ton coté (je cite) :

Mais le pap2T est configuré en DHCP.
Il faut probablement que tu le mette en IP fixe ou que tu parametre ton serveur DHCP (souvent le routeur ou la box) pour qu'il affecte toujours la meme IP a ton pap2T.

Je ne dit pas que c'est ca, mais c'est une piste, car j'ai eu le meme soucis au debut a cause du DHCP qui n'affectait pas la meme adresse tout le temps a mon poste et il arrivait, en plus, qu'il affecte l'ip du poste sur un autre autre poste (pas telephone en plus). :eek:
Apres parametrage de mon routeur, plus de soucis.

oles@ovh.net
29/01/2009, 10h10
chrisdec <chrisdec.3mqhhb@no-mx.forums.ovh.com> a écrit:
>
> J'ai déjà eu et j'ai toujours ce problème.
> J'ai acheté un pap2T chez OVH et depuis le 9 janvier je peux appeler
> mais mon correspondant ne m'entend pas. Les appels entrants ne
> fonctionnent pas.
> OVH prétend que le problème est dans mon installation et n'en démord
> pas.
> J'ai ouvert un ticket n°33564 et je suis toujours en rade.
> FAI orange et routeur très bien configuré.
>
> Tout cela me semble confirmer que le bug est bien chez OVH.

non. le bug n'est pas chez Ovh, mais sur ton routeur linksys.
le routeur transforme les paquets sip. ce qui est GRAVE !!!
il reecrit ce que le pap2t envoit vers notre central. c'est
donc NORMAL que ça ne marche pas normalement. car du coup
pap2t derriere fait n'importe quoi, il envoie la voix
vers les mauvais routeurs résultat: la voix n'arrive pas.
tu as aussi un peu touché a la conf de son pap2t. nous l'avons
vu puisqu'on s'est connecté sur le pap2t ...

ceci dit, nous avons changé la configuration de ton pap2t à
distance pour essayer de faire passer la voix autrement.
aucun feedback de ta part depuis. marche ? marche toujours pas ?
rien en face. il y a encore quelqu'un ?

pour se plaindre sur le forum, plusieurs fois de suite comme
si on avait un probleme generale, il y a toujours des gens.
lorsqu'on demande de nous aider pour identifier le probleme,
il n'y a plus personne. on demande pas grand chose pour commencer
votre identifiant. plus si possible. toi tu as les traces tcpdump
et tu ne veux pas nous les donner. on aurait gagner du temps
en les ayants. à la place nous avons dû mettre la capture puis
attendre le jour J où tu aurais bien voulu lancer un appel
telephonique ... et là quand le probleme est reglé mais il faut
la confirmation plus personne en face.

bref, tous ces threads inutiles prouvent encore une fois que
les problemes de chaque client sont differents et ne sont pas
generales. il y avait encore 1 semaines 7-8 personnes qui ralaient
sur le forum en generant plus de 90 postes (!!) et là il reste
1 ou 2 cas très particulier encore à fixer.

oles@ovh.net
29/01/2009, 16h40
cherchepas <cherchepas.3mrvun@no-mx.forums.ovh.com> a écrit:
>
> oles@ovh.net;246385 Wrote:
>> ceci dit, nous avons changé la configuration de ton pap2t à distance
>> pour essayer de faire passer la voix autrement.
>> aucun feedback de ta part depuis. marche ? marche toujours pas ?
>> rien en face. il y a encore quelqu'un ?
>>
>> pour se plaindre sur le forum, plusieurs fois de suite comme
>> si on avait un probleme generale, il y a toujours des gens.
>>
>
> Oles est fatigué, il n'a pas vu que l'intéressé a eu une réaction du
> type "cela fonctionne enfin" :
> http://forum.ovh.com/showpost.php?p=246232&postcount=10

encore 40 posts pour 1 probleme. oui c'est fatiguant.

ctc
29/01/2009, 18h00
<rep a Chrisdec>

Bjr,

je te confirme (si besoin) ce qu'a dit Octave, il n'y a pas besoin d'un quelconque parmetrage de routage.
j'ai fonctionné avec un modem-routeur alcatel , avec pap2t direct, pap2t par asterisk, softphone direct, softphone par asterisk, et idem apres avoir changé de routeur (Dlink maintenant)
Des fois, j'ai pas de registration (hier apres midi par exemple, jusqu'a ce matin) puis ca refonctionne sans toucher a ma config.

J'ai juste un pb de qualité voix sortante quand appel sortant. hachage.
J'entends toujours bien les interlocuteurs, en entrant comme sortant.

Pb de qos, codecs, mais tres chiants a mettre au point.

a plus

chrisdec
29/01/2009, 18h47
> OVH prétend que le problème est dans mon installation et n'en démord
> pas.
> J'ai ouvert un ticket n°33564.
> FAI orange et routeur très bien configuré.
> Tout cela me semble confirmer que le bug est bien chez OVH.


Quand oles fatigué lui toujours mal réfléchir.



>"non. le bug n'est pas chez Ovh, mais sur ton routeur linksys."


Toujours difficile d'admettre que le bug est chez soi, on préfère dire qu'il est chez l'autre. Orgueil d'informaticien. Je rectifie pour te faire plaisir:
Tout cela semble confirmer que le bug est dans le logiciel utilisé par OVH.



"le routeur transforme les paquets sip. ce qui est GRAVE !!!"
"il reecrit ce que le pap2t envoit vers notre central".


Ben non, mon routeur ne fait que du NAT : Network Address Translation. Par contre, il y a 13 hops dans le traceroute que j'ai envoyé (voir ticket 33564) dont deux routeurs OVH susceptibles de transformer les paquets sip !!!!!






"tu as aussi un peu touché a la conf de son pap2t."


A la demande d'Alexandre du support OVH voir ticket 33564.





" nous l'avons vu puisqu'on s'est connecté sur le pap2t ...


Ben voyons, faut pas se gêner. C'est quand même une PROPRIETE PRIVEE.





"ceci dit, nous avons changé la configuration de ton pap2t à
distance pour essayer de faire passer la voix autrement."


Oui, vous avez changé le numéro du port SIP/SDP en 5070 et configuré le serveur sipbackup.ovh.net.
Alexandre du support OVH m'avait déjà demandé cela mais avec le port 5061.




"aucun feedback de ta part depuis. marche ? marche toujours pas ?
rien en face. il y a encore quelqu'un ?"


Faux, j'ai envoyé un feedback dans les 15 minutes.





"pour se plaindre sur le forum, plusieurs fois de suite comme
si on avait un probleme generale, il y a toujours des gens.
lorsqu'on demande de nous aider pour identifier le probleme,
il n'y a plus personne. on demande pas grand chose pour commencer
votre identifiant. plus si possible."


C'est pas à moi qu'il faut dire ça Octave. C'est contre-productif.





"toi tu as les traces tcpdump
et tu ne veux pas nous les donner. "


Attention, j'ai dit que je ne PEUX PAS les donner. J'avais fourni les entêtes de trace (voir ticket 33564), de plus je les avais commentées car le support avait besoin d'une petite formation. Il n'a même pas lu ce que j'avais envoyé et m'a réclamé les traces complètes que je n'avais plus... Il fallait donc que je recommence, intéressant la relation avec le client.

Ton client n'est pas un employé OVH disponible 24/7.....
Un conseil, lis le ticket 33564 d'abord.




"on aurait gagner du temps
en les ayants. à la place nous avons dû mettre la capture puis
attendre le jour J où tu aurais bien voulu lancer un appel
telephonique ..."


Parce que c'est pas son boulot?





"et là quand le probleme est reglé mais il faut
la confirmation plus personne en face."


J'ai confirmé que ça marche dans les 15 minutes, mais je ne considère pas le problème réglé.





>"bref, tous ces threads inutiles prouvent encore une fois que
les problemes de chaque client sont differents et ne sont pas
generales."


Ces threads ont au moins une utilité : tu y réponds.
J'ai cherché à régler le problème par un ticket. Ce qui est la voie normale, j'ai appelé le support technique (qui est très cher pour un coup de téléphone à mon avis j'ai du y laisser 3 ou 4 euros et j'ai pas pris mon pied....).
Pour commencer, le support m'a dit d'appeler le 126 pendant 3 jours... C'est agaçant, non?




il y avait encore 1 semaines 7-8 personnes qui ralaient
sur le forum en generant plus de 90 postes (!!) et là il reste
1 ou 2 cas très particulier encore à fixer.


Moi, j'ai du en générer 25, et j'ai essuyé quelques injures du genre "grande gueule, barre-toi", sympa le forum OVH. Plus les réponses au support, à peu près 6 heures de travail, à qui j'envoie la facture?

En conclusion, j'ai testé l'offre téléphonique OVH ........

Christophe alias 0033974534411

chrisdec
29/01/2009, 19h47
Si, tu as changer quelquechose de ton coté (je cite) :

Il faut probablement que tu le mette en IP fixe ou que tu parametre ton serveur DHCP (souvent le routeur ou la box) pour qu'il affecte toujours la meme IP a ton pap2T.

Je ne dit pas que c'est ca, mais c'est une piste, car j'ai eu le meme soucis au debut a cause du DHCP qui n'affectait pas la meme adresse tout le temps a mon poste et il arrivait, en plus, qu'il affecte l'ip du poste sur un autre autre poste (pas telephone en plus). :eek:
Apres parametrage de mon routeur, plus de soucis.


Merci Skyman. la piste est intéressante.

Mais l'adresse de mon pap2T est restée la même depuis le début (le 9 janvier): une adresse locale en 192.168.. même quand je reboote. En fait mon réseau ne change pas souvent.

Le protocole sip/sdp prévoit le cas adresse locale avec le champ VIA.
On établit la connexion en SIP/SDP pour l'adresse locale 192.168.. VIA l'adresse IP publique, celle donnée par le FAI.
Ensuite, on passe en RTP pour la conversation avec des ports qui ne sont pas les ports SIP.
Quand un des deux raccroche, c'est en SIP/SDP que ça se passe.

Je suppose que le problème est quand l'adresse change au milieu d'une conversation, la demande de raccroché parvient à la mauvaise adresse.

Christophe.

chrisdec
29/01/2009, 21h49
A cherchepas,


Cela ne fonctionne pas avec les paramètres standard sip.ovh.net:5060 mais cela fonctionne avec sipbackup.ovh.net:5070=> c'est bien un problème de configuration chez OVH, ils faut qu'OVH ait des paramètres spécifiques pour que cela fonctionne avec ta configuration (ton papt, ton routeur et/ou modem ADSL) ....



Oui, c'est exactement cela.



Cela me fait penser au début du SIP de FreeADSL, un jour ils avaient déployé sur leur infrastructure interne une mise à jour qui n'était pas compatible avec certains SIP des clients et pour que cela fonctionne, il fallait changer le port jusqu'à la correction du problème.


Intéressant.



Je sais pas pourquoi, mais mais je penche toujours pour le ptime ....


Pourquoi pas, mais peux-tu en dire plus sur le ptime.

Selon Octave, c'est un problème SIP mal routé. Mais je ne le pense pas. en effet:
SIP sert à initialiser la transaction : par exemple A appelle B
A- Je suis machin et je voudrais appeler truc
B- ne quittez pas
B- ça sonne chez truc et vous pouvez entamer le dialogue en RTP avec les paramètres suivants.
A- OK pour les paramètres.

Ensuite on passe en RTP bi-directionnel sur des ports qui en général sont au-dessus de 10000, rien à voir avec les ports SIP habituels.

Ensuite quand un des deux raccroche, c'est le SIP qui est utilisé alors que le point à point RTP est toujours actif :
B- Ici truc, Je voudrais arreter la conversation avec machin.

Et à partir de là le port RTP est désactivé et les quelques trames RTP qui continuent reçoivent un message ICMP destination unreachable.

Bien, donc mon problème n'était pas lié à SIP, la connexion était bien effectuée, j'entendais mon correspondant, donc les trames RTP arrivaient bien jusqu'au pap2T. De même les trames RTP partaient de mon pap2T et sortaient sur le réseau, je l'ai vérifié. Cependant, mon correspondant n'entendait rien.
Ce sont des paquets RTP qui passaient à la trappe quelque part entre chez moi et le relais de voix OVH. Et pas dans mon routeur, et rien à voir avec SIP.
"Relais de voix" j'ai compris que c'est ainsi qu'ils appellent la machine qui fait l'interface entre la VOIP et le réseau téléphonique classique.

Entre chez moi et le relais de voix OVH, il doit bien y avoir une quinzaine de routeurs......

Le problème est compliqué parce qu'en principe un routeur doit simplement router, c'est à dire toucher uniquement aux adresses IP.
Mais maintenant pratiquement tous les routeurs font du packet mangling, c'est à dire qu'ils touchent au contenu des paquets, et ça c'est GRAVE comme dit Octave, et il a raison. C'est un peu comme si la poste modifiait les textes écrits sur les cartes postales.

Allez j'arrête là sinon je vais écrire un roman.

Christophe.

oles@ovh.net
30/01/2009, 02h00
> Cela ne fonctionne pas avec les paramètres standard sip.ovh.net:5060
> mais cela fonctionne avec sipbackup.ovh.net:5070=> c'est bien un
> problème de configuration chez OVH, ils faut qu'OVH ait des paramètres

non. ça veut dire que tu as un routeur ADSL pourri qui REECRIT les
packets SIP au lieu de les FORWARDER. il suffit de changer le port
de 5060 vers n'importe quoi (par exemple 5070) pourqu'il arrete
de REECRIRE. ton routeur ADSL est configuré pour réecrire les packets
destinés au port 5060 vers un truc qui ne fonctionne pas. change
le routeur ou reconfigure le pourqu'il arrete de reecrire les packets
et le probleme s'arretera. à défaut de ne pas savoir le configurer
tu peux autiliser sipbackupovh.net:5070.

donc c'est un probleme chez vous et pas chez Ovh.

oles@ovh.net
30/01/2009, 02h04
> Selon Octave, c'est un problème SIP mal routé. Mais je ne le pense pas.

pourtant c'est évident. tu peux faire toutes les demostraction possible,
la preuve logique est devant tes yeux: ton routeur ADSL reecrit les packets
SIP pour foutre la merde dedans. il est bete ton routeur: il suffit que le
packet soit destiné au port 5060 pourqu'il fout le bordel dans les packets.
tu changes le port de destination: plus de probleme. tu remets vers 5060
à nouveau le probleme. ecoute ce qu'on te dit, arrete de crier à l'incompetance
et relis ce qu'on te dit puis reflechis 2 secondes. c'est pas le 1er probleme
comme ça qu'on a. pour toi c'est le 1er, il faut un peu de temps pourque
tu l'acceptes, mais avant toi on en a eu 14-18 clients comme toi et on a
déjà trouvé l'origine du probleme et la solution.

chrisdec
30/01/2009, 05h28
> Selon Octave, c'est un problème SIP mal routé. Mais je ne le pense pas.

pourtant c'est évident. tu peux faire toutes les demostraction possible,
la preuve logique est devant tes yeux: ton routeur ADSL reecrit les packets
SIP pour foutre la merde dedans. il est bete ton routeur: il suffit que le
packet soit destiné au port 5060 pourqu'il fout le bordel dans les packets.
tu changes le port de destination: plus de probleme. tu remets vers 5060
à nouveau le probleme. ecoute ce qu'on te dit, arrete de crier à l'incompetance
et relis ce qu'on te dit puis reflechis 2 secondes. c'est pas le 1er probleme
comme ça qu'on a. pour toi c'est le 1er, il faut un peu de temps pourque
tu l'acceptes, mais avant toi on en a eu 14-18 clients comme toi et on a
déjà trouvé l'origine du probleme et la solution.


Ne t'énerve pas Octave.
Bon, j'admets que je suis opiniâtre, mais mon but n'est pas de crier à l'incompétence et j'ai toujours écouté ce qu'on me dit. Mais si j'estime que ce qu'on me dit n'est pas correct, on peut en discuter calmement, non?

Ce n'est pas un problème de port SIP parce que les communications s'établissaient correctement sur 5060 ou 5061.
Ensuite, j'entendais mon correspondant et lui ne m'entendait pas (là c'est en protocole RTP sur des ports > 10000).
Et j'avais bien le signal du raccroché (c'est en SIP).

Bonne journée. Cool.
Christophe.

sim@ovh.net
30/01/2009, 09h11
Mais si j'estime que ce qu'on me dit n'est pas correct, on peut en discuter calmement, non?

Ce n'est pas un problème de port SIP parce que les communications s'établissaient correctement sur 5060 ou 5061.


As tu regarder les traces SIP que je t'ai envoyé ?

On envoie l'ordre a ton PAP2t d'envoyer la voix vers l'ip 91.121.129.2.
Le pap2t recoie l'ordre de l'envoyer a 91.121.129.17 et le fait.

Sur le port 5070, plus personne ne met son nez dans les trames SIP.

chrisdec
30/01/2009, 10h17
As tu regarder les traces SIP que je t'ai envoyé ?

On envoie l'ordre a ton PAP2t d'envoyer la voix vers l'ip 91.121.129.2.
Le pap2t recoie l'ordre de l'envoyer a 91.121.129.17 et le fait.

Sur le port 5070, plus personne ne met son nez dans les trames SIP.


Octave aime qu'on se présente, moi aussi.

Je suppose que vous êtes quelqu'un du support technique.
Dans ce cas vous avez regardé les traces que je vous avais envoyé. Sur ces traces, mon pap2T reçoit la REQUETE d'envoyer sur 91.121.129.2 et il l'envoie sur 91.121.129.2.
Bien sûr, vous pouvez toujours dire que j'ai modifié les traces, mais moi aussi je peux dire que vous avez modifié les traces.....

Christophe

oles@ovh.net
30/01/2009, 19h48
chrisdec <chrisdec.3mtn00@no-mx.forums.ovh.com> a écrit:
>
> sim@ovh.net;246672 Wrote:
>> As tu regarder les traces SIP que je t'ai envoyé ?
>>
>> On envoie l'ordre a ton PAP2t d'envoyer la voix vers l'ip
>> 91.121.129.2.
>> Le pap2t recoie l'ordre de l'envoyer a 91.121.129.17 et le fait.
>>
>> Sur le port 5070, plus personne ne met son nez dans les trames SIP.
>
>
> Octave aime qu'on se présente, moi aussi.
>
> Je suppose que vous êtes quelqu'un du support technique.
> Dans ce cas vous avez regardé les traces que je vous avais envoyé. Sur
> ces traces, mon pap2T reçoit la REQUETE d'envoyer sur 91.121.129.2 et il
> l'envoie sur 91.121.129.2.
> Bien sûr, vous pouvez toujours dire que j'ai modifié les traces, mais
> moi aussi je peux dire que vous avez modifié les traces.....

mon timeout a ecoulé. j'ai donné l'origine du probleme et la
solution. le reste c'est ton probleme.

chrisdec
30/01/2009, 21h51
mon timeout a ecoulé. j'ai donné l'origine du probleme et la
solution. le reste c'est ton probleme.

"la preuve logique est devant tes yeux: ton routeur ADSL reecrit les packets
SIP pour foutre la merde dedans"


Oui, pourquoi pas.

Mais je n'ai PAS de routeur ADSL. D'ailleurs, on ne route pas l'ADSL.
ADSL signifie asymetric digital subscriber loop, c'est la couche physique.

Avant de faire des hypothèses, relisez le ticket 33564.

Christophe alias 0033974534411

oles@ovh.net
30/01/2009, 22h06
> Mais je n'ai PAS de routeur ADSL. D'ailleurs, on ne route pas l'ADSL.
> ADSL signifie asymetric digital subscriber loop, c'est la couche
> physique.

je suis impressioné.

rowes
30/01/2009, 22h44
Je suppose que vous êtes quelqu'un du support technique.
@ chrisdec : Oles et le patron OVH

jwhosting
30/01/2009, 23h23
D'ailleurs, on ne route pas l'ADSL.
ADSL signifie asymetric digital subscriber loop, c'est la couche physique.


impressionant !!!

chrisdec
31/01/2009, 09h17
Nous sommes donc bien d'accord, le problème ne vient pas de mon routeur ADSL.

Christophe alias 0033974534411

chrisdec
31/01/2009, 15h20
Je regrette de devoir insister.

A la question :
le problème ne vient pas de mon routeur ADSL.
Sommes-nous d'accord?

Vous répondez par oui ou par non ?

Christophe alias 0033974534411

chrisdec
02/02/2009, 15h37
Allo
Mon correspondant m'entend-il?

chrisdec
03/02/2009, 16h39
Keep Alive.

chrisdec
03/02/2009, 22h13
Depuis la version 2.2, le firewall linux est inclus dans le noyau et configuré avec ipchains puis iptables depuis la version 2.4.
Voir à ce sujet l'excellent article :
http://fr.wikipedia.org/wiki/Netfilter

Et aussi
http://fr.wikipedia.org/wiki/Pare-feu

Qui introduit les pare-feu applicatifs parfois appelés ALG (applicative level gateway). Les ALG sont faciles à construire sur la base de netfilter. Et c'est un avantage pour la sécurité.
Certains ont tendance à accuser les ALG de perturber le protocole SIP, mais comme d'habitude il s'agit d'une mauvaise utilisation.
Voir
http://forum.ovh.com/showpost.php?p=247745&postcount=9

Le NAT (network address translation) traduction d'adresses réseau permet entre autres à plusieurs équipements d'un réseau local d'utiliser une seule adresse IP publique.
Pour cela, il faut garder une trace des appels locaux vers l'internet. C'est ce qu'on appelle parfois stateful, en fait qui gardent la mémoire des connexion ou encore connexion tracking, conntrack.
On ne peut pas garder ces traces indéfiniment, il est donc nécessaire de leur associer une limite temporelle. Avec des protocoles comme http, cela ne pose aucun problème, un temps de l'ordre de la minute suffit. Mais dans une application de type téléphone, c'est un gros problème : il faut que la connexion soit ouverte en permanence pour le cas où un appel doit entrer chez le client. Tout ce que l'on a trouvé c'est d'envoyer des keep alive.

Le cirpack envoie des messages au client pour éviter que la nat se "referme".

De la meme façon, dans le sens client vers serveur, le pap2T envoie des NAT keep alive sous la forme de messages Notify. Ces messages n'ont pas lieu d'être dans le sens client vers serveur et s'il n'y a pas un message Subscribe auparavant.
Donc dès la réception du notify, le serveur renvoie un message d'erreur.
Et on s'aperçoit que cela suffit à maintenir les nat dans les deux sens.
Le cirpack keep alive ne sert à rien.

kidy71
12/02/2009, 13h43
Bonjour a tous
Pour vous dire que j'ai trouvé la solution a mon problème depuis longtemps (désolé de ne pas répondre plus tôt j'avais oublié ce forum) J'ai modifié la longueur des millisecondes du codec G729 de 10 a 20ms et maintenant cela marche très bien Voila si cela peut servir
Cordialement

chrisdec
13/02/2009, 09h37
Ne serait-il pas plus simple que OVH communique à ces clients les réglages nécessaires ?


Il s'agit vraiment d'incompétence de la part d'OVH, j'ai un pap2T de chez OVH qui a reçu les préréglages d'OVH effectués par OVH et qui présentait le même défaut: marche que dans un sens.
OVH m'a expliqué que c'était mon "routeur ADSL !!!" qui posait problème.
Je n'ai pas eu la patience d'attendre, j'ai résilié.
Merci pour le tuyau, il me reste un pap2t qu'OVH ne veut pas me rembourser.

dioms
30/07/2009, 09h51
Bonjour tout le monde,

Merci Kidy71 pour l'astuce du G729, j'étais en train de m'arracher les cheveux :p

Par contre, ce qui est lourd, c'est les 2 pages de renvois de balle pour savoir qui est en tort...